Zmienne środowiskowe


(Dualvzz) #1

Witam. Mój problem polega na tym, że gdy uruchamiam jakikolwiek plik instalacyjny to pojawia mi się komunikat: System nie mógł znaleźć opcji środowiska, która została wprowadzona. 

Napiszę jeszcze, że odpowiedzi szukałem już na innych forach, ale nic mi nie pomogło. Próbowałem również odzyskać system ale windows nie znalazł żadnych punktów przywracania.


(system) #2

http://traxter-online.net/zmienne-srodowiskowe-windows-domyslne-wartosci-przenoszenie/


(Dualvzz) #3

Zmiennych nie da się ustawić normalnie, ponieważ nie można włączyć zaawansowanych opcji systemu.

Wyświetlą się komunikat, że system nie może odnaleźć pliku.


(Atis) #4

Odszukaj i uruchom plik:

%windir%\System32\SystemPropertiesAdvanced.exe


(Dualvzz) #5

Pliku nie da się uruchomić.


(system) #6

Ciekawe czy wiersz poleceń da się odpalić, powinno, wtedy ręcznie komendą set można zmienne wprowadzać.


(Dualvzz) #7

Da się uruchomić, aczkolwiek nic mi nie pomogło przywrócenie zmiennych ręcznie za pomocą cmd. 

Zmienne są już włączone, lecz problem z plikami instalacyjnymi nadal istnieje. Po odczekaniu ok. 10 minut po włączeniu jakiegokolwiek pliku instalacyjnego exe pojawia się komunikat o treści: “<ścieżka pliku> System nie mógł znaleźć opcji środowiska, która została wprowadzona.”

 

EDIT: Po bardzo ciężkich dwutygodniowych zmaganiach udało mi się naprawić system. Aby naprawić problem, wystarczy uruchomić system w trybie awaryjnym, odszukać w folderze System32 plik SystemPropertiesAdvanced i ustawić zmienną windir=C:\Windows. Bardzo dziękuję wszystkim za pomoc, temat można zamknąć :slight_smile: