Adobe-air i e-pity lub jakaś alternatywa do rozliczenia podatkowego za 2017 rok


(pocolog) #1

Czy komuś udało się zainstalować nową wersję e-pity na Linuksie? U mnie wyskakuje błąd, bo nie mogę zaktualizować adobe-air, który został porzucony na tym systemie. Ostatnią wersję, jaką znalazłem to bodajże 2.6, ale to nie wystarcza e-pitom.
Wiem, że można złożyć deklarację online przez stronę internetową, ale ja wolę mieć na dysku historię wysłanych deklaracji.


(Razi) #2

Możesz te deklaracje pobrać i trzymać pliki .epit u siebie, PDFy też tam się dało ściągać.


(krystian3w) #3
https://airdownload.adobe.com/air/lin/download/latest/AdobeAIRInstaller.bin
http://www.e-deklaracje.gov.pl/files/dopobrania/e-dek/app/e-DeklaracjeDesktop.air

http://www.finanse.mf.gov.pl/documents/766655/1196444/instrukcjeLinux.pdf


(pocolog) #4

Mam już e-pity i wolałbym przy nich zostać, chyba że e-deklaracje są równie wygodne i mogą zaimportować historię?

Puszcza mnie już instalacja tych e-pitów, ale dostaję teraz głupi błąd:

Nie można zainstalować aplikacji Adobe AIR. W systemie nie można odnaleźć narzędzi systemu Debian do tworzenia pakietów deb (na przykład dpkg-deb lub ar).

ehhh…

Przy próbie instalacji e-deklaracji dostaję taki sam błąd :frowning:


(gunter) #5

Wystarcza do e-pitów i e-deklaracji najnowszej 10 też. Tu opis jak to zrobić dla e-deklaracji. Dla ciebie opis poniżej dla e-pitów i na końcu skrypt ułatwiający instalowanie.

Z błędu wnioskuje że masz Debiana (lub pochodny) i pewnie 64 bitowego. To musisz zrobić tak. Adobe-air jest tylko 32-bitowy, przynajmniej na linuksa, czyli dodać arch-i386.

Z root-a lub sudo jak ktoś ma.

dpkg --add-architecture i386

Doinstalować co jest potrzebne.

apt-get install wget unzip libgtk2.0-0:i386 libstdc++6:i386 libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386 libqt4-qt3support:i386 libgnome-keyring0:i386 libnss-mdns:i386 libnss3:i386

Bez root-a, jako normalny user. Teraz pobrać AdobeAIRSDK i “zainstalować”, czyli zrobić folder i rozpakować.

wget http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRSDK.tbz2

mkdir $HOME/adobe-air-sdk

tar jxf AdobeAIRSDK.tbz2 -C $HOME/adobe-air-sdk

Teraz adobe-air
Pobrać

wget https://aur.archlinux.org/cgit/aur.git/snapshot/adobe-air.tar.gz

Rozpakować

tar xvf adobe-air.tar.gz -C $HOME/adobe-air-sdk

Zmienić opt na $HOME zgodnie z tym gdzie rozpakowany był.

sed -i -e 's/\/opt/$HOME/g' $HOME/adobe-air-sdk/adobe-air/adobe-air

Uprawnienia

chmod +x $HOME/adobe-air-sdk/adobe-air/adobe-air

Pobrać e-pit dla linuksa i uruchomić w taki sposób.

$HOME/adobe-air-sdk/adobe-air/adobe-air Pobrane/setup_e-pity2017Linux.air

A jak ktoś chce prosto i szybko i dodatkowo e-deklaracje, to tu na dug.net.pl ktoś napisał gotowy skrypt do instalacji e-deklaracji, później jak chcemy uruchomić e-pity wystarczy zrobić to co jest w ostatniej linijce. Pobrać i

$HOME/adobe-air-sdk/adobe-air/adobe-air Pobrane/setup_e-pity2017Linux.air


(pocolog) #6

Dzięki za rozbudowaną odpowiedź. Oznaczam jako rozwiązanie, ale nie będę sobie mieszał architektur w robocie (a miałem nadzieję tam to zrobić z marszu). Zrobię to u siebie w domu i będzie mniej komplikacji.


(gunter) #7

To nie śmieci w systemie, dlatego dodatkowo tak mało jest robione na adminie. Zawsze można odinstalować paczki i386 i wyłączyć wsparcie dla architektury i386, po odinstalowaniu wszystkich paczek 32-bitowych wystarczy z root-a.

dpkg --remove-architecture i386

Usunąć pobrane i skasować folder z domowego adobe-air-sdk. Wyczyścić pamięć podręczną apt-a, np z sudo.

sudo apt-get clean && sudo apt-get update

I nic nie zostanie. Ale rozumie, każdy robi jak uważa.


#8

Ale kombinujecie jak koniki pod górkę :wink: Właśnie sobie dla testu zainstalowałam Air’a i tą apkę.
Dwa kliki i śmiga super.
Bez pierniczenia w mieszanie architektur, bez kombinacji. Są normalnie działające paczki deb dla x64.


(pocolog) #9

Tyle że temat dotyczy e-pity, ale to szczegół jak zwykle dla ciebie :laughing:
No i pytanie czy to pod Debianem? Bo niedługo sprawdzę na Gentoo i podejrzewam że też problemu nie będzie :wink:


#10

Tak samo działają.


(pocolog) #11

Podaj link do tych e-pity co się bez problemów instalują, bo ja nie znalazłem, a chcę to jak najprościej zrobić :wink:


(gunter) #12

O ile wiem nie ma na Linuksa adobe readera 64-bitowego, a jest on potrzebny do e-deklaracji, pokaż.

dpkg -l | grep adobe


(pocolog) #13

Przypomniałem sobie, że jak w tamtym roku instalowałem to też się bawiłem w mieszaną architekturę żeby zainstalować, tylko później przyszedł upgrade Debiana do wersji 9 i pewnie wywaliło stare libki :wink:


#14

Instalkę Air’a mam jako paczkę .deb, a aplikację .air pobrałam sobie stąd: goo.gl/qnHMzU
Nie widzę tam nigdzie “epity”, a jedynie “edeklaracje” w wersji 10.x.
Dokładnie toto sobie zapodałam: http://www.finanse.mf.gov.pl/documents/766655/1196444/e-DeklaracjeDesktop.air


(pocolog) #15

Z tego, co pamiętam e-deklaracje były straszną kaleką polegającą na tym samym co wypisanie papierowego formularza tylko na monitorze. Może się coś zmieniło, jednak mnie interesują e-pity, żeby podpiąć starą bazę. Tak czy siak, nie będę się tym trudził na Debianie.


#16

Przecież w tych tutorialach też nie ma epity nigdzie. Daj mi plik instalacyjny do nich to sprawdzę i tyle.
Tu masz paczkę air’a działającą na nowych systemach… http://www86.zippyshare.com/v/oSDtMHP2/file.html
Spoczko, to mój upload :wink:


(pocolog) #17

Tobie wierzę tak samo jak każdej innej osobie w internecie :wink: Jak nie mam paczki od producenta, to nie mam paczki :stuck_out_tongue:


(gunter) #18

Martyna zaczynasz mnie denerwować, sprawdzałaś zależności tego adobeair_2.6.0.2_amd64.deb. Jeszcze każesz pobierać z zippyshare.

Depends: libbz2-1.0:i386, libc6:i386, libgtk2.0-0:i386 (>= 2.6), libnss3:i386, libstdc++6:i386, libxml2:i386, libxaw7:i386, libxslt1.1:i386

#19

Znalazłam sobie… paczuszkę sama… proszę… Działają epity… nawet pod compizem…


#20

A Ty się gościu skończ mnie czepiać, bo nie ja tą paczkę robiłam!
Sam podajesz z doopy wyjęte, pogmatwane sposoby, zamiast chłopakowi ułatwić i pomóc!

eeehh… faceci.

BTW… Ja nie mam dodanej i386 i o żadne pierdy mi się nic nie pluło. Dwuklik i instalka poleciała z gdebi.
Chcesz to się doszukuj bzdetów… nie to nie i już. Nie mój problem.

Tyle w temacie.