Błędne ustawienia klawiatury na laptopie, tylko w terminalu, GUI jest ok


(ra-v) #1

Po aktualizacji openSUSE 42.1 do 42.2 na laptopie mam problem z układem klawiatury w trybie tekstowym. Po wpisaniu polskiego znaku czy wciśnięciu np. TAB lub BACKSPACE pojawiają się znaki zapytania.
http://imgur.com/qCAUonE

W GUI (np. KDE) jest wszystko ok, nawet w tamtejszym terminalu.
Na PC robiłem aktualizację praktycznie klona systemu i też jest ok.


(marcin82) #2

Pokaż zawartość pliku /etc/vconsole.conf.


(saturno) #3

Pokazujesz na root, a z poziomu usera też jest źle?


(ra-v) #4

Nawet w polu “Login:” działa tak samo.

Plik:
KEYMAP=pl
KEYMAP_TOGGLE=


(marcin82) #5

A gdybyś ustawił w ten sposób?

[code]KEYMAP=pl2
FONT=Lat2-Fixed16

FONT=lat2-16

FONT_MAP=8859-2
[/code]

Uwaga - sprawdź i dostosuj nazwy czcionek czy mapowania klawiatury. Nie kojarzę teraz jak to dokładnie wygląda w OpenSUSE. Czcionkę “Lat2-Fixed16” przytuliłem z Debiana, zostawiłem, żeby było wiadomo o co chodzi.


(ra-v) #6

Dzięki. Wpisałem jak podałeś - zadziałało.

Co ciekawe na PC jest tylko KEYMAP=pl i działa.


Polskie znaki restartuja xorg i srodowisko graficzne
(marcin82) #7

No to sprawdź jeszcze co dokładnie masz w /etc/X11/xorg.conf.d - u mnie plik:

[code][root@arch xorg.conf.d]# cat 00-keyboard.conf

Read and parsed by systemd-localed. It’s probably wise not to edit this file

manually too freely.

Section "InputClass"
Identifier "system-keyboard"
MatchIsKeyboard "on"
Option “XkbLayout” "pl"
Option “XkbModel” "pc105"
Option “XkbVariant” "legacy"
Option “XkbOptions” "compose:rwin"
EndSection
[/code]