Błędy podczas instalacji XP


(Blazejjba) #1

O problemie pisałem już w wątku Uszkodzony dysk. Wydawało się że rozwiązałem problem. Dysk przyszedł, zamontowałem go , bios go wykrył więc odpalam instalkę XP. Przy formatowaniu dysku(nowego) jakiś krytyczny błąd z odczytaniem stanu dysku i "instalator musi zakończyć pracę". Więc daję jeszcze raz. Tym razem etap tekstowy poszedł bez problemu. Po restarcie "Nie można załadować pliku [...]System\Config[...] Prawdopodobnie plik jest uszkodzony[...]". No to odpalam jeszcze raz. Po etapie tekstowym znów to samo, ale inny plik uszkodzony. No to dawaj jeszcze raz od nowa. Tym razem doszedłem do ekranu ładowania XP(ale tego przed instalacją GUI) i niebieski ekran. Ale nie taki charakterystyczny, tylko z komunikatem STOP: /jakieś cyfry/ - nieprawidłowa suma kontrolna nagłówka /jakiś plik/. Mówię sobie "już ostatni raz", i znów doszedłem w ten sam moment, znów ten sam komunikat STOP ale dotyczył innego pliku.

Czyżby uszkodzenie napędu DVD?

Jeśli tak, to co mogę zrobić? Instalacja z pendrive? Tylko jak...

EDIT. Płyta instalacyjna raczej dobra, właśnie udało mi się skończyć instalację na maszynie wirtualnej bez problemu.


(JNJN) #2

Taśma sygnałowa dysku.

Pamięć.

Może kręcony.

Dysk.

Inne.


(Blazejjba) #3

Laptop - taśmy nie ma.

Hmmm.

Nie kręcony.

Wczoraj kupiony nowy Samsung z 3-letnią gwarancją.

Np?


(Tompyk) #4

Tego typu błąd miałem kiedyś i okazało się że przyczyna leżała w uszkodzonej pamięci. Niby komputer chodził, na biosie test przechodził ale w momencie instalacji się wszystko sypało w różnych momentach.


(Blazejjba) #5

To laptop Dell Latitude D620. Wyczytałem że ma DDR2. Mam swoją starą DDR2 1GB wyjętą z PC, tylko to jest taka szersza, tzn ma 3cm szerokości a obecne mają troszkę mniej. Zmieściła by się do tego laptopa na test?


(Tompyk) #6

Z tego co wiem, ale mogę się mylić to pamięci z komputerów PC raczej nie będą pasowały do laptopów.

Jeżeli masz gdzieś możliwość zdobycia płyty z Linuksem np Ubuntu LIVE to spróbuj wykonać test Memtestem


(Michal Kolatek) #7

A próbowałeś zainstalować jakiegoś linuxa?

RAMu z PC nie wstawisz do laptopa, zostaje test memtestem

prawidlowe-sprawdzenie-modulow-ram-bledy-t50125.html


(Blazejjba) #8

Szkoda... Mam Ubuntu Live na płycie i jest tam test pamięci, więc spróbuję. A dlaczego wykluczacie napęd?


(Johny) #9

Czy dysk jest na SATA ?,raczej wygląda to na problem z nierozpoznawaniem dysku,w BIOSie przełącz tryb AHCI na IDE,XP nie rozumie komend w nowym standardzie kierowanym do dysku


(Tompyk) #10

Większe jest prawdopodobieństwo uszkodzenia pamięci niż napędu (napęd albo by Ci w ogóle nie czytał, albo jeżeli by się blokował to by to było w tym samym miejscu)


(Blazejjba) #11

Zgadza się, jest to dysk SATA Samsunga, 250GB, 5400rpm. Mówisz, że to może pomóc?

Tylko z biosem jest problem, jest tam hasło, którego oczywiście nikt nie pamięta... W PC wyjąłbym baterię, tylko jak się do niej dostać w laptopie? EDIT już znalazłem dokumentację i sposób.

Tylko czy to ma szansę powodzenia, wcześniej też był dysk SATA i grało(chociaż to nie ja instalowałem system). Po prostu nie wiem, czy warte jest zachodu zdejmowanie klawiatury.

Na chłopski rozum, jakby XP nie rozumiał komend od dysku, to by wywalał się w jednym momencie, a nie że raz "zrozumiał" a za drugim już nie...


(Gregorsi) #12

Jeżeli dysk nie zostałby rozpoznany to instalator zatrzymał by się i zakomunikował, ze nie znalazł dysku.

Dysk można przetestować programem HUTIL http://www.samsung.com/global/business/hdd/support/utilities/Support_HUTIL.html, równie dobrze możesz mieć walnięty RAM, możesz go testować Memtest86+. Memtest86+ jest na większości płyt instalacyjnych Linux


(Blazejjba) #13

Więc mam sprawdzić pamięć? Czy może da radę zdiagnozować jakimś innym, mniej czasochłonnym zajęciem?


(Gregorsi) #14

To jest diagnostyka do twojego della http://ftp.us.dell.com/diags/cdd_1284.iso.

Masz dwie możliwości:

pierwsza, przetestować sprzęt, zajęcie dość czasochłonne.

druga, instalować windows i liczyć na to że się zainstaluje prawidłowo.


(Monczkin) #15

blazej.30 , nazwij proszę temat konkretnie, bez zbędnych problemów w tytule. Inaczej wyciągnę konsekwencje. Przeczytaj proszę ten temat. viewtopic.php?f=16&t=394978


(igrek) #16

Na bank uszkodzona pamięć też tak miałem przy próbie instalacji xp tylko ze w moim przypadku nie mógł skopiować kilku plików. Po wymianie pamięci wszystko śmigało jak trzeba


(Blazejjba) #17

Monczkin , przepraszam, ale nie wiem jak mam konkretniej nazwać temat. Po prostu jest to sprzętowy problem z instalacją XP, nie wiem jaki. Zamieniłem problem na błędy, nic więcej nie wymyślę.

Co do tematu, przetestuję pamięć i dam znać. Gdyby była uszkodzona, to mam szansę zainstalować system bez jej wymiany? Jeśli ktoś czytał podany przeze mnie wcześniej temat, to wie, że nagle komputer przestał odpowiadać bo BIOSie. Sprawdziłem dysk - dużo błędnych sektorów, po zerowaniu bez zmian, instalka XP dawała czarny ekran po Instalator sprawdza konfigurację sprzętową komputera... więc dysk wymieniłem na nowy. A reszta problemu znana... Dziwne, żeby tyle rzeczy jednocześnie się sypnęło.


(igrek) #18

Jeśli wykaże błędy to niestety pamięć do wymiany bo nawet jak uda ci się zainstalować xp to będzie niestabilny (restarty bsody itp)


(Blazejjba) #19

Do testu wykorzystałem płytę z Ubuntu 9.10. Oto wynik końcowy testu Memtest86+:

Pass finished. No errors.

Co wy na to?

Instalacja XP dalej swoje, próbowałem raz, znów błąd, znów w innym miejscu, znów problem sumy kontrolnej nagłówka.

Natomiast instalacja Linuksa ... ciekawie, bo przeszła sprawnie, szybko i bezproblemowo. Po restarcie natomiast już problem. Po charakterystycznym logu migającym, napisy:

[tu jakieś liczby, zwiększające się z każdym wierszem]ata1.00:error: { UNC }

------------------------||-------------------------------------ata1.00:end_request: I\O error, der sda, sector 1222543


Ubuntu 9.10(none) tty1

(none) login:

I tu mogłem się normalnie zalogować, po czym dostałem

ppp@(none): ~$ i znak zachęty.

Więc co jest wreszcie grane? To się naprawdę zaczyna robić BARDZO dziwne.


(Gregorsi) #20

Masz problem z odczytem z dysku, przetestuj go. Wysłałem Ci już linki.

Polecam Ci diagnostykę od Dell, ma graficzny interfejs, wszystko wyklikasz,

http://ftp.us.dell.com/diags/cdd_1284.iso

możesz też użyć tego

http://www.samsung.com/global/business/hdd/support/utilities/Support_HUTIL.html