Błędy w działaniu forum ;-(


(Radek68) #1

Dziś często mam problemy na forum, a w zasadzie to problemy ma chyba forum. :wink:
Zgłaszam, bo być może komuś to się przyda.

image

image



(Direwolf) #2

Warto chyba oznaczyć odpowiednie osoby w temacie, aby wiedziały, że problem występuje.
U mnie od samego rana, ale nawet nie zgłaszam, bo poprzednio zgłaszałem i nic się nie zmieniło.
Zauważyłem, że nasilenie występuje od pojawienia się konkursu z maszynkami.

Pozdrawiam, Direwolf!


(Blacklord) #3

Ale dziś forum przymula, długo się ładuje. Ktoś chyba nie tylko ogolił ojca prowadzącego ale i chomiki w serwerowni.


(Paweł A.) #4

Tak, od pół godziny, cyrki z forum i u mnie.


(D35CART35) #5


U mnie jest tak samo :triumph:


(Paweł A.) #6


Bardzo często wywala błąd 500.


(Radek68) #7

No właśnie, teraz to już jest tak, że na jedno poprawne wejście na forum przypadają około 3 z różnymi (jak wyżej) błędami.
@tomekb @lisek


(Paweł A.) #8

Tak jest. Jest teraz gorzej, z wejściem na forum. Czasami trzeba odświeżyć stronę z 4 razy, aby forum weszło.


(Direwolf) #9

Forum chyba nabrało świadomości i teraz samo sobą zarządza, bo najwięcej błędów wyrzuca mi, kiedy chcę czytać ten temat. To jakby forum chciało, aby nikt nie wiedział o jego problemach :stuck_out_tongue:


#10

Jeszcze Error 500 Internal Server wywala.


(Domker) #11

Mi też wywala powyższe błędy i to dosyć często. Czasami po 3-4 razy trzeba klikać w zapisz zmiany, żeby w ogóle nie wywaliło błędu.


#12

Widac, że dibreprogramy.pl nie panują nad tym. Pojechali an ostatni ciepły weekend wszyscy się wtgrzewac na słoneczku z dziewczynami, żonami :stuck_out_tongue:


(tomekb) #13

Wlasnie przy tym grzebiemy :wink:


(Bogdan_G) #14

Dorzucę i ja screen. Bo mimo erroru, to tylko główną wyrzucało, a w powiadomienia i działy dało się wejść:


(tomekb) #15

OK, więc mały update w sprawie tych błędów error 500.

Pojawiają się, kiedy aplikacja Discourse nie może się połączyć do bazy. Ma to miejsce, kiedy na forum jest akurat wielu użytkowników, a w tle proces roboczy forum wykonuje intensywne zadania.

Rozwiązaniem tego problemu wg autorów Discourse jest wdrożenie w przypadku dużego forum czegoś, co się nazywa connection pooling. Discourse ma coś takiego natywnie, ale to przestaje wystarczać przy większym ruchu, który jak widać my już osiągamy.

Rozwiązaniem dla nas jest pgbouncer. Spędziłem właśnie godzinę nad tym, żeby go uruchomić i przepiąć forum. Przepięcie nastąpiło kilka minut temu, pewnie wtedy, kiedy Bogdan pisal przed chwila o błędzie.

Mam nadzieję, że to rozwiąże ten problem permanentnie.

Proszę o info, gdyby coś było nie tak.


(Seba228215) #16

Też mam co jakiś czas ten sam problem “przepraszamy…” i nie wiem czy to samo dotyczy kanału głównego, bo też mam “przepraszamy…”.


(tomekb) #17

Jakiego kanalu glownego?


(Paweł A.) #18

Od pół godziny, forum przynajmniej u mnie, działa prawidłowo.


(tomekb) #19

I tak powinno być już na stałe :wink:


(Seba228215) #20

@tomekb Temat “Kanał Główny”, to co zgłaszałem i pisałeś, że wiecie o niedostępności i pracujecie nad tym.