Brak dźwięku pod aplikacjami windowsowymi pod winem


(tomi001) #1

Mam taki problem zainstalowałem sobie Linuxa minta 17.2 i teraz pod aplikacjami widowsowymi uruchamianymi pod wine nie ma dźwięku, ale wszedłem sobie pod winecfg i nacisnąłem test dźwięku i było coś słychać natomiast pod aplikacjami nie ma co to może być.


(nintyfan) #2

Jaki sterownik dźwięku wybrałeś?


(tomi001) #3

Domyślny systemowy, zmieniłem na Pulse i nadal to samo.


(nintyfan) #4

Mam rozumieć, że w Winecfg wybrałeś sterownik Pulse? Podaj jeszcze wersję Wine.


(Amaterasu) #5

Zainstaluj pakiet:

sudo apt-get install libmpg123

Miałam ten sam problem, instalacja powyższego pakietu rozwiązała go ;).

Pozdrawiam, Amaterasu.


(tomi001) #6

Mam go zainstalowane w wersji libmpg123-0

wine-1.6.2

 


(saturno) #7

O ile się nie mylę sterownik pulseaudio dla wine trafił dopiero w wersji: 1.7.55: http://www.dobreprogramy.pl/Wine-1.7.55-teraz-dzwiek-z-gier-dla-Windows-bez-zaciec-a-niebawem-wsparcie-dla-DX11,News,68162.html

Sprawdź dla pewności używaną wersję wine:

wine --version

 


(tomi001) #8
wine-1.6.2 mam taką wersję wine, a nie idzie innego sterownika dźwięku wybrać.

(Amaterasu) #9

Zaktualizuj Wine do najnowszej wersji (1.7.55), może to pomoże.

Pozdrawiam, Amaterasu.


(tomi001) #10

Właśnie w mojej dystrybucji ta wersja wine którą mam zainstalowaną jest w najnowszej wersji.


(nintyfan) #11

Zawsze możesz spróbować zainstalować Wine ze stronki. O wiele gorsza metoda, ale skoro to Ci tylko pozostaje.


(tomi001) #12

Próbuje i założyłem oddzielny temat bo teraz próbuje skompilować wine ze stronki i też mi się nie udaje.


(Amaterasu) #13

Zainstaluj PlayOnLinux, uruchom program oraz przejdź do Narzędzi → Zarządzanie wersjami Wine. Tam będziesz mógł dostać najnowszą wersję pakietu. Robisz to, wybierając poszczególna wersję z lewej strony (tutaj: 1.7.55) i przesuwasz ją za pomocą strzałki “>”, by została zainstalowana.

Pozdrawiam, Amaterasu :D.


(tomi001) #14

Zainstalowałem niby wszystko jest dobrze to wine znajduje się w kategorii 32 bitowych, a jednak się okazało, że zainstalowałem 64 bitowe wine, które nie może być używane do uruchamiania aplikacji 32 bitowych

wine: '/home/tomi/.wine' is a 64-bit installation, it cannot be used with a 32-bit wineserver.

 


(dragonn) #15

Poczytaj jak się używa PlayOnLinux oraz instaluje w nim aplikacje. Dodam że wszystko robi się z poziomu GUI a nie konsoli. Wtedy wszystko będzie działać.


(tomi001) #16

Ja zainstalowałem wine dzięki PlayOnLinux zainstalowałem to graficznie i dobrze się zainstalowało, ale żeby przetestować to wine to zrobiłem to za pomocą konsoli.


(dragonn) #17

Nie rób nic z konsoli, po prostu zainstaluj swoją aplikację przez PlayOnLinux i z tego ją włączaj.


(tomi001) #18

A jak zrobić, żeby np. PlayOnLinux używał wersji wine 1.7.55 do uruchamiania aplikacji bo używa 1.6.2 i jak zrobić, żeby nie instalować gry bo nie mam jej wersji instalacyjnej.


(dragonn) #19

Wskazać wersję podczas instalacji (lub w konfiguracj). Jeśli nie masz wersji instalacyjnej utwórz skrót do tego pliku. Patrz w screena jeśli nie wiesz jak:

2015-11-27-195632_1920x1080_scrot.thumb.


(tomi001) #20

U mnie nie ma czegoś takiego jak utwórz skrót ja mam trochę inny interfejs nie mam tego lewego menu.