Brak obrazu w WMP i problem z otworzeniem AVI w sony vegas


(Grzechut5) #1

Witam, mam problem z kodekami avi na Windows 7 64-bitowym Home Premium, mianowicie na potrzeby pewnego programu zainstalowałem K-Lite Codec pack po czym nastąpił mój problem. Dopóki nie zainstalowałem tej paczki pliki AVi odtwarzały się tak jak powinny, a pózniej WMP zaczął odtwarzać tylko dźwięk bez obrazu. Nie wiem co mam z tym zrobić, przeczytałem mnóstwo tematów na tym i innych forach lecz nigdzie nie mogłem znaleźć rozwiązania. Próbowałem odinstalować wszystkie kodeki i przeczyścić ccleanerem i ponownie zainstalować kodeki, ale to również nie pomogło. Dodam, że pliki w innych formatach działają poprawnie, a gdy plik avi próbuje zaimportować do Sony Vegas pro 11 pojawia się komunikat "wystąpił błąd podczas otwierania kodeku". Z góry dziękuje za wszelką pomoc.


(Dimatheus) #2

Echutor , zapoznaj się, proszę, z tym tematem, a następnie - korzystając z przycisku zmien.gif

Pozdrawiam,

Dimatheus


(Grabkamy) #3

Odinstaluj te kodeki programem "Revo Uninstaller Pro" i zainstaluj kodeki z tej stronki http://shark007.net/forum/Thread-Setup-and-usage (integrują się one bardzo dobrze z WMP).


(Grzechut5) #4

A czy będą działać dobrze z Sony Vegas Pro 11, bo to jest dla mnie najważniejsze?


(Grabkamy) #5

U mnie chodziły kodeki od shark007 z wersja 10, więc myślę że z 11 powinno być ok (nie spróbujesz to się nie dowiesz).


(Grzechut5) #6

Niestety nie mogę pobrać z tej strony ponieważ pojawia się komunikat mówiący, że jestem zbanowany, a nigdy na tą stronę nie wchodziłem. Możesz podać inny link do pobrania tej paczki lub innych kodeków?


(Grabkamy) #7

To link do najnowszych z DP http://www.dobreprogramy.pl/ADVANCED-Codecs-dla-Windows-78,Program,Windows,13277.html


(Grzechut5) #8

Niestety pomimo wykonanych czynności problem nadal występuje. Jakieś inne pomysły?


(Grabkamy) #9

Ze znanych są jeszcze takie "Combined Community Codec Pack".

Ps. być może to nie wina kodeków (zainstalowałem teraz vegasa 11-tkę trial i hula na tych od shark007).

Ps 2. jest jeszcze możliwość że instalując nowe kodeki były jeszcze pozostałości po starych


(Grzechut5) #10

Tego już też próbowałem.

Wątpie w to, wszystko odinstalowałem porządnie i raczej nie powinno być żadnych pozostałości. A poza tym to musi być wina kodeków, ale jeżeli nie to może to być wina dekoderów. Bo kiedy próbuje wrzucić filmik w formacie avi do sony vegas to pokazuje się błąd mówiący, że wystąpił problem w otworzeniu kodeku.


(Grabkamy) #11

Tu masz wątek odnośnie usuwania kodeków http://forum.dobreprogramy.pl/program-usuwania-kodekow-t216201.html

Tu link do tematu odnośnie przywracania ustawień kodeków http://www.elektroda.pl/rtvforum/topic2374158.html

A tu link do programu usuwającego uszkodzone kodeki z systemu http://codec-sniper.softonic.pl/

Ps. jest jeszcze taka opcja że sam vegas się uszkodził (spróbuj go przeinstalować).

Ps 2. już nic innego mi nie przychodzi do głowy :frowning:


(Grzechut5) #12

Możesz mi jeszcze wytłumaczyć jak bezpiecznie użyć codec sniper, żeby nie uszkodzić nic w plikach systemowych?

PS. Potem jakie kodeki zainstalować ew. jaką paczke?

-- Dodane 05.09.2013 (Cz) 21:05 --

Zrobiłem wszystko co mówiłeś i nic nie działa :C Normalnie sam bym to załatwił ale w tych sprawach jestem zielony. Jako że uczęszczam do technikum informatycznego zapytam się jutro nauczyciela, może pomoże, ale nie pogardzę żadną pomocą, a tobie grabkamy serdecznie dziękuję za próbę pomocy.


(Grabkamy) #13

Ja osobiście usuwałem tylko te w których widniał "filename" C:\Program files (x86)...lub C:\Program files (u Ciebie może być inna lokalizacja w zależności od tego gdzie instalowałeś kodeki.

Ps. autor programu radzi zrobić punkt przywracania przed usuwaniem błędnych kodeków.

Ps 2. proponowałbym zacząć od tej metody http://www.elektroda.pl/rtvforum/topic2374158.html

Ps 3. proponuję paczkę od shark007 bądź K-lite Mega Codec Pack.

A tu instrukcja obsługi Codec Sniper:

Źle zainstalowany lub uszkodzony kodek może uniemożliwić poprawne odtwarzanie niektórych plików audio i video, a nawet zachwiać stabilnością systemu operacyjnego. Aby tego uniknąć, można skorzystać z prostego, ale bardzo skutecznego programu Codec Sniper. Pozwoli on szybko i łatwo zidentyfikować oraz usunąć wadliwe kodeki z naszego komputera.

Wszystkie zainstalowane w systemie kodeki możemy obejrzeć na liście wyświetlanej w głównym interfejsie Codec Sniper. Obok ich nazwy podane są wersja, lokalizacja na dysku oraz stan. Jeśli ten ostatni przyjmuje wartość broken, oznacza to, że kodek jest uszkodzony i należałoby go usunąć. W tym celu trzeba zaznaczyć kodek na liście, a następnie skorzystać z klawisza Delete. Kodek zniknie bez śladu.

Codec Sniper szybko i sprawnie eliminuje uszkodzone lub zbędne kodeki. Jedyną wadą może być fakt, że program nie pyta o potwierdzenie usunięcia kodeka. Aby zabezpieczyć się przed przypadkowym skasowaniem potrzebnych kodeków, należy przed uruchomieniem programu stworzyć punkt przywracania systemu.

Jeśli masz problemy z kodekami, pobierz Codec Sniper.


(Grzechut5) #14

Czy w revo uninstaller nalezy usunąć windows media encoder 9 series?

-- Dodane 05.09.2013 (Cz) 21:52 --

Ehh... Zrobiłem co napisałeś... Nic nie działa :frowning: :-x


(Grabkamy) #15

U mnie Revo nie widzi czegoś takiego jak "windows media encoder 9 series" być może to jest winowajca.


(Grzechut5) #16

Usunąłem to i od nowa zainstalowałem K-Lite mga pack. Niestety nie pomogło


(Atis) #17

Użyj Fix WMP Utility i zrestartuj komputer:

http://www.thewindowsclub.com/repair-wi ... mp-utility


(Grzechut5) #18

Niestety to też nie działa :C Czy przed tym należy usunąć wszelkie paczki kodeków? Jeżeli tak to jakim programem który zrobi to za mnie, bo próbowałem użyć codec snipera ale boje się, że tym programem mogę sobie niechcący usunąć jakiś ważny plik systemowy. Zastanawiałem się również nad reinstalacją systemu/naprawą go. Jeżeli można to w miare szybko i sprawnie to zrobić? Należy to zrobić z płytki czy jak? Proszę o wytłumaczenie tego w sposób zrozumiały dla kogoś kto jeszcze nie za bardzo się na tym zna :slight_smile:


(Atis) #19

Przywróć system do czasu przed awarią:

http://windows.microsoft.com/pl-pl/wind ... em-restore


(Grzechut5) #20

Niestety ostatni punkt przywracania systemu jest z dnia 5 września, a problem pojawił się ok. 2 września i punktu przywrócenia systemu już nie ma na ten dzień. Czy jest opcja aby przywrócić system bez nich?