CIS blokuje program Http File Server


(Snoozerulez) #1

Witam!

Zauważyłem, że pakiet bezpieczeństwa CIS (Comodo Internet Security) blokuje mi program HFS (Http File Server) chociaż dodaje go do wyjątków/bezpiecznych plików. Zauważyłem, że nie tylko ja mam ten problem, gdyż na stronie firmy comodo ktoś już napisał podobny post mimo to nikt nie potrafił im pomóc... może ktoś z Was by doradził? Tutaj temat na forum Comodo http://forums.comodo.com/firewall-help- ... 316.0.html

Pozdrawiam,

Mati


(Tomek Matz) #2

Serwera, z którego korzystasz nie znam. Jednak mam u siebie postawiony inny serwer HTTP, więc poniższe pytania są oparte na własnych doświadczeniach:

  1. Czy masz ustawioną odpowiednią regułę w sekcji Zapora -> Reguły zabezpieczeń sieci -> Reguły globalne?

  2. Czy masz włączony Firewall wbudowany w Windows?

  3. Czy masz ustawioną odpowiednią regułę w sekcji Zapora -> Reguły zabezpieczeń sieci -> Reguły aplikacji

I jeszcze jedno ... skąd wiesz, że to Comodo jest przyczyną? W jaki sposób oceniasz, że serwer jest blokowany?


(Snoozerulez) #3

Hmmm... wiesz nie znam się zbytnio... jeśli chodzi o zaporę windows tam mam zaznaczone by nie blokowała tego programu (tak więc - tak mam włączony firewall windows) Programu używam w celu przesłania znajomym jakiś plików (na szybko) bez konieczności uploadowania go na różne serwery ftp... próbowałem tych rzeczy które są w temacie na stronie comodo i nic nie pomaga... tak więc zapewne mi nie pomożesz... liczyłem że może ktoś kto korzysta z tego programu rozwiązał ten problem i napisze mi co mam ustawić, mimo wszystko dziękuję za wypowiedź.


(Tomek Matz) #4

Nikt Ci nie pomoże jeśli nie będziesz udzielał odpowiedzi na pytania. Przede wszystkim jeśli chcesz znajomym szybko udostępniać pliki to powinieneś się zainteresować serwerem FTP (możesz go postawić u siebie na komputerze tak jak serwer HTTP) a nie HTTP lub skorzystać z dobrodziejstw chmury - polecam SkyDrive. W tym drugim przypadku Twoi znajomi będą mieli dostęp do plików nawet wtedy, gdy nie będziesz miał włączonego komputera. Poza tym nie wiem jaką masz prędkość upload-u (wysyłania). Jeśli niedużą, to stawianie serwera HTTP lub FTP na swoim komputerze po prostu nie ma sensu.

I jeszcze jedno ... problem może wcale nie leżeć w Comodo:

  1. Czy np. korzystasz z routera? Jeśli tak, to wówczas musisz przekierować port (zapewne będzie to port 80).

  2. Czy masz już jakąś aplikację uruchomioną na tym samym porcie, na którym domyślnie działa ten Twój serwer HTTP (zapewne będzie to port 80)? Jeśli tak, to będziesz musiał zmienić port, na którym działa ta aplikacja lub zmienić port, na którym domyślnie ma działać serwer HTTP.


(Snoozerulez) #5

Usunąłem pakiet. W regułach pozaznaczałem na zezwól wszystko co było możliwe by tylko nie kolidowało to oczywiste... sam korzystasz z Comodo? jeśli tak, pobierz http://www.rejetto.com/hfs/ i kliknij na Menu -> Self test i poczekaj chwilkę czy nawiąże połączenie czy wyskoczy błąd że firewall blokuje porty. (Jak usunąłem comodo wszystko śmiga jak należy, jak tylko zainstaluje comodo program na siłę się blokuje mimo że mu na to nie pozwalam...). Nie chcę innego programu, jakbym chciał to nie pytałbym o rade.

  1. nie

  2. nie


(Tomek Matz) #6

Co to za strona? A ten serwer mogę spróbować postawić u siebie na komputerze. Zaraz sprawdzę, czy napotkam jakieś problemy.

PS Oczywiście, że korzystam z Comodo. Inaczej nie wypowiadałbym się w tym temacie.


(Snoozerulez) #7

Albo przeciągnij plik jakiś w białe pole i kliknij na adres wyświetlony na górze... jeśli jest połączenie po prawej w okienku Log pojawi się np. "20:18:39 [adres IP] Request GET /Http File Server.exe" jeśli się nie pojawi - jak u mnie w przypadku posiadania pakietu comodo... znaczy że blokuje go.


(Tomek Matz) #8

Dla zainteresowanych: Skan na virustotal - plik jest czysty.

Jak widać wydaje się, że wszystko działa:

Adres mojego komputera w sieci lokalnej to 192.168.1.100. Na chwilę włączyłem komputer o adresie 192.168.1.101, żeby zobaczyć, czy będę miał dostęp do serwera z tego komputera i jak widać na załączonym powyżej zrzucie ekranu, takowy dostęp mam.


(Snoozerulez) #9

Hmmmmmmm zmieniałeś cokolwiek? jak Comodo pytał o dostęp dawałeś tylko "zezwól" czy coś głębszego?


(Tomek Matz) #10

Tylko zezwól (dla Defense+ i dla Firewall-a) - wraz z zaznaczonym checkbox-em, aby zapamiętać regułę. Istotne jednak jest, że po tym zezwól trzeba zrestartować serwer (uruchomić go ponownie). Jest to potrzebne dlatego, że przy pierwszym uruchomieniu automatycznie trafia on do piaskownicy i jego działania są blokowane:

Jeśli chodzi o sam serwer to zastanawia mnie, dlaczego zaraz po uruchomieniu próbował nawiązać połączenie z zewnętrznym adresem. Połączenie to zablokowałem, a widoczne ono jest w logach:


(Snoozerulez) #11

OK dzięki, spróbuje.

-- Dodane 07.01.2012 (So) 21:11 --

Kurcze dodałem w zaporze i defense+ ale w zdarzeniach w ogóle nie ma hfs'a mimo że po ustawieniu zrestartowałem go, dodałem plik itp.


(Tomek Matz) #12

Jeśli w zdarzeniach go nie ma (zarówno Defense+, jak i Firewall-a) to bardzo dobrze, tzn. że dodałeś go poprawnie w regułach CIS i nic nie jest blokowane.

http://help.comodo.com/topic-72-1-284-2975-View-Defense+-Events.html

http://help.comodo.com/topic-72-1-284-2968-View-Firewall-Events.html

Spróbuj kliknąć przycisk Open in browser i zobacz co się stanie.


(Snoozerulez) #13

Open in browser zawsze działa... w tym sęk... sam od siebie mogę. Problem polega na tym że ktoś ode mnie nie może. No i Self Test nie przechodzi - Menu -> Self Test (ikonka z plusem). Zobacz czy przejdzie Ci test normalnie.


(Tomek Matz) #14

Ta opcja jest zbugowana. Olej ją. U mnie pokazuje, że jestem za routerem i muszę przekierować porty, mimo tego, że dawno już to zrobiłem i bez problemu mogę się połączyć z zewnątrz z serwerem.

Na jakim serwerze masz ten port? Tzn. co masz w tym pasku Open in browser. Podaj mi.


(Snoozerulez) #15

Port: 80

Opcja nie jest zbuggowana - jak nie mam comodo działa zawsze. Ale wiele osób skarżyło się że Comodo im blokuje programy mimo że nie zezwalają na to... cóż. Ale dzięki za chęć pomocy ^^


(Tomek Matz) #16

Dobra dodaj sobie regułę do Comodo:

Zapora -> Reguły zabezpieczeń sieci -> Reguły globalne -> kliknij Dodaj -> Ustaw wszystkie opcje tak jak na poniższym rysunku:

28r019t.png

  • kliknij Zastosuj.

Jak to zrobisz wrzuć mi zrzut ekranu okienka Reguły globalne. Tak, żebym widział jakie masz tam reguły.

EDIT: Mówię Ci, że jest zbugowana. U mnie połączenie z zewnątrz działa, a ta opcja pokazuje, że jestem ukryty za routerem (co jest nieprawdą).


(Snoozerulez) #17

(Tomek Matz) #18

Ok,

  1. Usuń z tej listy reguły 1,3 i 4 (zostaw tylko tą czerwoną i Http File Server) i naciśnij przycisk OK.

  2. Ustaw Firewall na Tryb własnych reguł (Zapora -> Ustawienia zachowania zapory sieciowej -> zakładka Ogólne -> na suwaku ustaw Własne reguły -> kliknij OK).

  3. Zrestartuj serwer.

  4. Spróbuj połączyć się z zewnątrz.


(Snoozerulez) #19

Działa! Dziękuje :slight_smile: !!


(Tomek Matz) #20

Hm, na pewno? Ja nie mogę się z Tobą połączyć. Jak nie działa to napisz. Jeszcze jeden pomysł mam, co można sprawdzić.

EDIT: Aaa już widzę ... Zmieniłeś port :slight_smile:

Ok, nie ma za co :stuck_out_tongue: