Czarny ekran po przebudzeniu z trybu uśpienia lub hibernacji

Cześć,

Mam problem z uśpieniem i z hibernacją. Komputer po hibernacji zaczyna się uruchamiać. Jest pierwszy etap ładowania, kręci się “kółko”. Potem ekran przełącza się i pozostaje czarny.

Mogę przeskanować porty przez Nmap. Otwarte porty 135, 2179, 3389 są zgłaszane tak, jakby komputer działał normalnie. Niestety próba połączenia się przez RDP kończy się niepowodzeniem.

To samo dzieje się po przebudzeniu z uśpienia. Wygląda na to, że problem pojawia się, gdy uruchamiam więcej programów. W przypadku hibernacji lub uśpienia zaraz po starcie system budzi się prawidłowo.

Wiem, że jest to częsty problem, ale może ktoś zna właściwą metodę rozwiązywania takich problemów.

Wersja systemu operacyjnego: Windows 10, 10.0, wersja 2009, build: 19042 (x64)
Płyta główna: MS-7C81, Micro-Star International Co., Ltd.

BIOS i wszystkie sterowniki zaktualizowane

Ja miałem kiedyś coś podobnego. U mnie okazało się ze to była wina sekcji zasilania karty graficznej ale myśle ze jest dużo innych możliwych wyjaśnień.

Zobacz ACPI w UEFI:


Różne płyty różnie działają, trzeba poćwiczyć. Mi po wyłączeniu kompa świeciła się np. klawiatura, ale doszedłem.
W Twoim przypadku chyba ustawienie na s4-s5

1lajk

Dziś kolejne zaskoczenie. Siadam do komputera po pewnym czasie, mysz nie działa, pulpit wisi. Dioda od dysku czasami mruga jakby komputer chodził normalnie i coś tam w tle robił (komp więc nie wisi w 100%). Nie można się do niego dostać po RDP ani nie odpowiada na ping. Ekran wyglądał mniej więcej tak
obraz
Brak zegarka

Sytuacja podobna do tej po wybudzeniu, tylko że widać ekran. To chyba nie będzie związane ze stanami S, ponieważ mam hibernację i usypianie wyłączone. Wcześniej zmieniałem coś wBIOS, tak że procesor trzymał mi stałe max Ghz. Chyba coś ze stanami C.

Wszystko wskazywałoby, że trzeba zrobić coś ze stanami C i S oraz planem zasilania w zarządzaniu energią. Niestety różne ustawienia były bez znaczenia.

Problem rozwiązany. Należało zainstalować “Intel Rapid Storage Technology” (SetupRST.exe) a następnie wybrać ten drugi tryb pracy dysku. Chyba RST. Jest informacja, że nie można tego cofnąć. Po tej zmianie hibernacja i usypianie działają jak należy.

Ustawienia fabryczne w UEFI/BIOS i dopiero możemy myśleć

Ustawienia miałem fabryczne. Zobacz mój poprzedni wpis. Nie spodziewałbym się takiego rozwiązania problemu, zwłaszcza że w Internecie nic na ten temat nie znalazłem poza jednym małym wpisem gdzieś sugerującym ten kierunek. PC’ty z tą całą masą urządzeń i technologii to niezłe wyzwanie konfiguracyjne. Czasami zazdroszczę ‘makowiczom’

To grzebanie w Bios/uefi. S3, s4. itd Nie ma złotego środka, w żadnej dokumentacji płyty tez tego nie uświadczysz. do tego sterownik karty, i czy procek czasami nie “oszczędza prądu inaczej”

Wygląda na to, że miałeś rację, że to coś ze stanami C/S. Po zainstalowaniu powyżej wspomnianego “Intel Rapid Storage Technology” hibernacja działała przez parę dni i w końcu przyszedł dzień, w którym wybudzenie się zawiesiło. Postanowiłem poczekać bo to wyglądało jakby komputer działał i próbował się wybudzić ale bardzo wolno.

Po kilkunastu minutach a może i dłużej pstryk, komputer się obudził i zaczął działać normalnie. Wcześniej w UEFI całkowicie wyłączyłem C-States ale to nie pomogło. Tak więc dalsze eksperymenty z UEFI. Teraz ustawiłem:

Overclocking>Advanced CPU Configuration>Package C State Limit = CO
oraz
Settings>Advanced>Wake Up Event Setup>Resume by USB Device = Enabled

I już przez kilka dni działa, co więcej wybudzenie z hibernacji jest 2 razy szybsze niż kiedykolwiek poprzednio. Nic nie rozumiem, bo niby dlaczego wyłączenie stanów C nie pomogło a ograniczenie ich pomogło, no ale kto wie może w międzyczasie Windows jakieś aktualizacje zainstalował…

Powiem Ci ,że ja też po wielu latach do końca tego nie rozumiem. S3 -state limit itd.:frowning: