Częste BlueScreeny w Windows 7


(kamil_w) #1

Od jakiegoś czasu dość często pojawiają mi się BSODy na moim laptopie (Acer 5820TG, dysk OCZ Vertex2, 8GB RAM). Sprawa jednak mnie przerosała, gdy przywróciłem kopię systemu (system + sterowniki + ccleaner + ramdisk + vmware workstation) i problem i tak występuje. Jakieś pomysły z waszej strony?

Poniżej plik małego zrzutu i posumowania:

WER-18205-0.sysdata.xml

101612-14071-01.dmp


(matio) #2

Nie jest tak, że przy uruchamianiu komputera nie może znaleźć dysku i trzeba restartować kilka razy żeby zadziałał? Z tego co przeczytałem druga możliwość to problemy spowodowane Realtek HD audio. Po usunięciu sterowników problem minął, więc warto spróbować.


(kamil_w) #3

Tylko że podczas uruchamiania systemu nie ma żadnego problemu, a na systemie z zainstalowanymi wszystkimi programami nie mam zainstalowanego sterownika od Realteka (dźwięk działa na sterowniku domyślnym), więc to też odpada. Wkurzające jest też to, że zrzut pamięci nie jest robiony za każdym razem.


(adam9870) #4

Sprawdź czy w trybie awaryjnym jest w porządku.

Sprawdzaj sprzęt.

Analiza bluescreenów: blue-screen-windows-bit-t491491.html#p3095248 (nie ma znaczenia czy problem dotyczy Windows w wersji 32 czy 64-bitowej) oraz komputer-sie-wylacza-t498828.html#p3137602 W drugim temacie są informacje na temat testowania sprzętu.

Pozdrawiam.


(kamil_w) #5

Sprawa wygląda tak, że w plikach małego zrzutu pamięci są informacje o tym, że problemy mogą powodować różne procesy. Niestety nie pomyślałem wcześniej i nie zapisywałem sobie tych plików. ;/ Problem pojawia się jednak w różnych momentach: podczas normalnego przeglądania internetu, podczas ściągania produktów Adobe za pomocą ich programu - asystenta, podczas instalacji programu na maszynie wirtualnej,... Laptop zawiesza się nawet w stanie prawie jałowej pracy. Jutro wezmę się za sprawdzanie sprzętu, bo przywróciłem dziś obraz systemu do stanu, z którym przez wiele miesięcy nie miałem problemu i komputer i tak się zawiesił więc to najprawdopodobniej problem z którymś z podzespołów.


(adam9870) #6

To może być sterownik do karty sieciowej bluescreen-windows-t489660.html albo antywirusa, ale bez minidumpa na 100% nie powiem Ci.

Sprawdź jak jest w trybie awaryjnym:

  • jeżeli w trybie awaryjnym jest źle, to problem sprzętowy (np. pamięć - do spr memtestem, dysk - do spr hd tune)

  • jeżeli w trybie awaryjnym jest ok, to problem z oprogramowaniem (np. sterownik do karty sieciowej albo program antywirusowy)

Bo w trybie awaryjnym jest ładowane niezbędne minimum do startu Windows, czyli na przykład nie są ładowane wszystkie sterowniki.

Skonfiguruj system w ten sposób, aby tworzył minidumpy: komputer-sie-wylacza-t498828.html#p3137602

Potem możesz poczekać na bluescreena i na utworzenie pliku minidump, a następnie przejrzeć plik zrzutu pamięci, a najlepiej kilka plików DMP.

Tutaj blue-screen-windows-bit-t491491.html#p3095248

znajdziesz informacje na temat analizy plików minidumpów.

W razie gdybyś potrzebował sprawdzić sprzęt komputer-sie-wylacza-t498828.html#p3137602

Jak rozwiązać problem przez wykonanie czystego rozruchu w systemie Windows Vista lub Windows 7

Co do tego, że robiłeś reinstalację i problemy są dalej. Czy reinstalacja systemu pomoże? Jeżeli to problem ze sprzętem albo np. sterownika (np. do karty sieciowej) to prawdopodobnie nie. Nie ma też pewności, że jeżeli przykładowo teraz problem powoduje wersja X sterownika do karty sieciowej, to po ponownej instalacji systemu znowu możesz zainstalować wersję X sterownika do karty sieciowej i problem dalej będzie występować. Gdybyś teraz zdiagnozował problem i ustalił, że problem powoduje wersja X sterownika i aktualizacja do wersji Y rozwiązuje problem, to miałbyś problem z głowy.

Generalnie podaję dwa linki, które zawierają mnóstwo informacji na temat analizy bluescreenów:

W razie problemów z samodzielnym przeanalizowaniem plików zrzutów pamięci:

  • skopiuj katalog c:\windows\mindump na pulpit

  • kliknij na niego prawym przyciskiem myszy - wyślij do - folder skompresowany (zip)

  • wrzuć tego zipa na http://www.speedyshare.com/ i podaj tutaj link

Daj znać co z tego wyszło.


(kamil_w) #7
  • Link do pliku z minidumpa wrzuciłem w pierwszym poście w tym wątku.

  • Systemu nie reinstalowałem lecz przywróciłem system z obrazu utworzonego za pomocą Acronis True Image.

  • Jak na złość teraz system nie chce się zwiesić. ;/

SPRZĘT:

  • Sprawdziłem pamięci za pomocą programu Memtest i nie wykazało żadnych problemów (kości sprawdzałem osobno, każdą po 3 razy),

  • Sprawdziłem dysk za pomocą HDTune Pro trial i również bez problemów. Status dysku: OK

  • Minidump wskazuje czasem na problem z csrss.exe , a innym razem na ntoskrnl.exe

Zastanawia mnie czy to nie jest przypadkiem problem z kartą sieciową albo RAMdiskiem. Tylko kurcze sterowników nie aktualizowałem a wcześniej takich problemów nie miałem.


(adam9870) #8

Napisałem długiego posta i prawie wszystko poszło w las.

Jeszcze raz:

Wszystko jest tu blue-screen-windows-bit-t491491.html#p3095248 i tu komputer-sie-wylacza-t498828.html#p3137602


(kamil_w) #9

HDTune Pro ErrorScan: brak błędów.

Memtest: brak błędów.

Pliki minidump: LINK

Przy okazji zaktualizowałem BIOS płyty głównej i firmware dysku SSD. Też nie pomogło. Zauważyłem natomiast, że błąd mogę wywołać np. za pomocą klienta pobierania produktów Adobe (przy rozpakowywaniu archiwum 7z). Prawdopodobnie chodzi w tym przypadku o to, że BSODy pokazują się pod obciążeniem (laptop się nie przegrzewa w tym czasie). Sprawdzę to jeszcze w trybie awaryjnym.


(Semtex) #10

Zapis odbywa się na Vertex w tym czasie?

Obawiam się że jednak padłeś ofiarą "SandForce", tak właśnie umierają te dyski, przestają być wykrywane (nieregularnie) przez BIOS albo zaczynają się BSOD ni z gruszki ni z pietruszki. Być może się mylę ale te dyski mają bardzo złą opinię...


(kamil_w) #11

Hmmm... Teraz odpaliłem ściąganie trzech produktów Adobe, archiwa zostały poprawnie rozpakowane i BSODa nie było więc jednak nie za każdym razem tak się dzieje. Zdarzało mi się jednak, że BSODy pokazywały się podczas zwykłego przeglądania Internetu, a wszystkie pliki tymczasowe zapisywane są u mnie na RAMdisku więc teoretycznie na SSD nie było żadnych operacji zapisu/odczytu.


(Semtex) #12

Możesz to łatwo sprawdzić, o ile masz miejsce na innym dysku niż SDD, przywróć na nim system z backup, który masz, wyłącz SDD jako dysk rozruchowy w BIOS i zobacz co się będzie działo, jeżeli system będzie stabilny, nie będzie BSOD to masz odpowiedź, być może w celu odzyskania sprawności na SSD będzie wystarczyło zrobienie Sanitary Erase, ewentualnie RMA.

Jeżeli problem będzie występował na HDD to trzeba szukać dalej, być może RAM coś miesza, jednak tak czy inaczej obstawiam SandForce.


(kamil_w) #13

Jak już napisałem RAM sprawdzałem za pomocą programu MEMtest i nic nie wykryło. To samo z dyskiem. Zastanawia mnie czy jeśli faktycznie to problem z dyskiem SSD to czy HDTune nie powinien tego wykryć? Spróbuję to sprawdzić w najbliższym czasie - przerzucę dane na inny dysk i zrobię Secure Erase za pomocą narzędzia OCZ Toolbox. Potem spróbuję przywrócić system na inny dysk.

-- Dodane 19.10.2012 (Pt) 11:50 --

I wychodzi na to, że to jednak wina dysku. Przy kopiowaniu danych z dysku zewnętrznego na Vertexa znów pojawił się BSOD. Już zgłosiłem RMA. Swoją drogą ciekawa sprawa, że wsparcie OCZ dla Polski jest po angielsku a nie po polsku. Myślałem, że w dzisiejszych czasach to się już nie zdarza.