Firefox - nie działa video na testowej www


(covo) #1

(dysponuję: xp, ff v.52.2 esr, wszelkie blokowania wyłączone, zaś wlaczone primetime CDM, SILVERLIGHT, flash)

co może być powodem, że na tej testowej www -> https://demo.castlabs.com/
działa wszystko oprócz dwóch testowych video, 3 i 4: http://i.imgur.com/J1vhSvA.png (jako jedyne maja DRM)?
a jednocześnie:
na tej testowej z video DRM -->https://bitmovin.com/mpeg-dash-hls-drm-test-player/ - - ff działa, jak należy.

co jest nie tak z ff…?


(krystian3w) #2

Może ten drugi test ma więcej zamontowanych wideo z różnym zabezpieczeniem a ten na castlab tylko z widevine i nijak to przeskoczyć PrimeTime, Silverlight, Flashem.


(tdream) #3

U mnie wszystkie filmy śmigają.


(covo) #4

to nie jest problem “widevine”…


(krystian3w) #5

To zostaje jakaś praca sezonowa by kupić nowszy sprzęt i licencje na nowszy Windows, testowanie jakiś dystrybucji GNU/Linux z nowszym Firefox możliwym do uruchomienia.

Test na nowszym Windows (7, 8 / 8.1, 10) / MacOS / jakieś dystrybucji GNU/Linux z aktualizowaną jeszcze wersją, jest że tak powiem nic nie wnoszący do tego tematu.


Błąd że wideo nie chce lecieć do momentu włączenia klasycznych kontrolek elementów tagu Audio / Video, występuje też u mnie w Operze / Chrome - problem raczej ma strona z odtwarzaczem i pewnie nie wiedzą jak naprawić lub u nich działa i zbywają zgłoszenia (to nie YouTube by musieli to naprawić, bo inaczej stracą użytkowników).


(covo) #6

tzn “leci” po włączeniu…? jak włączyć? podreperować w źródle www, w inspektorze ff? pytanie może “gupie” - ale jest. :slight_smile:


(krystian3w) #7

Chodziło mi o to co napisano w wątku na mozilli - włączyć kontrolki spod prawego klawisza myszy.

błąd może też być w skrypcie co ma na mozilli odpalać w SL materiały które nie są kompatybilne z PrimeTime:

<script src="https://s3-eu-west-1.amazonaws.com/clpp/web/5.0.0-beta-4/clpp_silverlight.plugin.min.js"></script>

W tym drugim teście nie ma za bardzo informacji jakie zabezpieczenie jest użyte i jakie dekodujesz.


(covo) #8

który wątek? (to może dopytam się, jak włącza się kontrolki metodą ppm…)


(krystian3w) #9

Twój założony tam wątek.

ok, dziala.
ppm > wyswietl elementy sterujace; ciekawe, kiedy w (kazdym) ff bedzie to dzialalo na klik w prosty klawisz"play", w sposob intuicyjnie przewidywalny dla prostego chlopa,a nie bywalca forow…

:wink:

Dziwne że na domowym komputerze już działa odtwarzacz bez używania standardowych elementów sterujących - konflikt z 64 bitowymi systemami + 64 bitowymi przeglądarkami :question:


(covo) #10

czyli dowiedziałem się, że przez ppm włączałem kontrolki :slight_smile:
ale to dało się zrobić w 52.0, później porobilo się tak, jak wyżej opisałem, zero ruchu.
to, że można włączyc kontrolki przez ppm zawsze widac na czarnym ekranie, natomiast teraz mam na ww. dwóch ekranach - biały krzyżyk.


(Bogdan_G) #11

Wczoraj pokopałem z ustawieniami w FF, bo też trzecie i czwarte mam X na prestoplay.
Było dobrze przecież. Czytając - nietrudno wyciągnąć wnioski, że celowo zepsuli dla XP. Wrzucę cytat:

Niedawno zmieniliśmy nazwę naszych indywidualnych zestawów SDK graczy w ramach naszego pakietu produktów PRESTOplay . Nasz gracz DASH Everywhere nazywany jest PRESTOplay for Browsers .

Tu chodzi o produkty prestoplay. Trochę szukałem Video.js i nawet pobrałem zipy, wypakowanie wrzucałem do profilu i nico, aż mi się znudziło…

Specjalnie zacapili na XP, oby ich po…


(krystian3w) #12

pewnie nie do profilu a dla stronek www to jest.


(covo) #13

te dwie strony testowe i video na nich (dokładniej: dwa ekrany)… - zabrałem się za testowe, ale pal licho testowe; u źródeł jest inny problem (dla mnie ważniejszy), który wystąpił w ff 52.x.x
Otóż:
oto przykladowy film z portalu:
http://tinyurl.com/yb6q6yol

  • rozszerzenie netvideohunter za licho nie działa, tzn nie chce podać linku do filmu, aby wykonać prosty download; także Internet Download Manager (z właściwym pluginem dla ff) nie wyczaja adresu, tzn. IDM nie odzywa się po uruchomieniu filmu i także w ten sposób nie można wykonać download.
    Jednocześnie:
    i netvideohunter i IDM działają na tym portalu bez problemu , ale dla ff w wersjach z przedziału: 38.0.1 - 41.0.2
    I to jest jakaś choroba. Za licho nie mogę zdiagnozować: dlaczego? co nagle stało się z ff, ze ff 52 nie pozwala na wyczajenie adresu do filmu na serwerze, a np. 41.0.2 pozwala…

(krystian3w) #14

Może dodatek nie ogarnia blob (https://developer.mozilla.org/pl/docs/Web/API/Blob) w nowszej wersji.


(covo) #15

blob… Nie wiem… Wiem za to, że także IDM wykłada sie na tym portalu w ff 52.x.x
Oraz:
dziala netvideohunter i IDM ze swoim pluginem od wersji 38, az do wersji ff = 41.0.2 - ale też zauważyć wypada, że video uruchamia się bez Primetime CDM. Shockwave Flash wystarczy.
Na wersji ff 52.2 to wideo “chodzi” tylko na primetime

Podejrzewam, że cos systemowego u mnie szwankuje, bo mam info od kogos , że u niego na jakims filmie tego portalu videohunter pokazuje elegancko link bezposredni do filmu --> http://i.imgur.com/1kvfxiz.png, podczas gdy u mnie pokazuje strumienie --> http://i.imgur.com/XBAxyGD.png


(krystian3w) #16

Po części wina DRM, wyłącz z ustawień i zobacz (ja użyłem wersji DRM free (38) z FTP i miałem 1.16 GB pliku mp4 a z DRM leciało w milion kawałków). sprawdziłem i 54 wciąż rzuca wtedy rzuca stromieniami :disappointed: .

PS. jakaś reinstalacja raczej nic nie da, na świeżym 2 tyg. Windows 7 testowane (i tu akurat system nie jest wyznacznikiem jak to określiłem do pierwotnej treści pytania przy odpowiedzi tdream


skłaniam się raczej ku temu że coś bardziej popsuli w przeglądarce.


(covo) #17

nie rozumiem.

  1. co i gdzie mam wyłączyc?
  2. o jakim ftp piszesz…? ja pisze o przykladowym konkretnym filmie. ftp? kompletnie nie czuję o czym piszesz.
    możesz to jakos zebrać w paczke po pl? :slight_smile: thx

(krystian3w) #18

``ad 1.

W ustawieniach odfajkować drm - raczej nie pomaga na 54 i Windows 7 strumienie.

``ad 2.
Na 38 czyli wględnie dobrej co tobie również działa użyłem wersji bez drm (primetime)


stawiałbym w to że coś się mocno zmieniło między wersją 38 - 41 a 52 / 54 że wpycha strumienie.


(covo) #19

już rozumiem;
w sumie, to o tym “chyba” własnie pisałem wyżej:

"od wersji 38, az do wersji ff = 41.0.2 […] video uruchamia się bez Primetime CDM. Shockwave Flash wystarczy.
Na wersji ff 52.2 to wideo “chodzi” tylko na primetime "

bez Primetime CDM - czyli wyłączone drm w 38 - 41
tylko na primetime - czyli żeby w ogole video chodziło, musi byc primetime włączone w ff 52.

faktycznie, chyba jednak zgrzebali cos w ff (od pewnego numeru --> np. juz w ff 42 - netvideohunter, ani IDM nie działa mi tak ok, jak w 38-41.0.2)


(krystian3w) #20

Moim zdaniem to nie leci przez drm (wersja wykastrowana “DRM Free” ma tak samo) a coś rozbudowali strumieniowanie po 41 wersji Firefox.

Może dodatki też wymagają aktualizacji lub już jest za późno (problem z umieszczeniem ich w sklepie lub będą tak doskonałe jak te dla Chrome (sic!)).