Firefox - nie ładuje wszystkich stron - UPC - konflikt z IPv6


(plotex) #1

Hej,
Mam problem z firefoxem (wersja 56.x) na dwóch laptopach (win 10 pro i 7 HP). Co chwilę nie chce załadować poszczególnych stron. Czasami jest to też strona DP, gdy klikam w zakładkę lub wpisuję adres strony z palca, firefox kręci a na dole “oczekiwanie na stronę np. dobreprogramy.pl” (choć dotyczy to także innych stron, losowo innych). W tym samym momencie gdy firefox czeka na załadowanie strony (na odpowiedź ze strony serwera), na innych przegladarkach (Opera, Chrome, IE) strona ładuje się bez problemu. Nawet w tym samy czasie gdy strona ładuje się na innej przeglądarce, odświeżenie strony i ponowne załadowanie pod firefoxem nie pomaga. Po paru minutach, wszystko wraca do normy i firefox działa w porządku. Jest to problem na dwóch komputerach. Szukałem ustawień rutera, wszystko jest ok. Wyłaczyłem dodatkowo wsparcien na IPv6, ale dalej jest ten sam objaw. Jeszcze raz wspomnę, że to dotyczy tylko firefoxa, i jak zauważyłem po ostatniej aktualizacji, ale nie wiem czy wcześniej tego problemu nie było, zauważyłem to najbardziej po ostatniej aktualizacji FF do wersji 56.x.
W ustawieniach firefoxa ustawiłem połączenia bez proxy, opcję w about:config “network.dns.disableIPv” na true, “network.dns.disablePrefetch” też na true, wszystko zgodnie z pomocą zawartą na stronie mozilli: https://support.mozilla.org/pl/kb/Firefox%20nie%20wczytuje%20witryn%20internetowych%20–%20inne%20przeglądarki%20tak.

Może ktoś ma taki sam problem i/lub wie jak go rozwiązać. Jeśli chodzi o ciasteczka, to czyszczenie pomaga do momenty kolejnego uruchomienia FF.
Dodam jeszcze że gdy odpale kartę w trybie incognito, jest z FF wszystko ok.


(plotex) #2

nikt nie wiem co się dzieje z FF?
Zainstalowałem na nowo i dalej problem, niektórych stron w ogóle nie wczytuje, kręci tylko kółko na zakładce i to wszystko. A w tym czasie Opera np. wczytuję strony bez problemu.
Antywirus, zapory w momencie sprawdzania wyłączone, to samo.
FF się zachowuje jakby nie mógł przetworzyć jakiegoś skryptu, po odświeżeniu pół strony mignie przed oczami jak na nowo zaczyna wczytywać to dalej biała strona.
To samo dzieje się na drugim kompie.
Dodam, że problem nie dotyczy adresów z zakładek, ale strony wpisane z palca, z wyszukiwarki google, czy nawet kliknięcie w link na stronie.


(direct39) #3

Próbowałeś go po prostu przeinstalować albo chociaż użyć opcji “Odśwież Firefoksa”?


(plotex) #4

tak, korzystałem z opcji “odśwież FF”, też kasowałem całego FF, łącznie z katalogami w “users”, bez zmian


(krystian3w) #5

A jak w Firefox Portable?

Język Wersja Link
Polski 56.0.2 Download Mozilla Firefox, Portable Edition

(Bogdan_G) #6

Pierwsze, to w opcje, zaawansowane, ogólne - odznacz akcelerację sprzętową, jeśli dostępna - potem ponownie włącz FFxa.


(plotex) #7

FF Portable jest to samo
Akceleracja wyłączyłem też jest to samo.
Zainstalowałem FF 32bit zamiast 64bit, bez zmian.
Już sam nie wiem, gdzie szukać rozwiązania. Pozostałe przeglądarki działają bez problemu.


(Bogdan_G) #8

Pozostaje odinstalować firefoxa. Usunąć portable. Odznaczyć w opcjach folderów ukrywanie chronionych, odznaczyć ukrywanie rozszerzeń i zaznaczyć pokazywanie ukrytych plików i folderów. Zastosuj i OK. Potem użyj wyszukiwarki, najlepiej malutki wisejet search. Program znajdzie wszystko firefox i usuniesz. Znajdzie wszystko mozilla i usuniesz. Potem przeczyścisz choćby ccleanerem i zainstalujesz FF jaki chcesz z tej strony:
https://ftp.mozilla.org/pub/firefox/releases/
Wybierzesz na ile bit, potem wybierzesz polski i pobierzesz.
Po zakończeniu instalacji odznacz uruchomienie Firefoxa. Po prostu wejdziesz do folderu, gdzie zainstalował się i tam otworzysz folder browser, w nim features. W features pousuwasz komponenty telemetrii i inne - możesz zostawić tylko wieloprocesorowość, jeśli chcesz mieć więcej procesów.
Potem uruchomisz przeglądarkę, poustawiasz i nie będzie niczego, co miałoby blokować strony w firefoxie. Wrócisz do domyślnych ustawień w opcjach folderów, o ile nie zechcesz zostawić ustawienia.


(plotex) #9

niestety dalej jest to samo, czyściłem cccleanerem (pliki-śmieci, rejestr), pokasowane wszystkie katalogi / pliki gdzie było słówko firefox/mozilla, a po świeżej instalacji firefox wywala komunikat że jest program ponownie zainstalowany i czy chce go odświeżyć, żeby śmigał jak nowy. Też nie pomaga. Za to opera hula aż miło.
Szczerze to chciałbym skasować FF i przerzucić się na Opere ale czy jest możliwość wyłączenia cache na dysku? (mam SSD i nie chciałbym, żeby wszystko ładował, buforował nie na dysku tylko w RAM, tak jak jedną linijką w config FF można zrobić i nie potrzebne są żadne aplikacje typu ramdisk.


(krystian3w) #10

No to najpewniej pominąłeś jakoś stary profil w AppData/Roaming/Mozilla?


(plotex) #11

z appdata w roaming i local’ach usunąłem całe katalogi. Mam jeszcze taki katalog ukryty VTroot, wie ktoś po co to jest? pod win10 pro.
Firefoxa sprawdzę jeszcze w domu. Zrestartuję ruter i modem jak wrócę. Teraz korzystam z netu radiowego i jak do tej pory zauważyłem to stronki FF wczytuje, których wcześniej nie chciał.
Jakby problem był gdzie albo na firewall’u albo w dns. Choć dziwne dlaczego Chrome i IE nie miał problemu.
Czy FF ma jakiś swój plik z pamięcią dns? Bo chyba IE ma coś takiego, albo miało.


(krystian3w) #12

Jak nawet przeglądarka ma to standardowo do zamknięcia powinna przetrzymywać dane, potem się ulatniają. Z kolei windowsowa pamięć DNS powinna wyczyścić się po ponownym uruchomieniu komputera.


(trzynasty) #13

Pozwolę sobie na mały offtop, bo widzę że też używacie portable ff.
Ogólnie przeglądarki portable dla mnie dzielą się na dwie grupy- ff i opera, które są całkowicie portable,i nie cachują żadnych danych na dysku,i vivaldi który dość często korzysta z dysku, mimo że jest instalacja portable.i sami twórcy vivaldiego przyznają ze to nie jest w pełni wersja portable.
No,to był przydługi wstep, ale potrzebny.
używam wersji portable ff na ramdysku. codziennie uruchamiam spakowaną wersje.
I mimo to, mimo tego że mam powyłączane wszystkie opcje w synchronizacji oprócz zakładek, firefox gdzieś mi zapisuje historie przeglądania, kliknięte linki są podswietlone które wyszukiwałem nawet wiele tyhodni wczesniej. Gdzieś to Ff zapisuje, mimo ze nie ma prawa. Jakieś pomysły gdzie i czemu? Przeglądarke codziennie rozpakowywuję, i tylko sciągam aktualne zakładki poprzez synchronizację, nie zapisuje codziennie na dysku aktualnej wersji firefoksa.


(Bogdan_G) #14

A posprawdzaj, co dokładnie synchronizujesz.
Drugie - to google pamięta lepiej od Ciebie, na jakim koncie co wyszukiwałeś. Można to wyłączyć.


A jakie twoje konta google pamięta?
https://passwords.google.com/

Do tego dochodzą ustawienia FF - dotyczące pamiętania sesji i tam takich. W systemowych folderach użytkownika (w tym ustawień lokalnych) są foldery Firefoxa, gdzie są przechowywane cache. Bo może i usuwasz profil po każdym dniu, ale pozostają foldery ukryte i chronione.
U mnie Firefox nie zapamiętuje, gdzie byłem, gdyż przy każdym wyłączeniu kasuję cache, a historia jest całkowicie wyłączona w firefoxie. Na moich kontach też wyłączona historia. I nie ważne, czy to portable, czy instalacyjna przeglądarka.


(trzynasty) #15

I to jest odpowieź dzieki:) Też mam całą historię powyłączaną, ale mimo to te klikniete linki w google mnie ciekawiły,i podejrzewam że to jest własnie historia google zapamietana przez tego szpiega;) wiem że ff ma kilka folderów ukrytych ,ale z tego co zawsze sprawdzałem to niewiele się tam zapisuje.


(plotex) #16

Ja w pracy zawsze mam FF ustawionego tak, żeby nie pamiętał historii (pracuje on wtedy jakby był cały czas w trybie incognito).
Oprócz tego w FF ustawiam poniższe rzeczy:

  • Ustaw wpisowi „browser.cache.disk.enable” wartość „false„.
  • Ustaw wpisowi „browser.cache.memory.enable” wartość „true”.
  • Utwórz wpis „browser.cache.memory.capacity” (jeżeli go nie ma w rejestrze). Kliknij gdzieś w oknie prawym przyciskiem myszy i wybierz kolejno: Dodaj ustawienie typu > Liczba całkowita (integer). W pierwszym oknie, które się pojawi, wpisz „browser.cache.memory.capacity”, a w następnym „-1″.
    (źródło: http://ittechblog.pl/2010/11/12/przyspiesz-swojego-firefoxa-cache-w-pamieci-ram-bez-ramdisku/)

Daje to to, że cały cache leci do Ramu (można sprawdzić wpisując about:cache). Daje to dużo w momencie gdy korzystamy z dysku ssd. Nawet wersja portable FF ładuje dużo danych do cache. Wystarczy odpalić filmik na youtube i zobaczycie.

@trzynasty zobacz jeszcze ten link
http://www.hotfix.pl/firefox-znaczaco-obciaza-dysk-ssd-n11787.htm
wg mnie to też może być powodem, czemu coś mu w pamięci zostaje.


(trzynasty) #17

świetne porady, dzieki wielkie:)od razu idzie poznać ludzi którzy wiedzą o co biega w temacie.
Poczekam już na finalną wersję 57, i od nowa postawie wersje portable, wbrew pozorom to nie jest wcale duzo roboty, wystarczy skopiować pliki z hasłami .


(plotex) #18

A więc problem wygląda tak. Korzystałem przez weekend z internetu dostarczanego drogą radiową. Problemów z ładowanie stron pod FF nie było, na lapku nic nie zmieniałem. Wróciłem do domu, podłączyłem się do netu i problem znowu się pojawiaj. Dostawca UPC (modem ConnectBox). Udostępniłem sobie hot-spot na telefonie i działa wszystko bez problemu.
FF nie ładuje tylko na necie w UPC. W tym samym czasie pod innymi przeglądarkami strony ładują się bez żadnego problemu.
Niestety jak próbowałem sobie przypomnieć, problem zaczął się w momencie, gdy został zaktualizowany connectbox, i nie pracuje mi jako modem (bridge, do niego mam podłączony swój ruter), tylko pracuje jako ruter. Obecnie nie ma opcji w ustawieniach przełączenia trybu pracy Connectboxa z rutera na modem.
Connectbox zresetowałem do ustawień domyślnych i podłączyłem lapka po kablu bezpośrednio do niego (aby wyeliminować swój ruter) i problem dalej jest.
Objaw jest podobny do tego co opisuję forumowicz na tym forum:
http://forum.benchmark.pl/topic/247080-compal-ch7465lg-lc-od-upc-co-jakiś-czas-blokuje-połączenie-pc-router/
Wyłączyłem w ustawieniach firewall’a ochrone przed atakami flood, trochę się poprawiło, ale nie w 100%.
Może ktoś coś wie więcej na co zwrócić uwagę? Dodam, że panel ustawień connectboxa nie powala, o wprowadzeniu swoich adresów np. dns, czy ustawień zaawansowanych można zapomnieć, więcej bajerów graficznych niż ustawień.


(Bogdan_G) #19

Mam UPC, mam Connectbox jako router na domyślnych ustawieniach. Zero problemów z FF.
We właściwości karty internetowych mam domyślnie adres serwera DNS


(plotex) #20

mam tak ustawione i jest problem