Google Chrome 89 nie pobiera plików - mieszana zawartość na stronach https

Problem jest taki, że przeglądarka Google Chrome, od bodajże 3-ech wersji, nie pobiera plików. Zaktualizowałem przeglądarkę do wersji 89, ale problem wciąż występuje.
Z rozszerzeń mam tylko uBlock Origin. Nawet wyłączenie rozszerzenia w niczym nie pomaga.

Dla przykładu, przeglądarka nie może pobrać tego pliku: https://www.retroarch.com/index.php?page=platforms
Po prostu nic się nie dzieje, żadnej informacji.
Z Wykresu usług Microsoft Update, też nie pobierze aktualizacji, np: https://www.catalog.update.microsoft.com/Search.aspx?q=KB2952664

Opera, czy też Firefox, pobierają pliki bez problemu.
Czasami jest to uciążliwe, przełączanie się między przeglądarkami.

Sprawdź czy Opera zmieniła silnik na wersje 89 Chromium.

Jak po aktualizacji też padnie to może aż w kodzie chromium jest coś nie tak.

Mam to samo.
Automatycznie tłumaczy stronę na język polski i brak pobierania pliku.
Jednak nawet jak ustawię, aby nie tłumaczył strony, również żadnej reakcji.
Tak chyba się dzieje, jeśli oryginalna strona nie jest w języku polskim i tłumacz coś miesza, nawet jak się ustawi, aby nie tłumaczył.
Z polskich ściąga normalnie.

Raczej ślepy trop z tłumaczeniem, zmiana języka interfejsu na angielski niby też wyłącza a się dalej nie pobiera.

To czemu z polskich ściąga prawidłowo?
FF z kolei nie chce przetłumaczyć strony na polski…dziwne.
I wówczas też nie pobiera…

Firefox ma archaiczną eksperymentalną obsługę tłumaczenia przez np. Bing/Google/Yandex (pewnie trzeba by nawet API tych tłumaczy uaktualnić). Dodatek z Moz://a Addons się nie liczy pewnie.

Konsola niby zwraca błędy zawartości mieszanej:

Czyli to efekt wymuszania źle https, wdrożonej w przeglądarce Google około wydania 85.

1lajk

Czyli stronki z mieszaną zawartością - Chrome po prostu blokuje tę niezabezpieczoną zawartość po http…tak?
Czy źle interpretuje dobrą zawartość jako niezabezpieczoną?
Bo albo strona źle jest kodowana, albo przeglądarka źle ją czyta?
Takiego babola przecież internauci zaraz by dostrzegli…

Tak, trzeba by przeciągać link na pasek kart (pobieranie rozpoczyna się) lub używać “zapisz jako” (i ignorować ostrzeżenie o braku szyfrowanego pobierania).

Opcjonalnie pisać do każdej “instytucji” by sobie linki poprawiła (do MS chyba się nie da, do retro arch pewnie można jako zgłoszenie problemu na github) lub znaleźć metodę na zluzowanie blokad treści mieszanych globalnie w Chrome 89+.

Raczej skrypt co by dopisywał S może nie zadziałać i generować errory 404/403.


Co do pisania stron to raczej utknęło pewnie w erze sprzed wymuszania HTTPS do wszystkiego lub dany webmaster nie zwracał uwagi czy domena ma regularnie odnawiany HTTPS.


Co do dostrzeżenia przez internautów to raczej to jest etap za późno jakby naprawiać to w kodzie Chrome.

Czyli to jednak wina leży po źle zakodowanych stronach.
A Firefox na to…

Po części też w kodzie Chrome czemu nie ma jawnego powiadomienia dla newbie, raczej nikt taki nie aktywuje konsoli by się dowiedzieć czemu pobieranie nie rozpoczyna się.

OK wszystko jasne.
Ważne, że można to obejść i pobrać.
Działa poprzez przeciągnięcie na nową kartę.

Dzięki za wyjaśnienie.
Czyli pozostaje tylko czekać, aż ogarną to a póki co, przeciągać na nową kartę.

Też zauważyłem ten problem na Chromowatych, ale rzadko używam przeglądarkowego pobierania, bo mam w sandboxie przeglądarki. Bywa też, że potrzebuję na chwilę tylko jakiegoś pliku, więc pobieram do RAMu.

Kopiuje link i resztę wykonuje za mnie działanie na schowku przekazując link do curl || aria2 || uGet

Polecam Firefoksa

Zastanawiałem się nad przejściem na Firefoxa, jednak on powoduje u mnie problemy z płynnym odtwarzaniem filmów na YT i to tylko na Firefoxie.
Może do Opery wrócę.