GTA 4 - nietypowy prblem z grafiką. :/


(system) #1

WITAM! :slight_smile:

Mam nietypowy problem z grafiką:

ORYGINAŁ. Gdy go pierwszy raz zainstalowałem chodził 1 dzień dobrze. Na następny włączam grę: STRASZNIE się wieszała i tak jak wyżej grafika coś nie teges. Przeinstalowałem stery do grafy, Direct'a ( 9.0 c) i oczywiście przeinstalowałem całą grę. Włączyłem ją i chodziła jak przedtem na początku. Czyli płynnie na średnich detalach na rozdzielczości 1280x960. Po 2 dniach znowu stało się to samo tyle, że się nie wiesza, a sama grafika się zepsuła. PROSZĘ O POMOC. Jakiekolwiek rady. Dodam, że wcześniej zmieniając rozdzielczość i wyłączając grę i włączając ja spowrotem problem znikał. Wracał jak ją znowu włączałem. Teraz to już nic nie daje. :? #-o

Pozdrawiam, i czekam na jakiekolwiek sugestie. :slight_smile:

(SPRZĘT PODANY W OPISIE)


(Goodprogram) #2

może temp. masz za duze ?

ile masz na procu i grafie ?


(system) #3

Ja mam dodatkowe czujniki, to:

płyta główna: 32

procek: 38 (kręcony z 2 x 2,2 na 2 x 2,45)

grafika: 45 (jak gram, niecałe 60 [ale miałem na niej tak zawsze])

A ogólnie w środku obudowy mam 25 stopni. :smiley:


(Garfield) #4

a pacza masz ?


(system) #5

Jakiegoś NAPEWNO instalowałem. Na v1.1 czy v1.2 bo wiem że wyszedł jak narazie 1.


(Garfield) #6

opisz w jakim momencie go instalowałeś...

btw. ta gra to jeden wielki bug także nie oczekuj za wiele :wink: raz jest tak raz tak [-o<


(system) #7

DOKŁADNIE TAK:

  • świeży WINDOWS,

  • Service Pack 3,

  • WSZYSTKIE sterowniki,

  • GTA 4

  • PATCH

  • gaming i ****************** się gry... :cry:

__________________________________

Czy Ty kolego nie potrafisz odpowiednio zachować się na forum nawet w tak świątecznym dniu, jak dzisiejszy ?

Nawóz potaniał ? :?

Uważaj, bo mimo święta coś się przyklei...


(Garfield) #8

a więc:

1.robisz skrót (jeżeli go masz to nie rób)

2.PPM

3.właściwości

4.element docelowy

5.dopisujesz -norestriction -nomemrestrict -DX9 /high ... jedziemy dalej

6.w miejscu docelowym (tam gdzie zainstalowałeś grę) tworzysz plik commandline.txt i w nim wpisujesz

-nomemrestrict -

vailablevidmem 2.0 -norestriction -percentvidmem 100

w jednej linii ze spacją na początku (nie enterem TO WAŻNE)

7.po tym wszystkim Defragmentacja

8.jeżeli to nie pomoże skocz z mostu :wink:


(system) #9

Dobra. Ale kilka pytań jeszcze. Nie da się DOPISAĆ w "element docelowy" tego: -norestriction -nomemrestrict -DX9 /high

I jak defragmentacja? :slight_smile:


(Garfield) #10

da się da dlatego napisałem, że masz zrobić skrót, a do skrótu da się podpisać

defragmentacja systemowa chociaż polecam Power Defragmenter :wink:


(system) #11

Dobra da się. Ale wcześniej nie mogłem bo to był ten skrót co się przy instalacji robi. A ten... Nie strace Save'ów? PROSZĘ! POWIEDZ ŻE NIE!

I tak dla pewności jak ma wyglądać to w pliku tekstowym?

TAK:

-nomemrestrict -

vailablevidmem 2.0 -norestriction -percentvidmem 100

CZY TAK:

-nomemrestrict - vailablevidmem 2.0 -norestriction -percentvidmem 100

nie wyłączaj forum bo ci jeszcze bede musial ZAJE**SCIE podziekowac jak bedzie dzialac. Jak nie bedzie to tez dzieki za pomoc! :slight_smile:


(system) #12

Ja z kolei proponuję zwiększenie pamięci wirtualnej. Sam wykorzystałem kilka Gb dysku jako pamięć RAM i dało to niezłe efekty (chociaż nie zawsze - tak jak wyżej wspomniał kolega ta gra to jeden wielki błąd).

  1. Otwierasz panel sterowania.

  2. Odszukujesz narzędzie "System"

  3. Wybierasz opcję "Zaawansowane ustawienia systemu" (W interfejsie VIsty znajduje się ona po lewej stronie okna, gdzie to jest w XP - nie pamiętam :twisted:)

  4. Otwiera się nowe okno z domyślnie zaznaczoną zakładką "Zaawansowane", naciskasz teraz pierwszą opcję od góry - "Ustawienia" (Efekty wizualne i wydajność).

  5. W nowym oknie naciskasz zakładkę "Zaawansowane", po czym opcję u samego dołu - "Zmień".

  6. Kolejne okno to już ostatni panel przez który będziesz musiał przejść, teraz po prostu zaznaczasz wybrany dysk lokalny, następnie naciskasz opcję "ustawienia niestandardowe" i zaznaczasz jako najmniejszą wybraną wartość np. tyle ile masz pamięci RAM, a z kolei za maksymalną wartość dwukrotnie większą od ilości Twojej pamięci RAM. Następnie przycisk "Ustaw" i standardowo "OK".

Mi ten prosty manewr pomógł, choć nie zawsze, ta gra jest po prostu spapraną konwersją z konsoli z katastrofalnie złą optymalizacją :twisted:

@UP Zapisów gry nie stracisz, sam korzystam z tego zabiegu choć nie bardzo rozumiem jego sens w tym problemie. Po przeprowadzeniu tego zabiegu będziesz mógł ustawiać stan grafiki bez znaczenia na możliwości sprzętu (domyślnie nie da się zwiększyć ustawień jeżeli PC nie wyrabia). Chyba że ta opcja ma jakieś inne, ukryte właściwości o których nie wiem :twisted:


(system) #13

Spróbuje tego co ty "TorresQSeven", a tego co kolego wyzej jak nie zadziala. Twoje "TorresQSeven" jest szybsze mi sie wydaje. :slight_smile: DZIĘKI ZA POMOC! KICK ROCKSTAR TO WIDNOW(S). :smiley: Jakieś inne propozycje mile widziane. :slight_smile: POZDRAWIAM!

NIESTETY NIE POMOGŁO "TorresQSeven" - ale dzięki za pomoc. :slight_smile:


(Garfield) #14

-nomemrestrict - vailablevidmem 2.0 -norestriction -percentvidmem 100


(system) #15

Jeżeli to nie pomogło, mam dla Ciebie kolejną propozycje. Podczas gry wciśnij ESC i w opcjach (tam gdzie jest opcja "Load") zaznacz Clips Off (domyślnie ON). Nie jestem pewien czy rozwiąże to Twój problem z teksturami, ale sam go przed chwilą przetestowałem i uzyskałem dzięki temu kilka(naście) FPS-ów więcej. Z pewnością ten manewr nie zaszkodzi (gra nie nagrywa po prostu filmików, a sądzę że jeżeli masz problemy z komfortową grą za to się zabierać nie będziesz :twisted: ) a gra dostaje niezłego "kopa".


(system) #16

To napewno nie pomoże, bo nie mam problemów z grywalnością a z grafiką. Tak mnie się przynajmniej wydaje, że chodzi i Shadery... Kliknąłem OFF i nie działa. Dalej to samo. Zobacz sobie Print Screen'a (na górze) jak nie widziałeś. :slight_smile:


(system) #17

Próbowałeś już defragmentacji? Jeżeli tak to czym prędzej się tym zajmij, na pewno nie zaszkodzi a pomoże nie tylko z GTA. Oprócz tego mam jeszcze jeden pomysł który mi pomógł, a mianowicie:

  1. Download Contig - Pobierz ten plik

  2. Rozpakuj pobrany plik do folderu z grą, a konkretnie do katalogu z plikiem .exe

  3. Stwórz do niego skrót (obojętnie np. na pulpicie, lub najlepiej w tym samym folderze - z plikiem .exe)

  4. Naciśnij PPM (na skrót) i wybierz opcję właściwości, następnie w linii komend (element docelowy) po cudzysłowu i spacji dopisz -s *.* -v

Ma to przykładowo wyglądać C:\Program Files\Rockstar Games\Grand Theft Auto IV\Contig.exe" -s *.* -v

  1. Następnie otwierasz skrót i czekasz... Zostaną po defragmentowane wszystkie pliki związane z GTA IV.

(system) #18

Tym razem już myślałem, że pomoże... a tu DUPA... ehhhh... Chyba tylko 1 rzecz wchodzi w gre... ZMIANA GRAFIKI. Ale dalej czekam na sugestie jakiekolwiek! :slight_smile: Dzięki "TorresQSeven" i tobie "goodprogram". :slight_smile: POZDRO! (CZEKAM! :slight_smile: )


(Garfield) #19

...ja bym jeszcze spróbował... podkręcić grafikę :wink:

RivaTuner i jazda (tylko nie przesadź)

jakie masz chłodzenie na karcie ?


(system) #20

Dobra, podkręce grafikę. Chłodzenie mam zwykłe.

http://images.dailytech.com/nimage/4968 ... 00_AGP.jpg <--- takie :slight_smile:

Czyli wentylator 60mm i radiator. Napiszę jak już podkręce. :slight_smile: Mam ją na PCI x16.

EDIT:

Przez te podkręcanie GTA już wogóle nie chodziło... :expressionless: Wieszało się jak bym grał jeszcze na ATi TNT i na jakimś Sempronie (takie porównanie... :slight_smile: ) Poszukam jeszcze na GTA Site... Ale jak narazie to swojego problemu znaleźć nie mogę. :expressionless: Zamiast szybciej chodzącej gry i wogóle ogólnej poprawy pokazywały się kreseczki, takie przez cały akren które szybko znikały i się pojawiały... Na pulpice to samo... Podkręciłem ją o 100 MHz na procu i 80 na RAM'ie.