Instalacja L. Mint 18 obok W8 - awaria, problem z GRUB


(Bartolini234) #1

Cześć.
Postanowilem przeczyścić nieco laptopa po semestrze i ogarnąć instalację Windowsa 8 obok Linux Mint(a właściwie na odwrót, ale to jest najmniej tu ważne).
Laptop to dell 3537, niestety ście**o z UEFI - wyłączyłem je, bo gdy był włączony nie chciał się odpalić pendrive z Mintem. Zmieniłem typ partycji dysku na MBR(wcześniej miałem Windows 10, typ był GPT). Windows sobie hula - nie ma problemów. Wyłączyłem fastboot, instaluję tego Minta, idzie gładko aż do końcowego etapu - dostaję informację, że instalator uległ awarii. Chwilę wcześniej był komunikat o braku możliwości zainstalowania GRUBa w trybie UEFI(musiałem wymusić ten tryb, aby pójść dalej z instalacją). Obecnie laptop stoi obok z odpalonym tym komunikatem, nie wyłączałem niczego. Ktoś ma jakiś pomysł, jak w tym trybie wymusić instalację GRUBa z terminala i cieszyć się oboma systemami na raz?
Niedługo będę też wymieniał w nim dysk, więc można by też przemycić jakieś rady na temat instalacji z UEFI, o ile to możliwe, bo po tych przebojach zacząłem wątpić.


#2

Najfajniej opisaną instalację masz na wiki Arch, Manjaro, Ubuntu.
Z tego co napisałeś może wynikać, że… sesja Windows nie została zakończona. Żaden instalator nie poradzi sobie z tym. Z czego wnioskuję “(…)z UEFI - wyłączyłem je, bo gdy był włączony nie chciał się odpalić z pendrive z Mintem”. Takie zachowanie jest najczęściej przypadkiem “zamknięcia” Windows, a nie “wyłączenia go”. Czyli Windows sobie śpi i uniemożliwia cokolwiek.
Sprawdź - bo 100% pewności nie mam.


(Bartolini234) #3

Czekaj - ale jak? Klikam w Windowsie Zasilanie -> Zamknij, system się zamyka, wszystkie diody z przodu laptopa gasną.
To chyba oznacza, że się wyłączył “definitywnie”? Jeśli chodzi o to, że był zahibernowany/nie wyłączony poprawnie i przez to np. instalator nie mógł zamontować partycji to raczej nie; przed jej uruchomieniem sprawdziłem zawartości partycji i się otworzyły - czyli Winda ich nie blokowała. Dopiero potem zacząłem instalować, zmieniłem też jedną z partycji na ext4(była pusta itd., właśnie do tego celu). Dopiero instalacja gruba się nie powiodła, dodatkowo instalator się zawiesił - po jego zamknięciu miała być możliwość wysłania błędu do deweloperów, ale okna nie dało się zamknąć itd.


(Domker) #4

Chyba nie ogarniasz do końca tematu.
Jeżeli chcesz instalacji do MBR dysku to:

  1. Włącz w BIOS CSM, ustaw tryb “Legacy”, jeżeli masz taką opcję to zmień z Windows na “Other OS” i przy niektórych płytach głównych jeszcze trzeba ustawić, aby nośnik UEFI nie miał pierwszeństwa przy bootowaniu.
  2. Upewnij się, że nie ma partycji EFI jeżeli robiłeś konwersję z GPT.
  3. Zrób jeszcze raz nośnik USB z Mint programem Rufus i wybierz typ dla MBR.
    Instalacja powinna pójść gładko.

BTW instalacje GRUB możesz wykonać z terminala:
Najpierw trzeba zrobić “chroot”:
Wpisz:

sudo fdisk -l

A następnie zlokalizuj partycję z systemem Linux

Teraz trzeba zamontować tą partycję:

sudo mount /dev/sdaX /mnt

Za “X” podstaw numer zlokalizowanej partycji z Linuxem! (tylko się nie pomyl)
Następnie montujesz:

for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done

Jak się powiodło to robisz “chroot”:

sudo chroot /mnt

Teraz instalacja GRUB:

sudo grub-install --recheck /dev/sda
sudo update-grub

Teraz odmontowanie:

exit
sudo umount /mnt/dev/pts /mnt/dev /mnt/proc /mnt/sys /mnt


Błąd przy aktualizacji pakietów w Linux Mint
(marcin82) #5

To bez ‘sudo’ - jesteś już rootem:

[quote]grub-install --recheck /dev/sda
update-grub[/quote]


(Bartolini234) #6

Teraz nic z tych poleceń nie będzie, wyłączyłem laptopa jakiś czas temu, instalacja się nie udała.


(Bartolini234) #7

Poszło, po przygotowaniu pendrive’a programem Rufus. Nie wiem co dokładnie było źle, bo w konfiguracji nie ruszałem nic.