Instalacja sterowników graficznych na Virtual Boxie


(kisame.) #1

Witam mój pierwszy temat na forum jako że z komputerami nie jestem jakoś szczególnie dobrze zaznajomiony taki tam typowy laik więc nie mam pojęcia jak rozwiązać mój problem. Po około 10h pracy nad tym( prób,przeglądania stron internetowych wszelkich itd dałem sobie spokój i uznałem że napiszę o pomoc bo to przerasta moje siły jak widać :?

Otóż problem jest taki. Posiadam windowsa 8 ale że na nim starsze gry nie odpalają chciałem zainstalować win xp. Zrobiłem to poprzez wirtualizację w programie VirtualBox. Zainstalowany system to windows xp home edition. Sterowniki karty graficznej intela nie chcą się zainstalować wyskakuje błąd "ten system nie spełnia minimalnych wymagań dotyczących instalowania tego oprogramowania". I podejrzewam że to jest źródłem mojego problemu. Zajrzałem też w menedzer urządzeń i nie ma tam opcji takiej jak karty graficzne.

Tutaj zrzuty z grafiki chyba win 8 i tego wirtualizowanego xp

 

7fa71e2086863f11m.png


(Dimatheus) #2

kisame. , zapoznaj się, proszę, z tym tematem i stroną, a następnie - korzystając z przycisku Edytuj (na dole pierwszego posta po prawej stronie) i opcji Użyj pełnego edytora - popraw tytuł wątku tak, by mówił konkretnie o problemie. Poprawnie zatytułowany wątek zwiększa szansę na uzyskanie szybkiej pomocy. Zignorowanie tej prośby będzie skutkować przeniesieniem tematu do kosza.

Pozdrawiam,

Dimatheus


(Adammo) #3

W przypadku wirtualizacji instalujesz sterowniki dodane do VirtualBox. Wystarczy uruchomić XP i wybrać z menu VirtualBox: Devices->Insert Guest Additions CD image…

Zamontuję to obraz CD który posiada instalator z potrzebnymi sterownikami.

 

PS: Jakie to gry nie chcą ci działać na Windows 8? Próbowałeś tryb zgodności (prawy na ikonkę z grą->Właściwości->Zgodność)?


(kisame.) #4

Zrobiłem jak mówiłeś, pojawiła się instalacja virtualboxa i teraz mam coś takiego

 

614fae5166ad4e2bm.png

 

A co do drugiego pytania to chodzi mi o grę Kozacy 2 i tryby zgodności nie pomagają. Różne rzeczy próbowałem i nic:(


(Dimatheus) #5

Hej,

Po prostu wybierasz Mimo to kontynuuj.

Pozdrawiam,

Dimatheus


(kisame.) #6

hmm widzę już jakiś postęp:) a z tym pomożecie? włączam grę i mam takie coś( to powiadomienie na górze"the virtual screen")

 

f93f63c78035308em.png

 

a gdy włączam uruchom jako administrator mam coś takiego

 

 

844bb9e55ebf8c74m.png

 

Aa i jeszcze dodam że jest to laptop aspire E 530


(Dimatheus) #7

Hej,

Pierwszy komunikat dotyczy ustawienia jakości kolorów w systemie wirtualnym - wejdź we właściwości pulpitu i w ostatniej zakładce zmień kolory na 32-bitowe.

W przypadku drugiego screena warto sprawdzić, czy nie ma jakiś logów w katalogu z grą.

Pozdrawiam,

Dimatheus


(kisame.) #8

Po zmianie na 32 chwilę coś się robi(przez chwilę widok jak w win 95 jakby)a potem wraca do 16 z powrotem. A gdzie sprawdzić te logi? bo ja kompletny laik:)

Edit zobaczyłem jeszcze raz mając włączone ustawienia i stoi ciągle na 32 bity a mimo to dalej tamto powiadomienie


(Dimatheus) #9

Hej,

Zatem po prostu kliknij w x i powiadomienie powinno zniknąć. Co do logów, popatrzyłbym w folderze z grą.

Pozdrawiam,

Dimatheus


(kisame.) #10

Hm teraz po uruchomieniu zauważyłem że w folderze z grą po każdym razie tworzy się plik tekstowy !!crash!! i plik !!crash!!. dmp

Mogę dać screeny z tego pliku tekstowego jeśli się przydadzą


(Dimatheus) #11

Hej,

Tak, pokaż jaka jest zawartość tych plików.

Pozdrawiam,

Dimatheus


(kisame.) #12

Kolejne odkrycie jest takie że po przestawieniu w ustawieniach na rozdzielczość 1386:846 pokazuje mi się taki błąd a przy 800:600 nic mi się nie pokazywało

0bc224ef9496807em.jpg

 

 

 


(wirtualizacjawit) #13

Przyznaj do system gościa około 1 GB RAM. Następnie ustaw sobie rozdzielczość 1024×600 (w XP) i uruchom wtedy grę. Coś się pokazało ?


(kisame.) #14

Po zmianie rozdzielczości niestety dalej to samo co w przypadku rozdzielczości 800:600. Czyli chwila jakby się ładowało i tyle. Do gościa przyznane ram 2 gb chyba ale nie wiem czy o to ci chodziło więc daję screena

438687d31a1e77f1m.png

 

Po próbie włączenia w rozdzielczości 800:600 i 1024:744 nic się nie pojawia a jeśli uruchamiam jako administrator pojawia się komunikat o crashu (jest na screenie w którymś z moich poprzednich postów)

 

W folderze z grą pojawiają się przy tym dwa pliki !!crash!! tekstowy i !!crash!!.dmg.

Tutaj screeny z crasha jako że nie umiem wrzucić całego pliku. Jest więcej stron ale to są te chyba najważniejsze bo tamte już się powtarzają ale jak trzeba to wrzucę

75c4946cb8191f5dm.jpg

2beeba990acd5b1em.jpg

b84ab38cbb6f5841m.jpg

79297962eb490671m.jpg


(Dimatheus) #15

Hej,

Czy w ustawieniach Virtual Boxa masz zaznaczoną w ustawieniach ekranu opcję przyśpieszenia akceleracji 2D i 3D?

Pozdrawiam,

Dimatheus


(kisame.) #16

Miałem samo 3D teraz włączyłem też 2D ale nic nie pomogło

 

Zależy mi też na pełnym ekranie czyli musi być rozdzielczość 1366:768 bo w innym wypadku 800:600 są czarne pasy a ekran pomniejszony.

Ale wtedy jest ten błąd “assertion error” który zamieściłem na którymś poprzednim screenie


(Dimatheus) #17

Hej,

Ale w przypadku rozdzielczości 800x600 gra ostatecznie się uruchamia?

Pozdrawiam,

Dimatheus


(kisame.) #18

No właśnie rzecz w tym że nie. Przez moment jakby coś się uruchamiało i na tym koniec


(Dimatheus) #19

Hej,

Z tego wniosek, że ciężko będzie uruchomić grę z pełną akceleracją sprzętową 3D na Virtual Boxie. Można zatem spróbować innego rozwiązania - Vmware Playera. http://www.dobreprogramy.pl/VMware-Player,Program,Windows,13312.html Program ten wiele lepiej obsługuje akcelerację 3D.

Pozdrawiam,

Dimatheus


(kisame.) #20

Ok to jedziem od nowa niedługo poinformuję o rezultatach:)