Instalacja zamkniętego sterownika NVIDIA-Linux-x86_64-340.24


(wojownik) #1

Witam, 

 

Działam sobie na otwartym sterowniku , i postanowiłem zainstalować sterownik ze strony Nvidia.

 

NVIDIA-Linux-x86_64-340.24

 

Podczas instalacji wyświetla się taki komunikat 

 

  ERROR: You appear to be running an X server; please exit X before            
         installing.  For further details, please see the section INSTALLING   
         THE NVIDIA DRIVER in the README available on the Linux driver         
         download page at www.nvidia.com.

Poogoglowałem i działałem wg. http://linuxg.net/how-to-install-the-nvidia-340-24-driver-on-linux-systems/

 

Po wydaniu polecenia sudo /etc/init.d/lightdm stop

pojawia się czarny ekran i migający kursor - nic nie można wpisac nic się nie dzieje.

 

najnowsze xubuntu 64 bit - grafika gf 750 ti

 

dziękuje za pomoc

 


(LeserGD) #2

Ctrl + Alt + F1 powinno załatwić sprawę.


(wojownik) #3

Ctrl + Alt + F1 - wydaję :

sudo ./nvidia.run ( zmieniłem nazwę ) i wyswietla się taki komunikat :

 

error: you appear to be running an x serwer :pleas kill x before installing. 

 

:frowning:


(marcin82) #4

Nie wiem czy będzie działać, ale spróbuj uruchomić system w trybie w trybie teskowym, dodając zaraz po ‘rw’ opcję jądra: 1.


(wojownik) #5

czy możesz to szczegółowo opisać ?


(Lightextract) #6

Próbowałeś podłączyć repozytorium sterowników w celu zainstalowania ich w formacie DEB? To najprostsza i najprzyjemniejsza sprawa… a jeżeli nie zależy Ci na najświeższym, a wystarczy Ci prawie najświeższy sterownik - to instalujesz go jeszcze prościej niż na Windowsie poprzez manager pakietów Synaptic.


(wojownik) #7

można spróbować - czy sterownik jest już w synaptic ? jak tak to jaka cyferkę ( nazwe wybrać ) by nie natrafić na otwarto-źródłowy ?


(Lightextract) #8

Synaptic > Ustawienia > Repozytoria > Dodatkowe sterowniki


(roobal) #9

Uruchom ponownie komputer i włącz go w trybie recovery. Jeśli nie masz takiej pozycji w Grubie uruchom system w trybie single mode, dopisując ręcznie parametr jądra. System uruchomi się w trybie tekstowym. Logujesz się na roota i instalujesz sterownik.


(marcin82) #10

Najpierw zainstaluj pakiet:

sudo apt-get -y install sysv-rc-conf

Następnie uruchom ten program z prawami roota:

sudo sysv-rc-conf

 

Odznacz za pomocą spacji usługę lightdm na 3 poziomie uruchamiania (to jest tabelka będziesz wszystko wiedział). Wyjdź z programu - bodajże Escape.

 

Następnie zrestartuj komputer - na ekranie wyboru systemów Gruba wciśnij spację, ustaw się na pierwszej pozycji od góry. Następnie wciśnij klawisz e , odszukaj linię, która wygląda podobnie do tej:

i zmień na taką:

linux /boot/vmlinuz-linux-lts root=UUID=229f835b-e1c6-4531-8431-269a72df148a rw 3

Następnie wciśnij F10. System powinien uruchomić się w trybie tekstowym .

 

W poprzednim poście się machnąłem - miałem na myśli poziom 3 - multiuser z obsługą sieci.


(Lightextract) #11

Naprawdę konieczne jest instalowanie sterownika z formatu binarnego? :-D  3 linijki… jak nie będzie działać, czy X’y padną to do dyspozycji ostatnia linijka.

$ sudo add-apt-repository ppa:xorg-edgers/ppa
$ sudo apt-get update
$ sudo apt-get install nvidia-340

Usuwanie:

$ sudo apt-get remove nvidia-340

(wojownik) #12

Luki_2 - to tak fakt próbowałem ale : w wyborze dodatkowych sterowników są 3 możliwości i są to sterowniki otwarto-źródłowe - brak sterowników zamkniętych :slight_smile: po kolei sprawdzę kolejne metody.

 

Luki - zainstlowałem wg tego co napisałeś - po resecie pc - zmiana rozdzielczości na bardzo mała - w wyborze sterowników brak tych właśnie zainstalowanych - jak uaktywnić( czy sprawić ) by stertowniki zamknięte działały jak należy? 


(ra-v) #13

 

Ponieważ X-y trzeba wyłączyć poleceniem init 3 (z Ubuntu raczej z sudo )

 

Instalacja sterownika w postaci binarnej nie powinna wyglądać inaczej niż tutaj:

http://youtu.be/POVqUhto5EM


(roobal) #14

Po co tak kombinować jak wystarczy uruchomić system w signle mode?


(wojownik) #15

w praktyce : mam najnowsze sterowniki Nvidia - najnowsze xUbuntu  i nie można zainstalować zwykłych sterowników dla systemu ??? - żadena z opisanych  metod nie działa .

Używam z musu sterowniki otwarte - ale na przekór chcę te zamknięte . 

Nie da się ? Rozumiem dlaczego kolejny rok nie będzie rokiem Linuxa - ludzie się zrażają. hehe

Pomocy :slight_smile:

 

edit : godzina 8:05 - są postępy - ctr + alt + f1, następnie sudo /etc/init.d/lightdm stop

 

sudo sh instal nvidia.run - instalacja rusza - kończy się sukcesem . 

Po uruchomieniu kompa wszystko jest w niskiej rozdzielczości a w menagerze sterowników tylko otwarte stery - jak uaktywnić czy co zrobić by niby zainstalowany sterownik kontrolował kartę graficzna i czy on się faktycznie zainstalował … ah

 

edit2 : godzina 8:17 - jako że sterownik zamknięty się zainstalował niby, postanowiłem za pomocą synaptica odinstalować wszystkie pakiety związane z nvidia.

Po uruchomieniu ponownym blaszaka nvidia xserver settings wskazuje sterownik 340.24 :slight_smile:

dziękuję wszystkim za zainteresowanie i pomoc serdecznie .

 

edit3 - na zamkniętych sterownikach nvidii nie uruchamia się Warthunder, na otwartych jest spoko ale wywala mnie z bitew klanów - musze zainstalować windowsa - porażkę poniosłem :frowning:


(marcin82) #16

 

Bo wybrałeś taką dystrybucję, która nie obsługuje najnowszych sterowników z serwerem X, który jest w tej wersji Ubuntu - prawdopodobnie.

 

Sprawdź Manjaro Linux.

 

Czemu nie będzie rokiem linuksa?

 

Bo ludzie nie chcą słuchać, tylko na siłę sobie sami utrudniają i chcą instalować na piechotę zamiast instalować sterowniki z repozytorium dystrybucji bądź z PPA, które ludzie dostali na tacy …


(wojownik) #17

marcin’82 - same sterowniki - ich mnogosć , otwarte, zamknięte - taka instalacja dedykowanych sterowników ze strony producenta powinna sprowadzać się do 5 kliknięć, tak po prostu - bez zależności jaką dystrybucję wybrałem czy to Ubuntu, czy ARCH - skąd mam wiedzieć czy Debian jest dystro które obsługuje najnowsze sterowniki - skąd takie informacje brać - to nie takie proste. dlatego ludzie się zrażają. 

Dziękuję bardzo za pomoc finalnie sterowniki działają - ale nie spełniają zadania - moja gra sie na nich nie uruchamia ( przez pol :slight_smile:

pozdrawiam


(Lightextract) #18

Jaką kartę graficzną posiadasz? Dziwne, że do wyboru masz jedynie otwartoźródłowe sterowniki. Niska rozdzielczość po instalacji sterowników z “uniwersalnego” repozytorium nie jest raczej czymś nienormalnym, tzn. chyba jednak nie załapał poprawnie sterownik zamknięty. Ubuntu posiada własne repozytorium ze sterownikami i dzięki temu można prosto zainstalować je z karty “Dodatkowe sterowniki” świeżo po instalacji systemu i później, ale u Ciebie ich nie ma… dziwne. Nie kombinowałeś jakoś w systemie czy coś?  Może powyłączałeś jakieś repozytoria? Normalnie to wygląda tak jak napisałem - “Dodatkowe sterowniki”, wybierasz sterownik własnościowy, czekasz, odpalasz ponownie i gra, z tym że jest to jednak PRAWIE najświeższy sterownik, a nie najnowszy. Na kilku komputerach tak to dokładnie wyglądało i tak wyglądać powinno, jeżeli masz nvidie. Pamiętaj, że dołączanie nieoficjalnych repozytoriów jest ryzykowne i może mieć różne niefajne skutki. Ta gra o której piszesz to pod Wine?  Jeżeli tak, to nic dziwnego, że może nie działać :stuck_out_tongue:


(ra-v) #19

 

F7 może czynić to co init 5 w innych systemach. BTW. Sam nie wiem czy brak “init” to wynik kombinacji z Mirem.

 

Ewentualnie można uruchomić w jakimś trybie rescue z tym samym jądrem ale bez obsługi grafiki i spróbować wrzucić sterowniki.

 

 

 

Autor napisał w pierwszym poście:

xubuntu 64 bit - grafika gf 750 ti


(wojownik) #20

W systemie nic nie mieszałem - jak zainstalowałem tak był, w wyborze sterowników były 3 - otwarte sterowniki.

Gra uruchomiona pod wine za pomocą playonlinux - na sterownikach otrwartych działała - chciałem zapewnić wiekszą wydajność to nie zadziałała pod oficjalnymi sterami Nvidia wcale .