Jak sprawdzić sterowniki wbudowanej w laptopa kamery


(martz) #1

W laptopie znajdował się od nowości program Crazy Talk Cam Suite służący do uruchomienia wbudowanej kamery oraz posiadający "śmieszne" efekty jak zastępowanie obrazu animacją lub dokładanie do realnego obrazu np.okularów na nos, czapki na głowę.

Ale do rzeczy program bez włączonej kamery działa szybko sprawnie i bez problemów, za to przy włączonej wbudowanej kamerze zaczyna wolno przełączać animacje a przy

dodawaniu elementów do obrazu (czapki, okularów itp.) ostatecznie się zawiesza, procesor leci na obciążenie 100% i tak już zostaje do zamknięcia go przez menadżer zadań. Po wyłaczeniu obciążenie nagle spada.

Producent programu odpowiedział mi, że problemu należy szukać w systemie. Posiadam Vistę HP SP2. Nie jestem pewien w którym momecie się to stało ale może jest to wynik instalowania drugiej starej kamery zew.Logitech E3500-która się zacinała zresztą-podobno jakieś niedopracowane sterowniki na vistę. Ale już programy od tej starej kamery odinstalowałem. Zmieniałem też antywirusa z Nortona na G-Data. Inne instalacje i deinstalacje robiłem drobnych programów użytkowych, raczej nic nie znaczących i nie używajacych kamer.

Podejrzewam jakieś uszkodzenie sterowników albo nieodinstalowanie całkowite sterowników od kamery zew.które może sprawiają konflikt.

Nie mogę znaleźć w menadżerze urządzeń samej kamery wbudowanej, nie mówiąc o tym, że nie wiem gdzie szukać i jak sprawdzić jej sterowniki?

Dzięki za ew. podpowiedź. Pozdrawiam.


(Jas162) #2

Napisz jaki model lapka masz. Szukałeś na stronie producenta?


(martz) #3

Lapek Msi EX 620, na stronie producenta przy sterowniku do kamery jest wyjaśnienie, że to urządzenie używa "native" sterownika załączonego do systemu:

http://pl.msi.com/index.php?func=nbdriv ... os_no=2#os

robić recovery całego systemu? ; ale se wymyślili sterownik..... dlatego go niemożna znaleść.... i szach-mat.


(Jas162) #4

Może spróbuj pobrać i zainstalować go jeszcze raz. To stronka producenta Crazy Talk Cam Suite:

http://www.reallusion.com/crazytalk/crazytalk_trial.asp

Tu coś jest na temat tego softu:

http://msiwindforum.pl/topic70-jak-odpalic-kamerke.html


(Łukash) #5

Tu masz program

Co do identyfikacji sprzętu to może w Everest kamerka będzie w jakiś sposób widoczna,jak będzie to połowa sukcesu,a zainstalować takie oporne urządzonaka można przez Devcon


(martz) #6

Posiadana przezemnie wersja programu Crazy Talk Cam Suite to 2.0-na stronie producenta Reallusion jest tylko najnowsza wersja 6-zapewne mój klucz od starszej wersji nie zadziała. Ale producent laptopa zamiescił set up na dysku D: i stamtąd po odinstalowaniu programu, instalowałem go ponownie-jednak bez zmian, tak jak było.

Za to przeanalizowałem sterowniki systemu programem DriverFetch, pokazuje, że sterowniki do wbudowanej kamery nie wymagają aktualizacji (aktualizowałem je równiez prosto z systemu) ale pokazało przy okazji, że siedzą w systemie sterowniki od starej kamery Logitech E-3500. I jak się ich pozbyć, skoro zupełnie nie mogę namierzyć miejsca w systemie (vista HP sp2) gdzie one mogą się znajdować ?

Czy jedyne rozwiązanie to skorzystanie z programu Everest i ew. Devon-jeśli istnieje wersja obsługująca vistę?


(Łukash) #7

Instalacja Everest-2 minuty,Devcon działa na viście.


(martz) #8

Patrząc na Everesta (5.50) znalazłem również w systemowym menadżerze urzadzeń pod Imaging devices - USB 2.0 Cam (kamera jest wbudowana a nazwa USB?), tam też włączyłem aktualizacje sterownika z sieci ale podaje, że jest ten sam, w porzadku. Więc jeśli program do obsługi kamery jest doby, sama kamera działa, sterownik ma dobry to co się uszkodziło?

Czy siedzący gdzieś w systemie sterownik od innej kamery Logitech E-3500 (nie wiem jak sie go pozbyć) może mieć na to wpływ a może to zupełnie inna przyczyna?


(Łukash) #9

Teraz jak możesz napisz,czy kamerka działa np z skype'em,oraz czy zależy ci na kamerce+Crazy Talk.Jeżeli program drenował ci procka to raczej sam program/sterowniki są niedopracowane a nie jak sądzą producenci.A sterownik do zewnętrznej nie powinien mieć raczej na 100% wpływu na działanie wbudowanej,jeżeli jest odinstalowany to jest odinstalowany.

Można by spróbować odinstalować w menadżerze urządzeń kamerkę,potem skan w poszukiwaniu zmian sprzętu i powinno ją wykryć,ewentualnie restart. Zaznaczam powinno nie mam pewności co do tego.

A i w takich przypadkach może pomóc też devcon.PPM na urządzenie>właściwości>szczegóły>identyfikator sprzetu

potem w devcon bodajże tak:

devcon update mydev.inf *tu identyfikator

enter


(martz) #10

z pracą kamery w skypie, nie było i nie ma problemów,

-mozna tam wybrać bądź kamere poprzez program Crazy Talk(ustawienie nazwano kamera virtualna) lub bezpośrednio samą kamerę bez użycia Crazy Talk(wówczas trzeba wyłaczyć ten program),

-bez problemów również odinstalowałem i zainstalowałem samą kamerę (wraz ze sterownikiem) z menadzera urządzeń-nawet dwa razy, powtórzyłem odinstalowanie całego programu Crazy Talk Cam Suite(ver 2.0), restart a nastepnie zainstalowanie z set up-a na D: i restart.

Jedynie przez chwilę zaczęły działać efekty dodawania obiektów do obrazu rzeczywistego, co również zdarzało się uprzednio aby na koniec się ostatecznie zawiesić.

Tak jak procesor dostawał obciążenia =/- 80% po samym właczeniu programu Crazy T... a po włączaniu funkcji zmiany obrazu i dodawaniu efektów 100%, tak nadal się dzieje. Tak jakby mu brakowało miejsca w obciążeniu na wykonanie zadania. Sam komputer po właczeniu pokazuje +/- 10% obciażenia.

Ponieważ mniej więcej w czasie kiedy się to uszkodziło zmieniałem program antywirusowy, sprawdziłem też działenie Crazy Talk przy wyłączeniu antywirusa (G Data Internet security 2010) razem z firewallem i autopilotem-niestety nic to nie dało nadal bez zmian. Może by trzeba było go odinsatować i wrócić do Nortona?

Tak zależy mi na działaniu tego programu (dla małego dziecka jest to fajna rozrywka w czasie rozmowy), chciałbym utrzymać efekty jakie dawał wcześniej.

Pamiętam, że wtedy kiedy działał prawidłowo również znacznie obciążał procesor ale nie aż tak żeby sie zawieszać. Nawet usunąłem program Du meter pracujący w tle, a także staram się wyłączać Sidebar-choć z niego odczytuję obciążenie procesora.

Czy rzeczywiście spróbować wrócić do jakiejś bezpłatnej wersji nortona?


(Łukash) #11

Czy wrócić do nortona?Jeżeli mogę się wypowiedzieć to ja osobiście unikam kombanjów Internet Security czyli norton,gdata,kaspersky ,np nowy Avast jest ciut lepszy niż był kiedyś,a z samych antywirusów ostatnio testuję Panda Cloud Antywirus(+zapora systemowa i rozwaga a i w vista jest kontrola rodzicielska )jestem mile zaskoczony malutko jej potrzeba zasobów naprawdę i jest niezła.Jeżeli wcześniej działało to może i w tym rzecz...


(martz) #12

niestety, nawet przy odinstalowanym antywirusie nadal wystepuje ten sam problem, także ponownie odinstalowałem i zainstalowałem kamerę i jej program Crazy Talk a więc co mogło zostać zmienione w systemie, że aż tak upośledza działanie tego tylko (jak na razie programu) ?


(Łukash) #13

W jaki sposób są widoczne sterowniki do zewnętrznej ,zrób zrzuty wszystkich informacji.


(martz) #14

Sterowniki od odinstalowanej kamery zewnętrznej logitech E-3500 pokazało mi po skanowaniu programem DriverFetch, pokazuje on stan wszystkich sterownikow u mnie w raporcie zamieścił zalecaną aktualizację kilku rzeczy (dzwięk, itp.) natomiast w wiekszości sterowniki są zaktualizowane a konkretnie przy kamerach oprócz wbudowanej znalazla się informacja o aktualnych sterownikach właśnie drugiej kamery Logitech E-3500, ku mojemu zaskoczeniu i tylko w ten sposób dowiedziałem się o ich istnieniu gdzieś w systemie. Wydawało mi się, że zostały odinstalowane razem z programami Logitech-a od niej.

Co do zrzutów to nie bardzo wiem jak, gdzie i czym je zrobić?


(Łukash) #15

Zainstaluj SIW (tools>option>laguage>polish)>Sterowniki>i zobacz czy jest ten sterownik,jak będzie to sprawdź w kolumnie Status czy on działa ,czy nie,może będzie też ścieżka to pliku,i zastanowimy się co dalej...


(martz) #16

Sterownik ma status stopped, typ-kernel driver, ścieżka dostępu: system32\DRIVERS\lvuvc.sys w rybryce Start jest wpis Demand Start

a skolei podglądając go w systemie widze, że ma 6 599 KB, typ-System File a powyżej nad nim o tej samej nazwie ale innym rozrzerzeniu lvuvc.hs, typ HS File, 0 KB

?


(Łukash) #17

Sprawdź we właściwościach czy pliki są podpisane-(mogą być ale nie muszą)-czy o te właśnie chodzi,i czy zostały utworzone w tym samym czasie,jak tak to to raczej będą z jednej paczki, zrób punkt przywracania systemu i może je usuń,nie mam innego pomysłu.


(martz) #18

lvuvc.sys (6,44MB) file description-Logitech USB Video Class Driver wszystkie daty z 7 października 2009

lvuvc.hs (0KB) jest name: lvuvc.hs i daty: created i accessed 29 marzec 2009 a modified 1 kwiecień 2010

oraz details obu plików róznią się więc czy mimo różnicy dat kasować oba?


(Łukash) #19

może tymczasowo je wytnij i wklej do jakiegoś folderu(dokumenty czy coś w tym stylu),i zobaczymy czy to coś daje.


(martz) #20

niestety, w pierwszym momencie myślałem, że już się coś odblokowało ale niestety jest bez zmian, spowrotem wstawiałem raz jeden plik, raz drugi, instalowałem ponownie program, kamerę, restarty i nic absolutnie się nie zmieniło, program świetnie działa bez włączonej kamery a jakby zatyka się przez nadmierne-non stop 100% obciążenia procesora-przy włączonej kamerze, co może mu dodawać obciążenia, wcześniej kiedy działał również dawał duże obciążenie ale nie aż takie.