Jak to sprawdzić, czy karta graficzna dostała prawidłowy sterownik?

Cześć.

Posiadam laptopa HP Pavilion G6 1050ew.

Powinien mieć on kartę graficzną: AMD Radeon HD 6740m.
Oto jej identyfikator sprzętu który widzę w menedżerze urządzeń: PCI\VEN_1002&DEV_6760&SUBSYS_1669103C&REV_00

Gdy wpisuję w stronę AMD produkt, którego szukam, czyli “6470m” poprawnie przechodzę do strony pobierania i pobieram plik o nazwie “whql-win8.1-win7-catalyst-15.7.1-oct30.exe”.

Okej, instaluję sterownik i w menedżerze urządzeń widzę że nazwa mojej karty graficznej to “AMD Radeon HD 7400”.

I zgłupiałem. Czy zainstalował się poprawny sterownik? Nie satysfakcjonują mnie odpowiedzi w stylu “tak ma być”, lecz chciałbym wiedzieć jak to sprawdzić, czy moja karta graficzna dostała prawidłowy sterownik i czy poprawnie funkcjonuje.

Jeśli toś miałby pomysł to proszę o pomoc.

Dziękuję :slight_smile: .

Witaj.

  1. Masz wszystkie sterowniki do płyty głównej zainstalowane i aktualne?
  2. Masz sterownik do karty Intel aktualny?
  3. Sprawdź poradę, nieaktualny sterownik Intel może być powodem
    6470M automatically changed to 7400M…

Cześć, dzięki za odpowiedź.

Sterownik Intel HD mam w wersji 8.15.10.2993.

Sterownik chipsetu taki:

Opis

TITLE: Intel Chipset Installation Utility and Driver

VERSION: 9.2.0.1015 REV. A
DESCRIPTION:
This package contains the Intel Chipset Installation Utility and Driver for supported notebook models and operating systems. This utility enables the operating system to show the correct name for the installed Intel hardware in the Microsoft Windows Device Manager.

PURPOSE: Recommended
SoftPaq NUMBER: SP52791
EFFECTIVE DATE: April 18, 2011
CATEGORY: Driver - Chipset
SSM SUPPORTED: YES

DEVICES SUPPORTED:
PCI\VEN_8086&DEV_3B42=“Intel ® 5 Series / 3400 Series Chipset Family PCI Express Root Port 1 - 3B42”
PCI\VEN_8086&DEV_1C10=“Intel?CPT Chipset Family PCI Express Root Port 1 - 1C10”

Pobierz Crimson Edition 16.2.1 Beta Radeon i zapisz na pulpicie.
Zainstaluj nowsze sterowniki Intel HD
win64_15.36.36.5067

Po restarcie wejdź w Menedżera Urządzeń i usuń kartę graficzną Radeon.
Następny restart i spróbuj zainstalować pobrany wcześniej sterownik do Radeona
Kolejny restart i sprawdź w Menedżerze Urządzeń, czy zainstalowało jako 6470m

Napisz co się udało a co nie.

Pierwszy link mi nie działa, drugi po uruchomieniu instalatora pokazuje komunikat “Ten system nie spełnia minimalnych wymagań dotyczących instalowania tego oprogramowania”.

Wersja mojego systemu to “Windows 7 SP1 Home Premium x64”.

Twoje sterowniki do karty graficznej AMD są tutaj:
https://ftp.hp.com/pub/softpaq/sp55001-55500/sp55025.exe

Odszukaj na stronie AMD Radeon™ HD 6470M Drivers & Support wersję Radeon Software Crimson Edition Beta dla Twojego systemu operacyjnego.

Jeśli zainstalujesz sterownik wskazany przez @Astor44 lub odszukanego pod linkiem ode mnie i nic to nie pomoże (spróbuj najlepiej oba), to zwróć uwagę do jakiego katalogu rozpakują się pliki sterownika.
Następnie przejdź do Menedżera Urządzeń i wskaż sterownik ręcznie.
Wybierz Aktualizuj Sterownik -> Przeglądaj mój komputer… -> Pozwól mi wybrać z listy… -> Z dysku -> Znajdź i wskaż plik .inf ze sterownikiem.
W oknie odszukaj Twoją kartę i zainstaluj.

Pospieszyłem się ze sterownikiem do Intel.
Dla grafiki Intel wersja 15.22.58.64.2993 (8.15.10.2993) z Twojego procesora jest wersją ostatnią.

No niestety plik od użytkownika Astor nie instaluje u mnie sterownika. A wersja beta powoduje u mnie bluescreen. Ledwo postawiłem wszystko na nogi bo w trybie awaryjnym musiałem odinstalować sterownik od AMD i uszkodził się również nie wiedzieć czemu ten od intel. Po instalacji sterownika od intel nie działało aero. Po czyszczeniu kompa programami typu driver sweeper i instalacji na nowo wszystko ruszyło. Niestety wróciłem do dawnej konfiguracji czyli starych sterowników.

Dalej mnie zastanawia jak sprawdzić czy karta graficzna AMD pracuje poprawnie. W biose nie mam żadnych ustawień odnośnie kart graficznych.


AMD Catalyst za dużo nie podpowiada niestety.
Powoli zaczynam tracić nadzieje ;p

Czy na tej stronie próbowałeś zlokalizować sterownik do swojego laptopa?
Sterowniki w przypadku laptopów należy brać ze strony producenta i nie sugerować się, że gdzieś na stronie producenta danego układu są nowsze (z nielicznymi wyjątkami od tej reguły).

Tak, to są te same co podlinkował @Astor44. Nie wgrywa mi sterownika, wygląda to tak jakby instalator nie wykrył karty i instalował tylko jakiś soft bez sterownika. Dziwne bo w AMD Catalyst brak informacji o sprzęcie, a HW Info ładnie pokazuje wszystkie dane:


Wygląda, że masz mocno “nagrzebane” w OS w kwestii sterowników. Przykładowo, sterownik do GPU Intela masz inny niż najnowszy ze strony producenta. Ja bym nie kombinował tylko “pojechał” referencją.

Wobec tego sprawdź w systemowym Menadżerze Urządzeń czy w pozycji Karty graficzne jest karta HD6470M i czy nie ma przy niej jakichś wykrzykników lub pytajników. Jeśli karta tam jest i bez tych “znaczków”, to sterowniki są również zainstalowane.

Okej ruszyłem trochę z miejsca. Odinstalowałem wszystkie sterowniki od kart graficznych. Użyłem programu AMD cleanup i po ponownej próbie zainstalowania sterownika od AMD sytuacja się powtarza. Chce instalować aplikacje bez sterownika.

Okej wszedłem do folderu:

i widzę ze sterowniki są, więc wszedłem na kartę graficzną w MU. Dałem zaktualizuj sterownik, z dysku i wybrałem plik inf z tego folderu.

No i pięknie wykryło sterownik:

Wybieram Radeon 6470m i klikam dalej, a tu zonk:

Teraz to przynajmniej wiem co go boli, ale przydało by się to jakoś naprawić :smiley:

Co do wykrzykników to przy grafice amd jest, ale opis błędu to kod 10, czyli potrzebuje sterownika.

A i jeszcze tylko na koniec, tak aby nie było nieporozumień - screen ze strony HP :

Dorzucę jeszcze obrazek z informacjami o systemie:

Hej,

A jak w tej chwili wykrywa system karty w menadżerze urządzeń? Może Ty instalowałeś sterownik do karty zintegrowanej?

Możesz pokazać, jakie drzewo folderów się tworzy przy instalacji tej paczuszki ze sterownikami? Jakie katalogi znajdują się w katalogach Drivers, Packages i Display?

Pozdrawiam,
Dimatheus

Cześć. :slight_smile:
Hm, bardzo wątpię abym pomylił karty graficzne, ponieważ każdy element w MU ma swój identyfikator sprzętowy. Karta graficzna oznaczona wykrzyknikiem ma taki: PCI\VEN_1002&DEV_6760&SUBSYS_1669103C&REV_00

A oto drzewo folderów, o które prosiłeś:

Zaznaczę, że próbowałem również z innych folderów podejrzeć plik inf (czy wykryje odpowiedni sterownik i będzie chciał zainstalować), ale tylko w jednym przypadku doszedłem do momentu gdzie mogłem przejść dalej, niestety zakończyło się niepowodzeniem.

Przepraszam, ale pozwolę sobie napisać nowy post ponieważ pojawił się nowy wątek.

Wszedłem na stronę hp i zobaczyłem, że jest dostępna starsza wersja sterowników AMD.

Uruchamiam instalator i moim oczom ukazał się taki widok:

Zainstalowałem sterownik, uruchomiłem komputer na nowo i wyskoczył BSOD.

Wszedłem w tryb awaryjny:

Oto treść BSOD (jeśli potrzeba mogę przesłać plik dmp):

Treść do skopiowania:

*** STOP: 0x00000116 (0xfffffa80065f54e0, 0xfffff88002cd42ac, 0x0000000000000000,
0x0000000000000002)

*** dxgkrnl.sys - Address 0xfffff8800513d3f0 base at 0xfffff880050e0000 DateStamp
0x5d5222cb

ht tps://bankfotek.pl/image/2142931.jpeg <- nie mogę usunąć spacji, ponieważ nowi użytkownicy mogą dodać tylko 6 linków do posta.

Muszę niestety napisać kolejny post, ponieważ nie mogę dodawać więcej zdjęć, a zależy mi na tym aby dokładnie opisać sytuację.

Wróciłem ponownie do sterowników, które miałem na początku. Podczas instalacji najnowszej wersji ze strony amd:

w MU mam taki widok:

Tylko nie wiem czy ta karta z tym sterownikiem faktycznie działa.
Z tego co wiem powinna być opcja do wyboru kart graficznych:

  1. Tryb oszczędny - Intel HD.
  2. Tryb bardziej wymagający - AMD 6470m

Ciekawy jestem jak sprawdzić czy przy odpaleniu gry uruchamia się karta AMD.

Edycja:
Chyba nie działa bo w CS:GO mam 8 fps… a wszystkie ustawienia skręcone na minimum.

Spróbuj tych: http://ftp.hp.com/pub/softpaq/sp54001-54500/sp54363.exe

@ bystryy
Niestety BSOD.

*** STOP: 0x00000116 (0xfffffa80068fe010, 0xfffff880040e0448, 0x0000000000000000,
0x0000000000000002)

*** dxgkrnl.sys - Address 0xfffff88002c8e3f0 base at 0xfffff88002c31000 DateStamp
0x5d5222cb

Oki, to faktycznie jest karta Radeon HD 6400M/7400M Series. I wiele źródeł podaje zamiennie 7400 i 6400. Pewnie dlatego, że to ten sam chip.

Patrząc po strukturze faktycznie można szukać sterowników w folderze W7_INF i W76A_INF, przy czym ten drugi dotyczy systemów 64-bitowych. Czyli wybierałeś dobry.

Mogłeś spróbować też jeszcze innych wersji, skoro są trzy. A BSOD? Obawiam się, że to z winy bardzo starych sterowników bądź braków w instalacji. Może brakuje jakiś bibliotek .NET? Samym zaś trybem awaryjnym się nie sugeruj, bo w nim urządzenia działają na najbardziej podstawowych sterownikach. I dodatkowa karta pewnie nie działa wcale.

System pokazuje, że wszystko jest oki - czyli karta działa poprawnie. Jak sprawdzić? Na pewno koniecznie ustaw profil zasilania na wysoką wydajność. Czy w menu kontaktowym nie masz możliwości decydować, na jakim procesorze graficznym chcesz daną aplikację uruchomić?

Ja bym zostawił te nowsze sterowniki, które identyfikują kartę jako 7400 i sprawdził, czy karta się włącza i obsługuje bardziej wymagające aplikacje. Rozumiem, że system masz zaktualizowany o najnowsze poprawki?