Linux Mint - porady odnośnie instalacji obok Windows 10


(kolektor) #1

Hej :slight_smile:
Planuję zainstalować na swoim notebooku Linux Mint obok Windowsa.
Układ mam taki: dysk SSD 240 GB + 1TB HDD.
Na SSD mam postawiony Windows 10, 1 TB podzielony na dwie równe partycje na dane.
Nie ukrywam, że głównym systemem dla mnie nadal będzie Windows 10. Linuxa instaluję bardziej w celach poznawczych. I tutaj pytanie do was, doświadczeni użytkownicy. Jaki podział sugerowalibyście mi/będzie najkorzystniejszy (chciałbym póki co uniknąć formatu, bardziej “ukraść” trochę miejsca z istniejących partycji).?
Jeśli to możliwe - chciałbym Minta postawić w całości na HDD - tak jak pisałem, cele poznawcze - nie potrzebuję jakiejś mega wydajności. Liczę na jakieś fajne propozycje i z góry dziękuję za odpowiedzi :slight_smile:


(pionner) #2

Wydziel sobie puste miejsce jakimś edytorem partycji z poziomu Windowsa, polecam AOMEI Partition Assistant.
Następnie postaw system, uważając, żeby przy partycjonowaniu wybrać “ręcznie” i wskazać mu puste miejsce. Utworzyć 1 partycję EXT4 z dziennikiem, punkt montowania na “/”.

Możesz utworzyć również partycję SWAP, jest ona wykorzystywana gdy systemowi zaczyna brakować RAMu. Nie jest to punkt konieczny, jakbym ci polecił tworzyć, to zaraz zbiegną się ludzie, którzy stwierdzą, że SWAP jest zbędny, jakbym polecił olać, to zaraz inni by przybiegli i krzyczeli, że jak to bez SWAPa. :wink:
Jeśli się zdecydujesz, walnij jej ze 2GB, typ “przestrzeń wymiany”.

Zwróć uwagę na wybór urządzenia do instalacji bootloadera. Chcesz wybrać dysk, na którym NIE ma Windowsa. (pamiętaj, żeby potem w BIOSie ten dysk ustawić jako pierwszy w kolejności wczytywania systemów). Dzięki temu, jesli uznasz, że Linux to jednak nie twoja bajka, wystarczy, że przełączysz dysk z powrotem na ten z Windą i GRUBa już nie zobaczysz.

Po instalacji GRUB powinien wykryć i Linuksa i Windowsa. Niestety (bądź stety, zależy od punktu widzenia) do menu wrzucone jest multum dodatkowych opcji. Możesz je usunąć, edytować itp programem grub-customizer.

Aby go zainstalować odpal terminal i klepnij po kolei:
sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer


(kolektor) #3

Czy ma znaczenie “gdzie” wydzielę sobie puste miejsce na system? Czy może to być miejsce na końcu ostatniej partycji, czy musi być to przed pierwszą? Czy może nie ma to znaczenia?


(pionner) #4

Raczej nie ma to znaczenia.


(Domker) #5

Jeżeli instalujesz Linuxa na HDD to najlepiej z przodu dysku ze względu na czas dostępu do danych.
W przypadku dysków SSD jest to bez znaczenia, bo czas dostępu jest taki sam do wszystkich sektorów.

Zanim przystąpisz do instalacji to wyłącz szybki start w Windows, bo będzie stwarzać tylko problemy.

Partycje Linux zrób takie (w przypadku UEFI (tablica partycji GPT)):

  1. EFI (fat32) (z flagą “esp” i “boot”) 200MB
    (punkt montowania już w samym instalatorze nadaj jej “/boot/efi” - tu trafi bootloader GRUB)
  2. SYSTEMOWA (ext4) z 20GB-25GB (w przypadku osobnej partycji home)
    (punkt montowania “/”)
  3. HOME (ext4) - na dane użytkownika (rozmiar według uznania)
    (punkt montowania “/home”)
    • tu opcjonalnie partycja SWAP (większość dystrybucji przechodzi na SWAPFILE już, czyli podobnie jak w Windows plik wymiany znajdujący się tam gdzie system)
      Można go utworzyć po instalacji systemu paroma poleceniami w konsoli.

(niekoniecznie musisz robić partycję home osobną, ale wynikają z tego też profity, np przy formacie systemu)

Pamiętaj o zmianie kolejności bootowania w UEFI po instalacji lub jeżeli będziesz okazyjnie odpalać Linux to zostaw tak jak jest i używaj przy włączaniu komputera skrótu do listy szybkiego bootowania (w zależności od płyty głównej - u mnie jest to F8).

Pamiętaj, że przy takiej instalacji gdzie masz drugą partycję ESP niekoniecznie UEFI będzie w stanie poprawnie uruchomić Windows z poziomu wpisu w GRUB i trzeba będzie odpalać listę szybkiego bootowania i wybierać booloader Windowsa lub ustawić, żeby startował od razu Windows.


Linux Mint obok Windows 7 - Kilka pytań i problemów
Linux Mint obok Windows 7 - Kilka pytań i problemów
(kolektor) #6

Mam tylko jeden problem - jak z poziomu instalatora Minta próbuję utworzyć partycję EFI, nie mogę mu nadać parametru /boot - nie mogę w ogóle nic wybrać z rozwijanej listy. Macie jakiś pomysł dlaczego tak może być?


(pocolog) #7

Rozglądnij się dobrze po opcjach instalatora bo kolega pisał ci o nadaniu FLAGI boot, a wydaję mi się że ty próbujesz ustawić PUNK MONTOWANIA /boot. To są dwie różne rzeczy.


(Domker) #8

W instalatorze Mint jest trochę namieszane - osobno masz opcję systemu plików “Fat32” i osobno “EFI boot partition”. Wybierz poprostu najpierw “Użyj jako: EFI boot partition”, a dopiero potem pole punkt montowania stanie się aktywne. (ustawiasz go na “/boot/efi”).
Po wybraniu “EFI boot partition” system plików automatycznie ustawi się na Fat32 i flagi też same się ustawią za sprawą instalatora.


(kolektor) #9

Nadal nie jestem w stanie tego zrobić. Sorry za infantylność, ale coś nie idzie :slight_smile: Proszę o wyrozumiałość.
Po odpaleniu instalacji wygląda to tak:
http://www.tinypic.pl/xqr3vicr0it8
Na początku dysku jest jakaś partycja 134 mb - nie wiem co to, więc wolałem nie ruszać. Dlatego zaraz za nią tworzę partycję systemową EFI (ESP) którą ustawiam na 200 mb - ale niestety punktu motowania dla niej ustawić nie mogę, a następnie resztę dostępnego miejsca przeznaczam na partycję EXT4 i ustawiam montowanie na /.
Próbuję jeszcze wtedy edytować partycję EFI ale efekt jest taki:
http://www.tinypic.pl/3eniqwo8kb64
I teraz wytłumaczcie mi proszę jak powinienem to wszystko ustawić, jak ustawić też bootloader.


(Domker) #10

Jedna rzecz mi przychodzi na myśl - tablicę partycji na tym HDD masz typu MBR, a nie GPT, dlatego instalator nie dopuszcza ustawienia EFI jako partycji rozruchowej systemu.
Dokładnie to widać na 1 zdjęciu, gdzie sekcje “Bootloader” “Urządzenie do instalacji programu rozruchowego” masz aktywne - w przypadku GPT tak nie jest, ponieważ bootloader trafia na partycję, a nie do sektora MBR dysku.

Otwórz konsolę i pokaż rezultat polecenia:
sudo fdisk -l /dev/sdb | grep "Typ"

W przypadku GPT powinien być taki:

Druga sprawa to nośnik USB z Linuxem, czy aby na pewno uruchomił się w trybie UEFI, czy wystartował w trybie Legacy/BIOS.

To też możesz sprawdzić poleceniem:
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

Rezultat polecenia powinien być:
UEFI


(kolektor) #11

Ok, tak więc sprawdziłem i partycję na pewno mam GPT, a pendrive był pod UEFI. Wreszcie mi się udało postawić system, problemy były w Biosie - dość dziwne, ale opiszę.
Podsumowując:
Zgodnie z zaleceniami, stworzyłem partycję EFI, partycję EXT4 z montowaniem na “/” i SWAP. Urządzenie do instalacji programu rozruchowego - wybrałem tę partycję EFI. System się zainstalował, ale automatycznie załączał się Windows, z menu szybkiego bootowania nie miałem możliwosći wybrać ani tego drugiego dysku ani Linuxa, po wejściu do Biosu też przy wyborze kolejności bootowania nie miałem nic.
Ale zacząłem tutaj grzebać.
Miałem oczywiście włączone UEFI i Secure Boot: Disabled.

Gdy zmieniłem Secure Boot na Enabled, w zakładce Security odblokowała się niżej podświetlona opcja:

W tym menu wybrałem jako zaufany plik, znaleziony na EFI plik grub i voilà - zarówno na liście kolejności bootowania w BIOSie, jak i w menu szybkiego bootowania pojawił się Mint który bez problemu się włącza. Po całym procederze Secure Boot znów dałem na Disabled i wszystko działa.

Teraz z samym system mam jeszcze jeden problem, ale to już chyba na inny temat.
O ile na kablu ethernetowym wszystko działa jak powinno, o tyle po WIFI już nie.
System łączy się z wybraną siecią WiFi, internet działa, jednak po paru minutach internet przestaje działać (sieć dalej pokazuje jako połączoną. Po prostu strony się nie otwierają, programy potrzebujące dostępu do sieci nie działają).
Próbowałem już wpisywać ręcznie googlowskie DNSy, próbowałem też wyłączyć oszczędzanie energii jak to było opisane w innym temacie (edycja pliku /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf i zmiana parametru wifi.powersave na 2), ale niestety nie przynosi to rezultatu.


(Domker) #12

Z tym bootowaniem to tak jak wspominałem niektóre UEFI ma problem z drugą partycją EFI.
Po prostu widzi pierwszą i nie szuka drugiej. Tutaj widzę, że poniekąd wymusiłeś zmianą ustawień startu. Dobry trik - dobrze wiedzieć.

Odnośnie Wi-Fi to zupełnie osobny temat, ale podejrzewam, że kłopot sprawia resolver DNS przeniesiony do systemd w Ubuntu i jemu pochodnych (Mint). W sieci grzmi na ten temat, a i tak idą w swoją stronę przymykając oko na problem.
Na Manjaro / Arch mam po staremu i działa tak jak powinno.
Spróbuj pingować jakiś adres IP w internecie jak nie będziesz mógł połączyć się z danym adresem www, np.:
ping -s 3 212.77.98.9
(www.wp.pl)
Jeżeli jest odpowiedź to znaczy, że to typowy problem Ubuntu/ubuntupochodnych z DNS resolverem.
Tak BTW to w sieci jest mnóstwo instrukcji jak powrócić do starego sposobu rozwiązywania nazw domenowych.