Manjaro długi start


(rolkass) #1

Witam

Od kiedy zaktualizowałem ubuntu z wersji 14(który był moim pierwszym) do 17 mam same problemy z linuksami, nie wiem co oni “usprawnili” ale system ładuje się koszmarnie długo przez:

dev/sda6: clean, xxx/xxx files xxx/xxx blocks

z jakiegoś powodu za każdym razem najwyraźniej skanuje dysk. Chciałem zainstalować deepina, to nie odpalał normalnie instalator bo po zniknięciu logo systemu zostawał czarny ekran i migający kursor. Po uruchomieniu w trybie live udało się zainstalować ale system nie startował, to samo co przy odpaleniu instalatora, logo a potem czarny ekran i kursor…
No trudno, pobrałem też obraz manjaro, instaluję… w odróżnieniu od deepina odpala ale dłużej niż ubuntu bo po za skanowaniem dysku dochodzi jeszcze kilka linijek:

laptop acer aspire 7750g
Grafika radeon hd6850m,
dysk ssd crucial mx250.

Co do manjaro to przynajmniej system startuje i spróbuję jakieś sterowniki poinstalować, ale chciałem mieć deepina, tylko jak tam cokolwiek zacząć jak nawet nie startuje?


(gunter) #2

Dodane nowe sterowniki do kernela może na twojej platformie rodzą nowe problemy. Tylko że w Deepin-e jest kernel 4.9, a nie 4.14-up.

Jak uruchamia się grub (przy zainstalowanym manjaro), wejdź w opcje zaawansowane później naciśnij e czyli przejdź do edycji wpisu i dodaj

modprobe.blacklist=amdkfd

w linii przed lub zastępując quiet splash, to się nie zapisuje na stałe, jak się pomylisz to spróbuj jeszcze raz. W skrócie gdzieś tu

linux /boot/vmlinuz … quiet splash

I uruchom z tym wpisem przez Ctrl-x, sprawdź czy wszystko działa prawidłowo.
A jak uruchamiasz Deepin Linux jako livecd w trybie failsafe, to jest tak samo?
To ewentualnie z tym wpisem możesz spróbować uruchomić też, z tym że na livecd naciskamy nie e tylko Tab. Deepina można instalować z sesji live.


(saturno) #3
  1. Zdecyduj się na jedną dystrybucję i na niej szukaj rozwiązania aż do skutku.

  2. Gdzie pełne logi ???
    Jako user:

    systemd-analyze
    systemd-analyze blame > systemd-analyze-blame.txt
    systemd-analyze plot > systemd-plot.svg

Jako root:

journalctl -b -0 > startlog.txt

(rolkass) #4

dodałem to w nowym wierszu przed, bo nie bardzo wiem co zastąpić, samego wyrażenia “quiet splash” nie byl tylko " … quiet …" bez “splash”, odpaliłem i bez zmian.

Jak wybrałem install to tylko czarny ekran i kursor, potemwybrałem failsafe to załadowało się, zainstalowało ale po ponownym uruchomieniu czarny ekran i kursor tylko.

Chciałem deepina, ale niech będzie i manjaro które teraz mam.

systemd-analyze
Startup finished in 1.912s (kernel) + 11.160s (userspace) = 13.073s
graphical.target reached after 1.004s in userspace

10.127s tlp.service
884ms upower.service
393ms lvm2-monitor.service
327ms dev-sda6.device
264ms NetworkManager.service
192ms systemd-rfkill.service
180ms ModemManager.service
142ms systemd-backlight@backlight:acpi_video0.service
112ms polkit.service
98ms udisks2.service
74ms dev-disk-by\x2duuid-f2d353a4\x2df85c\x2d415f\x2db171\x2dd534654182d6.swap
73ms systemd-logind.service
62ms systemd-journald.service
56ms systemd-udevd.service
56ms systemd-udev-trigger.service
55ms systemd-journal-flush.service
55ms user@1000.service
40ms systemd-fsck@dev-disk-by\x2duuid-a866ea5b\x2d3159\x2d40b1\x2da41c\x2dffa8275d3143.service
39ms org.cups.cupsd.service
37ms systemd-tmpfiles-setup-dev.service
32ms bluetooth.service
31ms wpa_supplicant.service
30ms systemd-modules-load.service
25ms systemd-backlight@backlight:radeon_bl0.service
24ms avahi-daemon.service
23ms systemd-tmpfiles-setup.service
23ms ntpd.service
19ms systemd-tmpfiles-clean.service
19ms systemd-remount-fs.service
16ms systemd-update-utmp.service
15ms home.mount
11ms kmod-static-nodes.service
11ms systemd-sysctl.service
11ms alsa-restore.service
10ms rtkit-daemon.service
8ms sys-kernel-debug.mount
8ms systemd-random-seed.service
7ms dev-hugepages.mount
6ms sys-kernel-config.mount
5ms systemd-user-sessions.service
4ms dev-mqueue.mount
4ms tmp.mount
3ms sys-fs-fuse-connections.mount

startlog.txt (218,6 KB)


(gunter) #5

Tlp to alternatywny system zarządzania energią w laptopie, nie wiem po jaką cholerę dodali to w manjaro domyślnie. Weź to zamaskuj i zobacz co się dzieje.

sudo systemctl mask tlp.service

Co do Deepina to w failsafe startuje on z takimi opcjami ładowania kernela.

noapic noapm nodma nomce nolapic nomodeset nosmp nosplash vga=normal union=overlay

Mogłeś sprawdzić przy ładowaniu która jest potrzebna u ciebie, nie powinna być potrzebna żadna, ale …


(marcin82) #6

rolkass

dodałem to w nowym wierszu przed, bo nie bardzo wiem co zastąpić, samego wyrażenia “quiet splash” nie byl tylko " … quiet …" bez “splash”, odpaliłem i bez zmian.

Może coś nie tak zrobiłeś? Pokaż wynik polecenia:
cat /etc/default/grub


(rolkass) #7

Ja jestem zielony, jak to sprawdzić? :]


GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=f2d353a4-f85c-415f-b171-d534654182d6"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper                                                                                                                        
# modes only.  Entries specified as foreground/background.                                                                                                                                           
GRUB_COLOR_NORMAL="light-gray/black"                                                                                                                                                                 
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Coś się zmieniło, teraz są tylko 3 linijki ale czas startu się nie zmienil…

starting version 236
/dev/sda6: clean…
[12.897050] kfd kfd: kgd2kfd_probe failed


(FadeMind) #8

https://bugs.archlinux.org/task/56413

The module to blacklist is amdkfd, it’s only needed for DRM but since it doesn’t actually work blacklisting it shouldn’t break gdm


(FadeMind) #9

Alternatywny OD czego?? Laptop-Mode-Tools?? :>
TLP został wprowadzony w zamian za LMT i jest domyślnie skonfigurowany OOB. Kto chce, może go dostosować wedle uznania (w szczególności użytkownicy bumblebee, czy dysków M.2/SSD SATA).

Jeżeli ktoś ma DESKTOPA można po prostu TLP wyłączyć.


(rolkass) #10

Więc, jak bardzo źle to robię, że nie działa?


(marcin82) #11

Nie w tej linii co trzeba i nie taką komendą jak trzeba … Na końcu linii zaczynającej się od słowa “linux” dodaj po spacji:

module_blacklist=amdkfd

Wciśnij Ctrl+X albo F10, żeby uruchomić system ze zmodyfikowanymi ustawieniami.


(gunter) #12

Po co ta drwina, laptop-mode-tools jest za stary już się go nie używa. Z zarządzaniem zasilaniem dobrze radzi sobie już oddawana kernel i nie trzeba do tego tlp. To może być alternatywa dla kogoś kto wie co robi na zaawansowanie zarządzanie energią, sam to czasami stosuje. Nie twierdze że się nie sprawdza, ale przy złych ustawieniach np. skanery zasilane z usb będą miały problemy. Nie musisz mieć tlp na laptopie też i wszystko będzie działać.

O amdkfd już mu pisałem, to po co to powielać.

Nie pisz do mnie, bo to nie ja potrzebuje pomocy, a na dyskusje nie mam czasu.

Napisałem dokładnie w poście nr. 2, w której lini ma być wpis na próbę.

modprobe.blacklist=amdkfd


(rolkass) #13

Pomogło ale nadal długo muszę czekać

starting version 236
/dev/sda6: clean xxx/xxx / files xxx/xxx/ block


(FadeMind) #14

Podaj pełny DMESG log. Wrzuć go na http://wklej.org i w odpowiedzi użyj linku do wklejki.

dmesg > dmesg.log

Znajdziesz go w /home


(rolkass) #15

http://wklej.org/id/3350328/

Jak teraz zapisać te zmiany? Ten sposób jest jednorazowy.


(marcin82) #16

Utwórz plik /etc/modprobe.d/amdkfd.conf o zawartości:
blacklist amdkfd

Oczywiście musisz działać jako root.

Można użyć magii:
echo "blacklist amdkfd" > /etc/modprobe.d/amdkdf.conf

EDYCJA:
Do samodzielnej “rozkminy”:

  • do czego służy katalog /etc/modprobe.d/
  • do czego służy komenda blacklist
  • do czego służy komenda echo

EDYCJA 2:

z jakiegoś powodu za każdym razem najwyraźniej skanuje dysk.

Zainstaluj pakiet smartmontools i wykonaj takie polecenia, pokaż wynik ostatniego - jako root:
pacman -S smartmontools
systemctl enable smartd
systemctl enable smartd
smartctl -a /dev/sda


(rolkass) #17

http://wklej.org/id/3350445/


(marcin82) #18

Wynik jest w porządku.


(rolkass) #19

Próbowałem w pliku etc/fstab podmienić wartości na 0, co niby by miało wyłączyć skanowanie dysku ale to też nie działa. System przez to dziadostwo startuje i wyłącza sie zdecydowanie zbyt długo a wszystko zaczeło się od jakiejś aktualizacji na ubuntu 14…


(gunter) #20

Można niby wyłączyć sprawdzanie dysku, ale to dla twojego bezpieczeństwa jest tak ustawione.
Pokaż:

sudo tune2fs -l /dev/sda6

I jeszcze raz po zmianach.

systemd-analyze blame