Nie mogę połączyć się z żadnym klientem FTP


(Klasyczny) #1

Witam,

 

mam nietypową sytuację. Próbowałem kilku klientów i nie mogę się z żadnych z nich połączyć z serwerem FTP. Dane są prawidłowe bo przez przeglądarkę się połączę. Próbowałem przez FileZilla status:

Status:    Łączenie z 46.105.43.92:21…
Status:    Nieudana próba połączenia z “87”.
Błąd:    Nie można połączyć się z serwerem

 

TotalCommander wyskakuje: Utworzenie gniazda sieciowego nie powiodło się! i po tym zawiesza się program.

 

Wyłączałem antywirusa zaporę Windows i dalej nic … W tle nie mam żadnych innych programów powiązanych z siecią.

Dodam, że nawet na telefonie próbowałem się połączyć przez FTP i bez żadnych problemów (wiec coś u mnie jest nie tak, nie wiem co). Ktoś ma jakiś pomysł?


(krypton) #2

w FileZilli ustaw tryb na pasywne połączenie ftp


(Klasyczny) #3

Ustawiałem, nic to nie dało …


(MeHowG) #4

Czy Twoje IP może być zablokowane przez zaporę ogniową serwera? 


(Klasyczny) #5

Raczej nie bo udostępniałem sobie internet z telefonu (inne IP) na komputer i bez zmian.


(MeHowG) #6

Jakie próby wykonałeś? Co wykluczyłeś? Jak sytuacja wygląda w przypadku innego komputera, systemu? Sprawdziłem łączenie do adresu IP, który podałeś, mam prośbę o użytkownika i hasło, więc prawidłowo, a co dalej to już nie wiem. Sprawdzałem przez przeglądarkę i TC.


(Klasyczny) #7

Dane do FTP są na bank poprawne, bo na innych komputerach wszystko działa (sprawdzałem też na telefonie - działa). U mnie nie łączy się tylko na programach do FTP m.in FilleZilla, TC oraz SmartFTP - na wszystkich wywala błąd (napisałem wyżej jakiej treści).

Przez przeglądarkę Firefox mogę się zalogować wpisując po prostu ftp://adres_IP a później login i hasło.

 

Wyłączałem antywirusa (avast), wyłączałem zaporę systemu (win 7) - bez rezultatu.

Łączenie się pod innym adresem IP też nie zdało egzaminu.

Programy FTP są “świeże” (nowa wersja i reset danych/ustawień).


(Acorus) #8

Do Firefoxa zainstaluj sobie FireFTP.


(Klasyczny) #9

Już to zrobiłem, działa, ale mi zależało żeby działać na FileZilla lub TC.


(MeHowG) #10

Nie masz przypadkiem ustawionego jakiegoś proxy w Opcjach internetowych > połączenia > Ustawienia sieci LAN?


(Klasyczny) #11

Konfiguracja automatyczna - > Tylko zaznaczone: Automatycznie wykryj ustawienia

Serwer proxy -> Odznaczony


(MeHowG) #12

Jeśli chodzi o status 87 to oznacza prawdopodobnie 87 Connect Failed co nic nie wnosi niestety. 

 

Czy próbowałeś połączyć się w cmd + telnet albo ssh z tym serwerem?

 

Pisałeś, że zapora ogniowa jest wyłączona, mimo to czy mógłbyś w wyjątkach zapory dodać dla FTP port 21 z opcją zezwalającą na połączenia do FTP i po restarcie sprawdzić?

 

Czy mógłbyś sprawdzić w rejestrze istnienie wpisów jak poniżej:

 

HKEY_CLASSES_ROOT\ftp
"AppUserModelID"
“EditFlags”
“FriendlyTypeName”
“ShellFolder”
“Source Filter”
“URL Protocol”

 

Tak powinny wyglądać:

[HKEY_CLASSES_ROOT\ftp]
(Domyślna) wartość “URL:File Transfer Protocol”
“AppUserModelID” wartość “Microsoft.InternetExplorer.Default”
“EditFlags” (dword) 200002 (szesnastkowy)
“FriendlyTypeName” wartość "@C:\Windows\system32\ieframe.dll,-905"
“ShellFolder” wartość “{63da6ec0-2e98-11cf-8d82-444553540000}”
“Source Filter” wartość “{E436EBB6-524F-11CE-9F53-0020AF0BA770}”
“URL Protocol” wartość " "

 

I jeszcze takie polecenie w cmd:

netsh advfirewall set global StatefulFtp enable

 

 


(Klasyczny) #13

Przez telnet się nie połączyłem. “Łączenie z 46.105.43.92…Nie można nawiązać połączenia z hostem na porcie 23: Połączenie nie powiodło się”

 

Dodałem wyjątek z FTP na port 21.

 

W rejestrze mam różnice tylko z:

“EditFlags” (dword) 200002 (szesnastkowy)

mam:

“EditFlags” REG_DWORD 0x00000002 (2)

 

netsh advfirewall set global StatefulFtp enable = Ok.

 

Dalej to samo … :frowning:

 


(MeHowG) #14

0x00000002 też może być, z taką wartością też się spotkałem. Czy próbowałeś zresetować Opcje internetowe do ustawień domyślnych?


(Klasyczny) #15

Tak, robiłem to przed napisaniem tego tematu.

Teraz przeszło mi przez myśl, bo przed działającym FileZilla ‘bawiłem się’ z programem FlyVPN. Czy to może mieć jakiś związek?


(MeHowG) #16

Tak, być może w ustawieniach dla IPv4 i bramy jest coś ustawione związane z VPN przez co może być blokowane. Jak wygląda TRACERT do tego IP?


(Klasyczny) #17

tracert.png


(MeHowG) #18

Ok, to jeszcze zapytam, bo nie widziałem, czy tylko do tego jednego serwera nie możesz się połączyć? Próbowałeś do innych FTP?

 

A czy w Opcjach internetowych > połączenia > ustawienia LAN > zaznaczysz proxy i wybierzesz zaawansowane, to masz coś wpisane w polu FTP?

 

Jeszcze do sprawdzenia w Opcje Internetowe > Zaawansowane czy jest zaznaczone pole “użyj pasywnego protokołu FTP …”

i w Połączenia, czy masz dodaną jakąś sieć VPN?

 


(Klasyczny) #19

Z innymi FTP też nie mogę się połączyć, program w ogóle nie reaguje - zawsze ten sam status.

 

Jak jest odznaczone to pewnie i tak nie brane jest to pod uwagę, ale nie nic nie mam wpisane oprócz:

Nie używaj serwera proxy do adresów zaczynających się od:

*.local

 

Mam zaznaczone “Użyj pasywnego protokołu FTP (dla zachowania zgodności…)”

W zakładce “Połączenia” nie mam dodanej żadnej sieci VPN.

 

 

 


(MeHowG) #20

Nie używaj serwera proxy do adresów zaczynających się od:

*.local

 

to pole mam puste tak samo jak pola Serwery w zakładce ustawień, możesz usunąć ten wpis i spróbować? Wiem, że to raczej nie ma sensu, ale powoli kończą mi się pomysły :frowning: