Nieaktywny pasek adresu w firefox 10


(Lufcik) #1

Witam. Od wersji 10 mam pewien problem. Gdy chcę wpisać w pasek adresu jakikolwiek adres, nie idzie tego zrobić, bo pasek jest nieaktwyny. Nie idzie nawet zaznaczyć treści w tym pasku. Z wyszukiwarką też jest podobnie. Miał ktoś kiedyś taki problem? Dodam, że ponowne uruchomienie programu rozwiązuje sprawę, ale to dla mnie, że tak powiem mało wygodne rozwiązanie.

Pozdrawiam


(korkodyl) #2

Miałem to samo, dlatego wróciłem do 9.0.1 i jest ok.


(Szymon606) #3

Jaki antyvir? U mnie był dodatek od AVG i on stwarzał problemy. Uruchom bez dodatków FF. Jeżeli posiadasz AVG, to wyłącz "safe search", czy jakoś tak podobnie.


(Lufcik) #4

Mam avire. Z dodatków to mam zainstalowane tylko AdBlocka. Mam tylko w zasadzie to, co niezbędne.


(manieKMP) #5

Próbowałeś je usunąć i na nowo wstawić w pasek nawigacyjny (tip: opcja menu "Dostosuj...", okno dostosowywania pasków narzędzi)?

U mnie przykładowo, po aktualizacji, wystąpił bug z brakiem wyświetlania nowego wyglądu przycisków wstecz/do przodu (były wyświetlane po staremu). Dopiero po ich zabraniu z paska i ponownym wsadzeniu na niego, wymienione przyciski zaczęły "działać" tak jak powinny. Może u Ciebie też jest podobnie.


(korkodyl) #6

Tak z ciekawości trochę zgłębiłem temat organoleptycznie, że się tak wyrażę.

Wnioski:

Pięć różnych komputerów (trzy lapki, dwa blaszaki), trzy różne systemy (2x win7, 2x win xp-sp3, 1x vista).

Na czterech z nich występuje opisany w temacie problem (na jednym blaszaku z XP -nie). Nie pomaga nowy profil, standardowa diagnostyka, nic...

Po powrocie do 9.0.1 niedogodność ustępuje. Moim zdaniem błąd jest w najnowszej wersji firefoxa.

Pozdrawiam.


(Lufcik) #7

manieKMP , już sprawdzam. Też osobiście wydaje mi się że to bug nowej wersji. Ale aż nie chce mi się w to wierzyć, bo do tej pory w zasadzie nie miałem żadnego problemu z firefoxem, no może czasem wyskoczyło okienko z komunikatem awarii, ale to sporadycznie. Napisze wkrótce, czy coś się poprawiło.


(Allynowa) #8

Witam,

mam dokładnie ten sam problem (nieaktywny pasek adresu, pasek wyszukiwarki, podobnie inne okna uzupełnień na stronach). Przeszukałam fora, rady-porady. Bez rezultatu. reinstalacja ff również nie pomaga. Na krótką chwilę pomaga ponowne uruchomienie ff lub wyczyszczenie pamięci podręcznej (co musiałabym robić średnio co minutę).

Czekam na rezultaty zmagań z problemem.

a.


(Lufcik) #9

Sprawdziłem, potestowałem, problem nierozwiązany. Jedynie co pomaga to odznaczenie pokaż pasek narzędzi nawigacyjnych i zaznaczenie go spowrotem.

Będzie trzeba niestety poczekac na jakąś łatke, o ile mozilla to zauważy, bądź ktoś to zgłosi.


(Newton) #10

Mam ten sam problem.

Najszybszym sposobem na chwilowe pozbycie się go, jest zminimalizowanie przeglądarki i ponowne jej przywrócenie.


(manieKMP) #11

Próbowałem dokonać reprodukcji tego problemu, zainstalowałem w 100% świeżego Fx10, z nowym profilem, bez zakładek (standardowo korzystam z wersji portable, z już bardzo przeterminowanym profilem -bodaj jeszcze z Fx'a 3.0-, a na maszynie testowej nie był jeszcze instalowany żaden Firefox, w sumie to jeszcze żadna przeglądarka, lapek ma niecały miesiąc :wink:), do którego wrzuciłem jedynie rozszerzenie ABP 2.0.3, z zaimportowaną listą reguł. System operacyjny to Windows 7 64bit, zainstalowane najnowsze wtyczki (Flash 11.1.102.55, Java 6.0.300.12 + te parę mniej ważnych, jak Silverlight 4.coś.tam lub cholerstwo od acrobat'a :wink:)

Wynik ponad godziny prób... żaden, nic w interfejsie Fx'a się nie zablokowało, ani pasek adresu, ani pasek wyszukiwarki, nawet sam Fx nie chciał paść, choć odtwarzałem filmy, łaziłem po stronach i szukałem w sieci tematów związanych z blokowaniem pasków w Fx.

Podczas próby reprodukcji, znalazłem w sumie tylko jeden temat nawiązujący do blokowania się pasków (z 2010 roku bodajże) i był on związany z flash'em, a konkretniej -jak się człowiek wczytał/domyślił- z nową/starą funkcjonalnością odpalanie flash'a w oddzielnym procesie (plugin-container). Niestety opisy procedury blokowania w tym przypadku nie powiodły się, a rozwiązanie, zmiana wartości dom.ipc.plugins.enabled.npswf32.dll na true lub false raczej nic by nie zmieniła (tego w about:config u mnie nie ma na świeżej instalacji).

W związku z brakiem u mnie efektów i w zasadzie zerowej wiedzy nt. stanu systemów osób, które tu napisały o występowaniu takiego problemu, mogę jedynie przypuszczać i/lub doradzić:

  • aktualizację lub kompletne przeinstalowanie Flash Player'a i Java'y (z tym drugim był wątek związany z tymczasowym zamrażaniem się Fx'a, ale może ma to jakiś związek)

  • w zależności jakie podjęto kroki z powyższym punktem -konkretnie o Java'ę chodzi-, profilaktyczne przeczyścić cache Java'y nie zaszkodzi: Panel sterowania -> Java -> General - Settings... -> Delete Files... (chyba że ktoś chce skorzystać np. z CCleaner'a, który posprząta i Java'ę i Flash'a :wink:)

  • sprawdzić czy oprogramowanie zabezpieczające nie ma jakichś modułów/dodatków ingerujących w/integrujących się z przeglądarką (z tego co mi wiadomo, takowe bonusy posiadają Norton Internet Security, Avast -WebRep na Fx od wersji 9tej robi dziwne rzeczy-, AVG -chyba tu jużpodano-, Avira -nie wiem czy to od konkretnej wersji zależy, ale do tego oprogramowania dodawany jest jakiś WebGuard, obiło mi się o oczy, że wchodzi on w jakiś konflikt z Fx'em)

  • kompletne usunięcie profilu Fx (robić przy wyłączonej przeglądarce). Odpalamy okno eksploatatora na dysku C:, klikamy na pasek, gdzie jest wyświetlana litera dysku (powinno się zaznaczyć "C:\"), wpisujemy/wklejamy _%appdata%\Mozilla\Firefox\Profiles_ i enter. W miejscu, w którym się znajdziemy powinien znajdować się katalog z .default na końcu nazwy, ten katalog usuwamy lub przenosimy gdziekolwiek indziej, tylko by go nie zostawiać w bieżącej lokalizacji (przeniesienie daje możliwość sprawdzenia czy Fx odzyska sprawność, jeśli nic to nie zmieni, można będzie powrócić do starego profilu ze starymi ustawieniami poprzez powrotne umieszczenie tego katalogu w w/w miejsce. Należy wtedy pamiętać by usunąć katalog nowo utworzonego profilu).

To by było na tyle, więcej sugestii do łebka mi nie przychodzi, może poza jednym, możliwe że problem powoduje wirus, którego używane zabezpieczenia nie potrafią dostrzec, no ale to jest takie moje gdybanie.

PS. Jak już piszę, to tak przy okazji, co się dzieje, przy zblokowaniu pasków, jak klikniecie na systemowy pasek zadań i z powrotem na okno Fx'a, jest jakaś reakcja, czy nic to nie daje? Tak jakoś mi się z utratą fokusa na oknie skojarzyło.


(Lufcik) #12

manieKMP , to o czym pisałem w zasadzie dzieje się na jednej stronie. Bo w innych przypadkach działa normalnie. Już mówię jak to wygląda.

Mówię dokładnie o stronie kurnik.pl. Chciałem Ci napisać algorytm występowania błędu, ale póki co działa :smiley:

Może dlatego, że wczoraj wyczyściłem całkowicie pamięć podręczną, choć wątpie. Co do Twojego P.S. to nie wiem, nie zwróciłem na to uwagi, ale może ktoś, kto to zauważył się wypowie

Co do wirusa, to raczej nie możliwe, bo ja nie z tych co kolekcjonują robaki.

Nie mam zainstalowanych żadnych toolbarów. Wszystkie dodatki są w najnowszych wersjach, w tym java i flash.

Być może, że problem rozwiązałaby świeża instalacja liska, bo ja ostanio instalowałem świeżą wersję gdy wychodził firefox4 i może po prostu aktualizacje do nowych wersji, a było ich trochę coś namieszały.

Jak problem wystąpi ponownie to dam znać i być może zainstaluje świeżą wersje. Pozdrawiam


(Allynowa) #13

Witam,

ff jak wspominałam instalowałam "na świeżo" (po usunięciu dokładnie czyszcząc rejestr), wtyczki są aktualne. Problem jest. Kliknięcie na systemowy pasek zadań i z powrotem na okno ff "uaktywnia" nieaktywne wcześniej elementy (pasek adresu, wyszukiwarki etc). Podobnie działa czyszczenie pamięci podręcznej, cache Javy, minimalizacja oka ff, ale.... wszystko na chwilę (krótką).

Niestety.


(manieKMP) #14

Ok, chyba udało mi się dokonać reprodukcji problemu. Ten kurnik.pl naprowadził mnie na pewien trop, który sprawdziłem jeszcze na czacie wp.pl (to mi się jakoś skojarzyło z allynową, nick sugeruje dziewczynę, więc... :wink:).

Sytuacja przedstawia się (jak na razie) u mnie następująco:

-na kurniku pasek adresu "blokuje się" na oknach z jakąkolwiek grą, wygląda to tak, jak by pasek był aktywowany przez kliknięcie, ale nie daje się nić wpisać. Gry odpalają się w oddzielnych oknach i tylko w nich dochodzi do zblokowania, w reszcie okien -powiedzmy że głównych- paski dalej działają i można ich zawartość edytować. Pokusiłem się o sprawdzenie działania kurnika na Operze 11.60, ale w jej wypadku było w zasadzie jeszcze gorzej, bo próby klikania w pasek adresu blokowały treść okna (czyt. gra zachowywała się jak pasek). Na zachomikowanym Fx 3.5 sytuacja była taka sama (sądziłem, że będzie inaczej).

-test na czacie wp.pl chyba najlepiej odzwierciedlał problem, bo o ile na kurniku wyglądało to mi na "zamierzoną" blokadę paska adresu, o tyle na wp.pl tylko w Fx 10 dochodziło do zblokowania (na O 11.60 i na Fx 3.5 paski się nie blokowały).

Ogólnie odblokowanie pasków wymaga ubicia procesu(ów) Java w menedżerze zadań (te procesy same się wyłączają, w momencie wyłączania/restartu Fx'a, do czasu jak się znów nie wejdzie na stronkę, odpalającą jawkę :wink:), oczywiście nie można tego robić jak się korzysta ze strony, która z tym "współpracuje".

Wnioski i spostrzeżenia na chwilę obecną są takie, że Fx 10 wchodzi w jakiś konflikt z Java'ą (możliwe że błąd leży po stronie Fx, a może po obu stronach), ponieważ obie strony, tak kurnik jak i czat wp, to wykorzystują (czaty onetu, czy interii pewnie też tak mają).

Rozwiązania jakie mi się nasuwają...:

-sprawdzenie Java'y w wersji 7-mej lub wcześniejszej (możliwe że któreś z wersji są pod tym względem "grzeczne").

-tymczasowa zabawa w terminatora :wink: (w/w ubijanie procesów)

-przejście na starszą wersję Fx, przynajmniej do czasu wydania poprawek (teoretycznie najbliżej będzie to wydane albo w 10.1, albo 11 wersji, jeśli w ogóle :wink:)


(Lufcik) #15

Witam ponownie. Udało mi się dokładnie zreprodukować problem. Teraz pisząc post nie mogę zaznaczyć tego tekstu. Pisząc post nie mam tego pionowego znaczka, który miga. Nie da sie nic zaznaczyć, na żadnej karcie. Ale do rzeczy.

Teraz wywołałem problem w dużo bardziej prosty sposób i mogę go wywoływać na życzenie. Wygląda że java 6u30 jest po prostu niedopracowana.

  1. Wystarczy sie zalogować na kurnik, uruchomić byle jaką gre, wejść na byle który pokój.

  2. Otworzy sie nowa karta, i wystarczy nacisnąć by posortował dane wg rankingu.

Tyle.

Nacisnąłem pokaż pulpit, kliknąłem firefoxa i jest ok. Wszystko wróciło do normy, ale jest to irytujące.

-- Dodane środa, 8 lutego 2012, 13:56 --

Poza tym mam pytanie. Czemu nie ma aktualizacji javy do wersji 7, która jest już od dawna? Przecież to chyba nie jest wersja beta jeszcze, no nie?


(Allynowa) #16

Witam,

potwierdzam, że problem pojawia się przy przeglądaniu stron z zawartością Flash/Java (chat/ you tube/ etc).

Jak rozumiem wiemy jak radzić sobie z problemem "na chwilę" - trwałego rozwiązania wciąż brak?

ps- nick sugeruje, przymiotniki sugerują, nie da się ukryć - płeć żeńska :wink:

pozdrawiam


(Lufcik) #17

Problem rozwiąże zapewne powrót do java u29 lub do wersji 7. Ja poczekam na wypowiedź manieKMP. Jutro ewentualnie zainstaluje sobie wersje 7 i dam znać czy coś to dało.


(manieKMP) #18

Dotarłem do tematu związanego w sumie z tym problemem, jako "zgłoszenie" na budzilli, oznaczony jako błąd z numerem 718939 i mówiący o "wywoływaniu błędu z polami wprowadzania tekstu przez uruchomiony aplet java'y" (skrótowe tłumaczenie tytułu :wink:).

Nie wdając się już w szczegóły, w 40-tym komentarzu znalazła się "nieoficjalna" poprawka Fx'a, która, jak sprawdzałem, rozwiązuje problem...

jest tylko taki tyci problemik, ta poprawiona, "nieoficjalna" wersja Fx nie jest zlokalizowana i po jej zastosowaniu będziecie musieli się pobawić w dodawanie polonizacji.

Tak więc do rzeczy:

  1. Wersja instalacyjna, w jej wypadku raczej wiadomo co należy zrobić :wink:

  2. Wersja w postaci archiwum. W jej wypadku należy podmienić zawartość katalogu instalacyjnego Fx'a, zawartością podanego archiwum (wypakowanie powinno skutkować utworzeniem katalogu "firefox", w którym znajduję się docelowa zawartość), czyli to co standardowo znajduje się w C:\Program Files\Mozilla Firefox (lub dla Win64bit, C:\Program Files (x86)\Mozilla Firefox), podmieniamy tym co mamy w podanej paczce.

  3. Instalacja polonizacji (kliknięcie spowoduje pobranie paczki lokalizacyjnej, a ponowne uruchomienie Fx'a powinno ją aktywować*)

* w przypadku braku automatycznej zmiany języka interfejsu należy wpisać w pasek adresu about:config i odszukać wartość general.useragent.locale. Dwukrotne kliknięcie w tą wartość wywoła okno edycji, w którym należy wpisać pl i ponownie uruchomić przeglądarkę, by jej język się zmienił.

@allynowa, co do YT lub ogólnie zawartości flash'owej na stronach, u mnie problem nie wystąpił (wspominałem o tym wcześniej), być może ma to związek z blokowaniem problematycznych treści przez ABP podczas testu. Tak więc w tym wypadku mogę doradzić jedynie hipotetyczne rozwiązanie, na jakie się natknąłem (chyba że w/w poprawka również i na to pomaga, tego nie wiem). Tym rozwiązaniem jest dodanie w about:config wartości logicznej dom.ipc.plugins.enabled.npswf32.dll i ustawienie jej na "true".

PS. Jest jeszcze jeden, chyba dość istotny wątek w sprawie problemu. Według niektórych odpowiedzi w tym temacie, Java 7 również naprawia problem karetki (kursora edycji tekstu). Jednak sam tego nie sprawdzałem, więc głowy za to nie dam :wink:.


(Lufcik) #19

Wersja 7 rzeczywiście załatwiła problem, kurnik sie szybciej uruchamia, ale muszę jeszcze poszukać, aby podczas działania skrót był w trayu.

-- Dodane środa, 8 lutego 2012, 19:11 --

Ok. Problem uznaję za rozwiązany. Oczywiście ten, kto zainstaluje wersje 7 powinien pamiętać o odinstalowaniu starej.

Nie chciało mi się czekać na jakiś patch do 6u30, bo pewnie musiałbym jeszcze troche poczekać. Dzięki manieKMP.


(Allynowa) #20

Pozostaje mi koledze zazdrościć.

U mnie:

  • powrót do java u29 nie rozwiązuje problemu, wersja 7 na podanej stronie przeznaczona jest dla win 64 (mam 32)

  • spróbuję innych porad manieKMP...

a.