Po instalacji GNOME 3 moje Unity jest zabugowane i mam problem z instalacją Nautilusa


(sajmon17099) #1

Zainstalowałem GNOME 3, ale zauważyłem, że moje Unity jest zabugowane (zabugowany Nautilus, miałem zbyt duże ikonki na pulpicie i w Nautilusie, i ogólnie Nautilus wydawał się mieć dziwny wygląd). Odinstalowałem wszystko, co jest związane z GNOME. Odinstalowałem też Unity, odinstalowałem też gnome-desktop3-data. Skutkowało to tym, że miałem dostęp tylko do terminala. Nie mogłem normalnie zainstalować Unity od początku, bo komenda "sudo apt-get install ubuntu-desktop" kończy się takim czymś:

Czytanie list pakietów... Gotowe


(bart86) #2

może spróbuj

aptitude  install -r ubuntu-desktop

zainstaluje to również zależności polecane


(sajmon17099) #3

Z poziomu zabugowanego Unity czy “ctrl+alt+f1”?


(bart86) #4

polecenie pisze się w konsoli tak więc bez różnicy ale chyba lepiej to drugie


(sajmon17099) #5

To mi w ogóle nie pomogło, bo nic nowego nie zainstalowało.


(sajmon17099) #6

sudo aptitude  install -r ubuntu-desktop

 

Następujące NOWE pakiety zostaną zainstalowane:


(flecht) #7

Może to głupie pytanie, ale masz połączenie z siecią?


(sajmon17099) #8

Tak.


(flecht) #9

Zacząłbym w takim razie od sprawdzenia aktywnych repozytoriów i wyszukiwania problematycznych paczek (apt-cache search, ale to raczej znasz). Clean powinien był usunąć wszystkie pobrane paczki, ale moim zdaniem warto sprawdzić, czy gdzieś się nam nieszczęsny nautilus nie zapodział i nie robi pod górkę (wersja nie niższa niż w aktualnym repo).


(sajmon17099) #10

Nigdy nie używałem tej komendy, więc zbytnio nie wiem czy dobrze jej używam

apt-cache search

apt-cache search nautilus

 

brasero - Aplikacja do nagrywania CD/DVD do GNOME


(flecht) #11

Trochę zamotałem. Interesują mnie (nas?) informacje gdzie dana paczka się znajduje i jakie są jej zależności. Apt zbyt wylewny nie jest i trzeba go trochę ponaciskać… Szybkie guglanie podpowiada, że zależności odczytamy wpisując np. apt-cache show nautilus. Z tego wątku na superuser dowiesz się, jak sprawdzić z jakiego repo można daną paczkę zaciągnąć: link. Prześledź drzewko zależności, aż znajdziesz winowajcę.


(sajmon17099) #12

cat /etc/apt/sources.list

See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to


(bart86) #13

(sajmon17099) #14

Gdzie “N”?

sudo aptitude install -N ubuntu-desktop


(flecht) #15

Chodziło mu raczej o negatywną odpowiedź na pytanie.

Mieszałeś trochę w repozytoriach i z tego prawdopodobnie wynikają twoje problemy z zależnościami – część paczek masz zbyt nowych i widać to nawet w twoim pierwszym wpisie. Najlepszym rozwiązaniem byłoby chyba jednak sprowadzenie zainstalowanych paczek do wersji dostępnych standardowo w repozytoriach. Ten wątek może okazać się pomocny.


(sajmon17099) #16

Pulpit mi już działa, mam nautilusa, sudo aptitude -f install ubuntu-desktop mi pomogło. Musiałem wybrać “n” i wtedy jakieś paczki zostały przywrócone do poprzednich wersji. Teraz wszystko mi działa. To dziwne, że można mieć w Ubuntu coś “zbyt nowego”.

Jeszcze jedno - gedit dziwnie się wyświetla. Boję się że inne programy też mogą się tak wyświetlać, chociaż na razie wyświetla się tak tylko gedit

dziwny gedit


(flecht) #17

Razem z GNOMEm ściągnąłeś GTK+ 3.18, a standardowo Ubu 15.10 przewiduje 3.16. Jako, że na GTK+ bazuje spora część oprogramowania, to i wygląd tych aplikacji się zmienił. Dziwny wygląd Gedita sugeruje właśnie, że nie wszystkie “zbyt nowe” paczki udało ci się przeinstalować w starszej, dystrybucyjnej wersji.


(sajmon17099) #18

I teraz nie wiem czy kontynuować:

 

sudo apt-get dist-upgrade


(flecht) #19

W twoim przypadku użyteczna będzie raczej pierwsza odpowiedź z tamtego wątku.

Tutaj znajdziesz zbliżone info o cofaniu Debiana Testing do wersji Stable. Skala zmian u ciebie jest znacznie mniejsza, ale mechanizm powinien być ten sam.


(sajmon17099) #20

Nie wiem jak to działa w Ubuntu, bo w Ubuntu nie ma wydania sid. Nie wiem co usunąć z sources.list - nie umiem rozpoznać co jest niestabilne, a co jest stabilne. Poza tym - nie mam wersji testowej, mam wersję stabilną, tylko zainstalowałem GNOME 3.

Nie mam nawet katalogu preferences tylko preferences.d, a ten katalog jest pusty.