Problem z FireFox czarne strony WWW


(Siarczyslaw) #1

Witam, mam problem z FireFoksem, odpalam i mam coś takiego jak na zdjęciu

Nie wiem co się stało i jak to naprawić... pomocy


(rgabrysiak) #2

Próbowałeś wyczyścić pliki tymczasowe przeglądarki?


(Siarczyslaw) #3

tak CCleanerem i odkurzaczem nie pomogło dodam iż Chrom działa normalnie…


(mp360) #4

Może jakiś dodatek blokuje poprawne wyświetlanie stron…


(Siarczyslaw) #5

Nie ma nic zainstalowanego, ani jednego dodatku


(Azgrel) #6

Czy problem występuje też w stabilnej wersji Firefoksa? Bo sądząc po ikonie odpalona jest wersja beta.


(Siarczyslaw) #7

Na zwykłej to samo, na becie to samo


(Azgrel) #8

A nie masz czasem włączonej akceleracji sprzętowej? Firefox ma z nią problemy i czasem wyświetla dziwne rzeczy. Dodatkowo zobacz czy problem występuje też na świeżym profilu.


(lordjahu) #9

Może pomoże :

"może jakieś rozszerzenie do FF nawala. skasuj katalog:

Kod: Zaznacz cały

C:\Documents and Settings{nazwa konta windows}\Dane aplikacji\Mozilla\Firefox

usuniesz, wszystkie ustawienia FF i zainstalowane rozszerzenia. uwaga - zostaną również usunięte zakładki.

Jak już usuniesz, ten folder, to reinstaluj FF." by grzegorzch

z czarny-ekran-podczas-korzystania-firefoxa-t203972.html


(Siarczyslaw) #10

Jak wyłączyć akceleracje? mam jakiś intelowski badziewie w lapku

Wywalałem już z Appdaty Foldery Mozilli nadal czarno, karta graficzna to Intel Family 4


(Azgrel) #11

Opcje -> Zaawansowane -> odhacz “Korzystaj z akceleracji sprzętowej”, ale to raczej nie to. Przy problemach z akceleracją artefakty pojawiają sie też na interfejsie Firefoksa.


(Siarczyslaw) #12

Nie mogę wejść w opcje FF bo są wykrzaczone :smiley:


(Azgrel) #13

Spróbuj tak: wpisz w pasku adresu about:config, w szukajce wpisz “layers.acceleration.disabled” i przestaw wartość na true.


(Siarczyslaw) #14

Ok ustawiłem tryb zgodności z XP i działa… ale jak wyłączę to nie działa ■■■?


(manieKMP) #15

Przejdź do katalogu profilu, odszukaj w nim plik o nazwie prefs.js, otwórz go przy wyłączonej przeglądarce i dopisz poniższe (najlepiej w kolejności alfabetycznej wpisów w tym pliku):

user_pref("layers.acceleration.disabled", true);

Zapisz zmiany i odpal Fx. PS. Kolejność przed i za powyższym wpisem u mnie wygląda tak:

user_pref("intl.charset.default", "ISO-8859-2");

user_pref("intl.charsetmenu.browser.cache", "ISO-8859-2, windows-1250, windows-1252, windows-1251, UTF-8");

user_pref("layers.acceleration.disabled", true);

user_pref("network.cookie.prefsMigrated", true);

user_pref("pdfjs.disabled", true);

(Siarczyslaw) #16

Nadal nic ;/ i czarny ekran pomocy!


(manieKMP) #17

Jeśli jest to rzeczywiście związane z akceleracją, to przydałaby się aktualizacja sterowników do karty (i pewnie takowych nie ma…).

Uruchom Fx’a w trybie zgodnoći, by móc wejść w about:config, wpisz w tamtejszą szukajkę “gfx.direct”, powinny pozostać Tobie trzy ustawienia:

  • gfx.direct2d.disabled (ustaw na true)

  • gfx.direct3d.prefer_10_1 (ustaw na true)

  • gfx.direct2d.force-enabled (ustaw na false)

Sprawdź też na wszelki wypadek, czy layers.acceleration.disabled jest ustawiony na true, oraz czy nie masz przypadkiem wymuszenia akceleracji, czyli layers.acceleration.force-enabled ustawionego na true.

Po tym odpal przeglądarkę normalnie…


(Semtex) #18

Zaczekaj z wszystkim, najpierw wypadałoby by sprawdzić czy problem występuje w trybie awaryjnym Lisa, możesz go odpalić w dwa sposoby: Przycisk Firefox-> Pomoc -> Uruchom ponownie z wyłączonymi dodatkami.

Lub: Zamykasz Lisa-> wciskasz i trzymasz Shift-> uruchamiasz Lisa ze skrótu-> potwierdzasz komunikat o uruchomienie w “Trybie Awaryjnym”.

Jeżeli masz nadal problem to prawdopodobnie jest uszkodzony profil, choć wątpię, myślę że chodzi o akcelerację sprzętową (wspomniane), w awaryjnym powinieneś mieć możliwość wyłączenia jej w opcjach, nie powinno być krzaków.

Twój problem jest najprawdopodobniej wynikiem tego bugu: https://bugzilla.mozilla.org/show_bug.cgi?id=870132

Poza tym, masz dwie karty w SLI, być może Lis nie lubi tej konfiguracji, co nadal dotyczy Akceleracji sprzętowej :slight_smile: