Problem z wifi, Kubuntu

Problem polega na tym, że po połączeniu sieć ma status “ograniczona łączność”. Wifi działa normalnie przez kilka minut, a później zachowuje się, jakby nie miała połączenia z Internetem. Po ponownym połączeniu znowu działa przez kilka minut i tak w kółko.

Możesz połączyć się po kablu i zaktualizować w pełni system? W ustawieniach powinieneś mieć narzędzie do instalacji sterowników własnościowych, nie wyszukuje tam czegoś do wifi?

niestety nie mam możliwości połączyć się po kablu, a w ustawieniach pisze, że wszystko aktualne.

A co to za laptop i jaki to moduł Wifi ?

laptop to lenovo g50-30

W tym komputerze jest tragiczna karta WiFi. Możesz spróbować https://github.com/lwfinger/rtlwifi_new może będzie lepiej.

Ewentualnie różne kombinacje z parametrami modulu typu:
options rtl8723be fwlps=0 swlps=0
i inne. Może metodą prób i błędów dobierzesz parametry odpowiednio.

systool -a -m rtl8723be
pokaże Ci listę atrybutów i parametrów. Upewnij się wcześniej, że używasz tego modulu do karty (w tym pomoże lspci).

jestem początkującym użytkownikiem i nie rozumiem większości tego co napisałeś. Możesz jaśniej?

Najpierw sprawdź używając lspci -k jakiego modułu używa Twoja karta. Potem sprawdź systool -a -m NAZWA_MODULU jakie są dostępne parametry, poczytaj o nich, wrzuć w Google, pewnie znajdziesz różne kombinacje, które pomogły innym ludziom z tą beznadziejną kartą. Jeden z nich nawet zamieścilem w poprzednim poście.

dobrze, spróbuję

Piszę teraz z kubuntu. Zaraz po włączeniu wykrzyknik zniknął, ale po uśpieniu i wybudzeniu znowu się pojawił. Dodam, że teraz sieć działa jak powinna tylko ten wykrzyknik dalej się pojawia i sieć ma dalej status “ograniczona łączność”.
Ps. piszę z drugiego konta, bo tamto mi “zaginęło”
PPs. nie użyłem jeszcze tego co proponował @abcdefghjikl

Może to jest po prostu jakiś konflikt IP w sieci lokalnej, a nie wina sterownika? Nie masz w domu skonfigurowanego urządzenia ze stałym IP w zakresie przydzielania przez DHCP? :thinking:

no to wez wklej tutaj wynik polecenia , to dwie sekundy roboty
lspci -k

bo tak to cała Twoja pisanina psu w dupę

00:00.0 Host bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register (rev 0e)
        Subsystem: Lenovo Atom Processor Z36xxx/Z37xxx Series SoC Transaction Register
        Kernel driver in use: iosf_mbi_pci
00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e)
        Subsystem: Lenovo Atom Processor Z36xxx/Z37xxx Series Graphics & Display
        Kernel driver in use: i915
        Kernel modules: i915
00:13.0 SATA controller: Intel Corporation Atom Processor E3800 Series SATA AHCI Controller (rev 0e)
        Subsystem: Lenovo Atom Processor E3800 Series SATA AHCI Controller
        Kernel driver in use: ahci
        Kernel modules: ahci
00:14.0 USB controller: Intel Corporation Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI (rev 0e)
        Subsystem: Lenovo Atom Processor Z36xxx/Z37xxx, Celeron N2000 Series USB xHCI
        Kernel driver in use: xhci_hcd
00:1a.0 Encryption controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine (rev 0e)
        Subsystem: Lenovo Atom Processor Z36xxx/Z37xxx Series Trusted Execution Engine
        Kernel driver in use: mei_txe
        Kernel modules: mei_txe
00:1b.0 Audio device: Intel Corporation Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller (rev 0e)
        Subsystem: Lenovo Atom Processor Z36xxx/Z37xxx Series High Definition Audio Controller
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 1 (rev 0e)
        Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 3 (rev 0e)
        Kernel driver in use: pcieport
00:1c.3 PCI bridge: Intel Corporation Atom Processor E3800 Series PCI Express Root Port 4 (rev 0e)
        Kernel driver in use: pcieport
00:1f.0 ISA bridge: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Power Control Unit (rev 0e)
        Subsystem: Lenovo Atom Processor Z36xxx/Z37xxx Series Power Control Unit
        Kernel driver in use: lpc_ich
        Kernel modules: lpc_ich
00:1f.3 SMBus: Intel Corporation Atom Processor E3800 Series SMBus Controller (rev 0e)
        Subsystem: Lenovo Atom Processor E3800 Series SMBus Controller
        Kernel driver in use: i801_smbus
        Kernel modules: i2c_i801
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
        Subsystem: Lenovo Z50-75
        Kernel driver in use: rtl8723be
        Kernel modules: rtl8723be
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
        Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
        Kernel driver in use: r8169
        Kernel modules: r8169

Jeszcze mogę wkleić wjynik polecenia systool
Attributes:
coresize
initsize
initstate
refcnt
srcversion
taint
uevent

  Parameters:
    ant_sel             
    aspm                
    debug_level         
    debug_mask          
    disable_watchdog    
    fwlps               
    ips                 
    msi                 
    swenc               
    swlps               

  Sections:


Karty na tym module to jeden wieczny problem.

Ponoć Twój problem nie występuje na nowszych kernelach, więc sugerowałbym zainstalować HWE zanim zaczniesz zabawę z parametrami modułu:
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

Czasami najlepszym rozwiązaniem jest zakup na alledrogo działającej karty intela za 2 dychy niż boksowanie się z hujowym firmware bo taki udostępnił producent sprzętu albo ktoś sobie sam napisał z użyciem inżynierii wstecznej :slight_smile:

Autor wspomniał, że na zwykłym Ubuntu wszystko działa prawidłowo. To jest bardzo dziwne, bo KUbuntu powinno mieć te same moduły.

Zawsze można zainstalować Ubuntu i doinstalować w nim KDE Plasma :wink:

Po filmie od @anon11285977 wykrzyknik zniknął, ale sieć wogóle przestała działać. Po ponownym połączeniu wykrzyknik znowu się pojawił. Chyba zainstaluję debiana z KDE lub zwykłe ubuntu tak jak mówi @pocolog

Debiana nie polecam początkującym. Jak chcesz proste i stabilne distro z KDE to wypróbuj Neona
https://neon.kde.org/

ale nie sądzę żeby pomogło :wink: