Przesyłanie dźwięku po AirPlay z Ubuntu 16.04 do amplitunera


(blumberplumber) #1

Witam!
Mam - obok Windowsa 10 - zainstalowanego Ubuntu 16.04. Chciałbym przesyłać dźwięk z tego systemu do amplitunera z wykorzystaniem systemu AirPlay. Na Windowsie do tego celu wykorzystuję programik TuneBlade i spisuje się bardzo dobrze. Niestety wersji tego programu na Linuksa nie ma - bynajmniej,niej nie znalazłem. Może znacie sposób na streamming audio po AirPlay z Pingwina?
Czytałem w Sieci, że podobno AirPlay nie działa na PulseAudio, lecz nie do końca wiem o co w tym chodzi. Jest sposób na to?
O tym niby niedziałającym AirPlay’u na PulseAudio dowiedziałem się tu:


Tyle, że ja mam Ubuntu 16.04 LTS.
Liczę na szybkie odpowiedzi
Z góry dzięki :slight_smile:


#2


Masz tam też ppa dla ubuntopodobnych :wink:


(blumberplumber) #3

No ok, ale który plik mam pobrać? Otwiera mi się lista plików i nie wuiem co pobrać, a linka do PPA nie widzę.


(saturno) #4

Słabo szukasz.
https://github.com/mikebrady/shairport-sync >> https://launchpad.net/~dantheperson >> https://launchpad.net/~dantheperson/+archive/ubuntu/shairplay-sync


#5

A to to co jest?: https://github.com/mikebrady/shairport-sync#building-and-installing
I zalecam przeczytanie opisu ppa


(blumberplumber) #6

Odświeżam temat
Dodałem repo poleceniem:

sudo add-apt-repository ppa:dantheperson/shairplay-sync

Zaktualizowałem repozytoria poprzez

sudo apt-get update

pobrałem Shairport-sync poleceniem:

sudo apt-get install shairport-sync

i nie wiem co dalej. Jak uruchomić dźwięk z systemu na amplitunerze? Po wpisaniu:

sudo shairport-sync

dostaję coś takiego:

Successful Startup
Could not establish a service on port 5000 – program terminating. Is another instance of Shairport Sync running on this device?

Program o coś pyta, ale nie do końca wiem o co i jak mu odpowiedzieć (co wpisać). Jakieś rady?


#7

Nie startuj go przez sudo! Odpala się samoczynnie przy starcie systemu jako usługa.
Jeżeli został skonfigurowany poprawnie powinien być widoczny na liście urządzeń AirPlay.
I oczywiście, jeśli nic nie blokuje mu portów.

Co do reszty, czytaj najlepiej u źródła:




(blumberplumber) #8

No ok, ale gdzie znajdę w systemie urządzenia AirPlay? w ustawieniach dźwięku nie ma mojego amplitunera.


(WODZU) #9

Jaki to amplituner?


(blumberplumber) #10

YAMAHA R-N402D z systemem MusicCast


(WODZU) #11

Z tego co widzę, obsługuje również DLNA. Próbowałeś transmisji tą drogą? Od razu zaznaczam, że sam nie testowałem takiego rozwiązania na Linuxie, jedynie pod Windows.


(blumberplumber) #12

Tak, wiem, ale AirPlay jest o tyle fajny, że mogę przesyłać audio z całego systemu, przy czym nieistotne jest to, z którego programu dźwięk jest przekazywany, a tak DLNA musi obsługiwać też oprogramowanie, którego używam.


(WODZU) #13

W ostateczności, jeśli nie znajdziesz rozwiązania, pozostaje strumieniowanie przez Bluetooth.


#14

Musi być pod zakładką “sprzęt”, albo “wyjście”. Jeśli nie ma, to coś jest źle skonfigurowane. Albo tak, jak pisał ktoś na git’cie, że mu blokował router. Nie sprawdzę u siebie dokładnie, bo nie mam już niczego ze sprzętu, co by miało support AirPlay.


(blumberplumber) #15

Mam tak:


Nie wiem, jak zrobić screena aktywnego okna, więc zrzuciłem cały pulpit.


(WODZU) #16

Linux z tapetą z Windows? Ślązacy zakrzyknęliby “gańba!” :wink:


(blumberplumber) #17

Taką znalazłem w necie. Co za różnica? a po drugie na dysku mam też Windowsa.


#18

Lewy alt+PrtSc robi zrzut okna.
Nie wiem jak powinien mieć ubu, ale u mnie jest zakładka “sprzęt” i tam się pojawiają przeważnie nowe urządzenia.

Zrzut%20ekranu%20z%202018-02-01%2020-42-42


#19

Coś mi się przypomniało… Można nieco inaczej… Wrzuć sobie paczkę “paprefs”. Jest w reposach systemowych. Odpal to i pokombinuj w okienku z takimi opcjami…

W ostatniej zakładce jest też dodatkowa fajna rzecz…
Opcja umożliwiająca odsłuch dźwięku na wielu urządzeniach jednocześnie. Wystarczy ją włączyć, a w normalnych preferencjach pojawi się opcja pt. "Simultaneous output to…"
Taki bajerek, ale się przydaje :wink:


(blumberplumber) #20

Mam takie urządzenia i nic nie gra :frowning:
Ustawienia ustawiłem tak:


Co jest jeszcvze nie tak? Mój amplituner w sieci zwie się “Daweid MusicCast”.