Ubuntu 14.04: System się uruchamia ale nie chce się zalogować


(Saarkkin) #1

Witam. 


(Amaterasu) #2

Witaj w gronie Użytkowników Ubuntu, niechaj ten system pozostanie z Tobą na dłużej! :smiley:

Ups, nie przeczytałam zbytnio tego. Zatem proszę Cię, uruchom pendrive’a z Ubuntu oraz zamontuj partycje:

mount /dev/sda[numer partycji systemowej] /mnt

mount /dev/sda[numer partycji na pliki użytkownika] /mnt/home

chroot /mnt

Ta komenda powyżej pozwala na wejście do systemu za pomocą konta administratorskiego. Nie wiem, czy działa na Ubuntu.

Postaram się wszystko wyjaśnić tak, żebyś zdołał mnie zrozumieć, a to mi niezbyt dobrze idzie - ludzie uznają mnie za magika. Ale do rzeczy! Moją prośbą jest to, żebyś nie bez powodu wklepywał te komendy do Terminala, albowiem nie na tym sztuka polega.

sudo

Jest to program, który służy do wykonywania akcji zarezerwowanych dla administratora systemu (nazywanego “rootem”). Dzięki temu będziesz mógł wypożyczyć jego prawa, umożliwiając tym razem działanie komend. Pamiętaj, by za każdym razem dawać jego nazwę przed poleceniem. W celu skorzystania, musisz podać swoje hasło. Na chroot nie musisz.

Więc… Zaczynamy! :slight_smile:

LDM to jest menedżer wyświetlania, chociaż wielu skrytykowało mnie za tę nazwę. Pozwala on na graficzne zarządzanie systemem. Jeżeli sprawia on kłopoty, należy się go pozbyć, to chyba najrozsądniejszy wybór. Tak oto wklep to Terminala taką komendę:

systemctl disable ldm.service

Systemctl zarządza systemem, więc disable oznacza “dezaktywowanie”. “ldm.service” służy od LightDM, tym oto sposobem usuwamy go z listy autostartu. Zalecam nie resetować w tym czasie komputera.

apt-get install gdm

Tym poleceniem zainstalujesz inny menedżer wyświetlania dla GNOME, jednak on bez problemu zadziała na Ubuntu. GDM to pakiet, install to instalacja apt-get to menedżer pakietów.

systemctl enable gdm.service

Tym sposobem aktywujesz GDM podczas uruchamiania systemu. Enable to po prostu odwrotność od disable, czyli aktywowanie. Po tych zabiegach możesz zresetować komputer, jednak zawita Cię inny wygląd logowania.

Pozdrowionka, Neukrate :).


(I727853) #3

Przeczytaj :wink:

https://forum.parallels.com/threads/ubuntu-14-04-no-gui-after-login.301083/

http://linux.ittoolbox.com/groups/technical-functional/linuxadmin-l/start-desktop-gui-from-command-line-in-ubuntu-1404-5529401

http://superuser.com/questions/747375/lightdm-not-starting-at-boot-in-ubuntu-14-04


(sir_lucjan) #4

Zamiast GDM polecam LXDM. Lekki i bezproblemowy. 


(Amaterasu) #5

No to na LXDM wklepuje się takie komendy:

apt-get lxdm

A autostart to to:

systemctl enable lxdm

(Suami777) #6

 

warto by jeszcze dbać o porządek w systemie czyi:

 

systemctl disable gdm

apt-get purge gdm


(Saarkkin) #7

Dziękuję za pomoc

 


(Amaterasu) #8

Przechodzisz do pulpitu oraz wyszukujesz aplikacji “Terminal” (na LiveCD). Jeżeliby się dało, podaj wynik tego polecenia:

fdisk -l

Powyższa komenda sprawdza partycje na dysku twardym oraz podaje informacje o ich typie, dostępnym miejscu, flagach (rozruch) itd.


(Saarkkin) #9

@Neukrate dzięki za chęci, tylko nie mogę się zalogować przez live cd. Każe podać login i hasło, próbowałem się zalogować danymi z zainstalowanego linuxa jednak bez rezultatów.


(nintyfan) #10

login: livecd

hasło: puste

 

login: root

hasło puste

 

Spróbuj powyższych.


(Saarkkin) #11

Wpisałem 

Login: Ubuntu 
Hasło:

Już nie pokazuje, że nie poprawne. tylko tak jakby chciał się zalogować ale nie może …  Ciągle wraca do okna logowania…


(Amaterasu) #12

Litery (a raczej ich wielkość) tutaj mają znaczenie :):

Login: ubuntu
Hasło:

Wiem, bo sprawdzałam, wybierając podczas logowania opcję wejścia na konto użytkownika, którego nie ma na liście. Wpisując “Root” i prawidłowe hasło, pojawiał się błąd uwierzytelnienia, ale jak już z małą literką, wszystko dobrze szło ;).


(Saarkkin) #13

No tak wpisałem, musiało mi się pomylić przy pisaniu posta ;). Jednak nadal nie mogę się zalogować nawet przez live cd :(.


(pocolog) #14

Od kiedy wersja live jakiegoś systemu wymaga zalogowania użytkownika? Z jakiej okazji prosi cię o ten login w którym miejscu?


(MacGregor) #15

To pewnie jakiś błąd uprawnień/uszkodzenie obrazu live cd.


(Suami777) #16

Jest ich trochę ale na ogół login jest nazwa distro a hasło puste

 

@Oazuk

Jeżeli chcesz go zainstalować to nie powinieneś musieć się logować tylko wybrać opcje instalowania i automatycznie powinno cię tam prowadzić dalej, na pewno dobre iso ?


(Saarkkin) #17

Z jakiej okazji ? Tego nie wiem :wink:

 

Możliwe, tylko pobierałem tą wersję dwa razy. Pierwsze co zrobiłem to chciałem uruchomić jako live cd ale musiałem się zalogować.

 

Tylko ja mam już zainstalowanego, tylko nie mogę się do niego zalogować. Przez płytę jak i z dysku nie mogę się zalogować  :(.


(Amaterasu) #18

Sprawdzałam na VirtualBox’ie, mogę normalnie wejść do systemu. Może warto skorzystać (do instalacji LXDM bądź GDM oraz dodania wpisu do autostartu) Linux Minta bądź dowolne *buntu?


(Saarkkin) #19

Mam zamiar zainstalować debian 8.1.0, tylko musi trochę to poczekać. 


(Amaterasu) #20

Myślę, że to nie przez to. Ale Debian jest stabilny, on nie powinien powodować problemów.