Ubuntu 20.04 wolno się uruchamia na laptopie

Witam mam problem. Zainstalowałem najnowszego ubuntu i się długo włącza. Co mogę zrobić żeby uruchamiał się szybciej? Proszę o jakieś rady.

Parametry lapka HP 255 G6
AMD® A6-9220 radeon r4, 5 compute cores 2c+3g × 2
4GB RAM
Grafika AMD® Stoney
Dysk 1TB HDD

Proszę o jakieś rady

systemd :slight_smile: kocham go nienawidzić :slight_smile: zawsze czeka 1,5 min zanim oleje martwą usługę :slight_smile:
Bez jurnala ciężko stwierdzić co wisi, obstawiam sieć, albo grafikę, albo sieć… albo cokolwiek może być :stuck_out_tongue:

Pomożesz jakoś, co mam zrobić ? Jestem świeży jeśli chodzi o robienie czegoś na ubuntu :sweat_smile:

Nie! umię tylko krzyczeć :smiley:
@Domker @marcin82 :wink:
btw.
od siebie polecam Gentoo! :smiley:

systemd-analyze blame

czyli?

czekaj :wink:

Dzięki

Czy instalowałeś Ubuntu 20.04 z głównym środowiskiem graficznym, czyli Gnome? (wygląda jak w tym artykule). Jeśli tak to może pomóc zmiana środowiska graficznego (albo doinstalowanie albo instalacja edycji Xubuntu).

Uruchom terminal/konsolę wklej wynik polecenia, o którym pisał @gom1.

3min 47.951s apt-daily-upgrade.service
35.938s plymouth-quit-wait.service
33.800s man-db.service
26.787s snapd.service
23.159s networkd-dispatcher.service
19.225s udisks2.service
16.411s NetworkManager-wait-online.service
15.042s dev-sda2.device
11.227s NetworkManager.service
10.556s ModemManager.service
9.378s dev-loop9.device
9.045s accounts-daemon.service
7.878s dev-loop10.device
7.760s dev-loop11.device
7.704s dev-loop13.device
7.544s dev-loop8.device
7.503s dev-loop12.device
7.462s systemd-journal-flush.service
7.178s dev-loop5.device
6.971s dev-loop2.device
6.971s dev-loop1.device
6.969s dev-loop0.device
6.967s dev-loop6.device
6.711s polkit.service
6.139s avahi-daemon.service
6.131s bluetooth.service
6.118s dev-loop7.device
6.007s dev-loop3.device
5.957s dev-loop4.device
5.662s switcheroo-control.service
5.401s thermald.service
5.393s systemd-logind.service
5.375s wpa_supplicant.service
4.130s gdm.service
4.129s systemd-udevd.service
3.552s user@1000.service
3.423s secureboot-db.service
2.741s apport.service
2.706s e2scrub_reap.service
2.687s logrotate.service
2.663s rsyslog.service
2.639s gpu-manager.service
2.609s grub-common.service
2.566s preload.service
2.458s apparmor.service
2.245s systemd-sysctl.service
2.174s grub-initrd-fallback.service
2.040s systemd-resolved.service
1.517s snap-canonical\x2dlivepatch-95.mount
1.446s snapd.apparmor.service
1.341s snap-chromium-1229.mount
1.219s snap-core-9665.mount
1.203s fstrim.service
1.194s systemd-tmpfiles-setup.service
1.036s systemd-modules-load.service
1.031s snap-core18-1705.mount
976ms snap-core18-1880.mount
874ms upower.service
870ms systemd-rfkill.service
865ms snap-gnome\x2d3\x2d28\x2d1804-128.mount
852ms systemd-user-sessions.service
834ms plymouth-start.service
830ms systemd-timesyncd.service
829ms systemd-random-seed.service
755ms snap-gnome\x2d3\x2d34\x2d1804-24.mount
734ms systemd-sysusers.service
665ms systemd-journald.service
647ms swapfile.swap
637ms pppd-dns.service
593ms systemd-tmpfiles-setup-dev.service
578ms snap-gnome\x2d3\x2d34\x2d1804-36.mount
522ms snap-gtk\x2dcommon\x2dthemes-1506.mount
519ms snapd.seeded.service
496ms openvpn.service
479ms fwupd.service
473ms keyboard-setup.service
471ms modprobe@drm.service
402ms systemd-udev-trigger.service
367ms snap-mc\x2dinstaller-499.mount
325ms systemd-fsck@dev-disk-by\x2duuid-0F8B\x2d5677.service
317ms ufw.service
312ms snap-snap\x2dstore-433.mount
257ms snap-snap\x2dstore-467.mount
257ms console-setup.service
251ms colord.service
245ms fwupd-refresh.service
213ms kerneloops.service
170ms dev-hugepages.mount
169ms dev-mqueue.mount
167ms sys-kernel-debug.mount
166ms sys-kernel-tracing.mount
161ms kmod-static-nodes.service
159ms geoclue.service
141ms plymouth-read-write.service
129ms systemd-remount-fs.service
125ms boot-efi.mount
123ms snap-snapd-7264.mount
120ms systemd-backlight@backlight:amdgpu_bl0.service
107ms setvtrgb.service
82ms snap-snapd-8542.mount
66ms systemd-update-utmp.service
54ms user-runtime-dir@1000.service
24ms systemd-tmpfiles-clean.service
17ms alsa-restore.service
15ms systemd-update-utmp-runlevel.service
15ms systemd-backlight@backlight:acpi_video0.service
12ms rtkit-daemon.service
7ms sys-kernel-config.mount
5ms sys-fs-fuse-connections.mount
1ms snapd.socket

Na moje oko, w uj wolny dysk :wink: Wszystko cacy :slight_smile:

Tylko to co? :open_mouth:
apt-daily-upgrade.service

Wywalić z systemd, systemctl disable apt-daily-pgrade i jesteśmy w domu :smiley:
Aktualizował będziesz się sam :smiley:

Dobrze mówię? Czy jestem wstawiony? :smiley:

jak mam to zrobić ?

Cierpliwości :wink: Ja tutaj tylko pajacuję :slight_smile: @marcin82 jest mózgiem :wink:

Okej :joy:

@pocolog Odpowiedzi udzieliliśmy w wiadomości prywatnej :stuck_out_tongue_winking_eye:

@djnarotis

Pokaż w ogóle co ta usługa robi, czy to tylko zbiera info o aktualizacjach czy pcha z automatu instalację:

systemctl cat apt-daily-upgrade.service

[Poprawka niżej] Jeśli chodzi o wyłączenie usługi to prędzej tak:

sudo systemctl disable --now apt-daily-upgrade.service

Przypuszczam jednak, że niezbyt wiele to zmieni, jeśli tylko odświeża indeksy i wyświetla info o pakietach do aktualizacji.

System może działać ociężale przy takim procesorze i 4GB pamięci RAM. Może pomóc instalacja Ubuntu ze środowiskiem graficznym Xfce. Jeśli dopiero zaczynasz szarpaninę przygodę z Ubuntu to lepiej będzie dla ciebie zainstalować Xubuntu “na czysto”.

No racja, bo nawet jeśli ta usługa wisi, to nie bez powodu, coś to powoduje :wink: Ja obstawiam problemy z połaczeniem internetowym… Jak mnie wpieniało zawsze, że wisiały inne rzeczy jak net nie wstał :stuck_out_tongue_winking_eye:
W sumie fajna sprawa te priorytety, ale żeby systemd ukrywa wszystkie komunikaty :stuck_out_tongue_winking_eye:

/lib/systemd/system/apt-daily-upgrade.service

[Unit]
Description=Daily apt upgrade and clean activities
Documentation=man:apt(8)
ConditionACPower=true
After=apt-daily.service network.target network-online.target systemd-networkd.s>

[Service]
Type=oneshot
ExecStartPre=-/usr/lib/apt/apt-helper wait-online
ExecStart=/usr/lib/apt/apt.systemd.daily install
KillMode=process
TimeoutStopSec=900

Podziwiam twoją wiedzę, ale nie zgadzam się z tym… Jemu wisi, zanim GUI wstanie…

Poprawka, tej usłudze towarzyszy tzw. timer (wtedy usługa ma ustawiony typ ‘static’. Jeśli chcesz wyłączyć to w ten sposób:

sudo systemctl disable apt-daily.timer apt-daily-upgrade.timer

Tu jest to omówione przy okazji innego problemu, ale nie stosuj innych zaklęć z tego artykułu (też widać, że sudo trole zeżarły):
https://saveriomiroddi.github.io/Handling-the-apt-lock-on-ubuntu-server-installations/ .

Po restarcie komputera sprawdź czy cokolwiek się zmieniło, możesz podać wynik:

systemd-analyze blame

W jaki sposób łączysz się z internetem (po kablu/ wifi - jaka prędkość w umowy z operatorem?)

wifi. 50Mbit/s 5Mbit/s