Uruchomienie przeglądarki chrome jako administrator


(izok1980) #1

Witam chciałbym się dowiedzieć w jaki sposób mogę uruchomić przeglądarkę google chrome jako administrator w systemie pc linux os 2013 ponieważ pomimo tego że jest ustawiona jako domyślna ciągle wyświetla się monit czy ustawić ja jako domyślną.Gdy wchodzę w ustawienia przeglądarki nie mogę po prostu tego kliknąć jest jakby nieaktywne.Miałem już taki przypadek w jakimś linuxie z kategorii ubuntu,ale była taka opcja uruchom jako administrator a w PC linux os nie ma.

 

Dzięki pozdrawiam.


(roobal) #2

Możesz albo uruchomić z terminalu jako root lub z użyciem sudo, albo przy pomocy Gksu (Gnome)/Kdesu (KDE), jeśli masz zainstalowane w systemie.


(izok1980) #3

Mam KDE ale nie wiem nadal jak uruchomić google chrome jako administrator odpalam konsole wpisuje Kdesu chrome i nie ma takiego polecenia.


(MrQ) #4

kdesudo


(izok1980) #5

nie znaleziono polecenia


(MrQ) #6

w takim razie

su <enter>

i

google-chrome <enter>

(izok1980) #7

dziękuję za pomoc ale po wpisaniu tego do terminala wywala coś takiego :Przeglądarki Google Chrome nie możesz uruchamiać jako użytkownik root. Uruchom aplikację Google Chrome jako zwykły użytkownik. Uruchamianie jako użytkownik root wymaga podania alternatywnego katalogu --user-data-dir do przechowywania danych profilu.


(Soren) #8

Sprawdź czy jest możliwa do zainstalowania paczka o nazwie kdesu


(MrQ) #9

 

Kdesu da ten sam efekt co su. Jak sam komunikat głosi, żeby odpalić chrome jako root trzeba podać alternatywny katalog. Nawet jest podany argument jakiego trzeba użyć.


(izok1980) #10

Nie jestem jakimś zaawansowanym linux użytkownikiem dlatego szukam pomocy tutaj dużo rzeczy jeszcze nie wiem znam tylko podstawowe rzeczy jak instalacja samego systemu czy programow wcześniej nie miałem z tym problemu tylko na PC linux os który przypadł mi do gustu. 


(MrQ) #11
su <enter>

google-chrome --user-data-dir=/home/nazwauzytkownika/jakistamkatalogznowymprofilem <enter>

(izok1980) #12

Wszystko fajnie  tylko co wpisać w miejsce "jakistamkatalogznowymprofilem"


(MrQ) #13

 

Załóż sobie jakiś folder w katalogu domowym i go podaj w tym poleceniu.


(izok1980) #14

Ok jutro spróbuję


(roobal) #15

Byłoby łatwiej jakbyś napisał, jaki masz system. Jeśli w systemie korzystasz z sudo, to zainstaluj Kdesudo i użyj kdesudo zamiast Kdesu. Kdesu pyta Cię o hasło roota, Kdesudo pyta o hasło użytkownika uprawnienionego do wykonania polecenia z uprawnianiami roota.


(izok1980) #16

Roobal pisałem Pc linux Os 2013

Ok zrobiłem tak jak MrQ podpowiedział przeglądarka się otworzyła lecz w jej ustawieniach "ustaw google chrome jako domyślną przeglądarkę" wyświetliło się to :Google Chrome nie może określić lub ustawić przeglądarki domyślnej.

Na razie jedynym sposobem jej ustawienia jako domyślnej jest wejście do ustawień systemowych i wybrać chrome w "programy domyślne".Ale pojawiają się komunikaty po otworzeniu przeglądarki ustawić jako domyślną i nie pytaj ponownie.


Na przyszłość użyj opcji edytuj, zamiast pisać post pod postem.

roobal


(marcin82) #17

Jakie masz środowisko graficzne - które wydanie?

 

Tutaj byłeś?

przegl_darka.jpg

 

Gdyby to ustawienie nie działało, podepniemy to jako alternatywę pod:

/usr/bin/www-browser

#18

To i tak nic by nie dało, bo jeżeli ustawisz ją jako domyślną na koncie administratora, to na tamtym koncie będzie domyślną, a nie dla wszystkich userów.


(izok1980) #19

marcin'82 tak tu byłem i własnie takim sposobem ustawiałem bo inaczej się nie da... środowisko graficzne KDE 4.11.3 wersja systemu operacyjnego linux3.4.64-pclos1

 

Areh ma chyba rację bo gdy otworzyła się przeglądarka sposobem MrQ to nie miałem zakładek ani adbloka czyli jakby po czystej instalacji chrome


(marcin82) #20

No to w końcu Google Chrome jest jako domyślna przeglądarka czy nie?

 

Może nie być to zaznaczone w samej przeglądarce, ale obowiązaują ustawienia z "System Settings" KDE.