Vista nie robi punktów przywracania systemu


(adaś99) #1

Witam! Mam w laptopie Vistę Home Basic, która od dłuższego już czasu (kilka miesięcy) nie robi punktów przywracania systemu. Co więcej, kasuje również po kilku dniach ręcznie zrobione punkty. A ponieważ trudno stale kontrolować tę rzecz, zdarza się, że system jest niezabezpieczony żadnymi punktami. Czy ktoś orientuje się, w jaki sposób przywrócić ustawienia automatyczne, tzn. żeby Vista sama codziennie robiła punkt przywracania systemu i kasowała tylko najstarsze, tak żeby zawsze przynajmniej 1-2 były? Szukałem po ustawieniach w systemie, zajrzałem do pomocy w komputerze, ale nigdzie nie znalazłem jakichś sposobów zmiany tej rzeczy.


(Marcin1025) #2

Możliwe też z jednej strony że masz wirusy daj logi OTL,włącz punkty przywracania są do włączenia w opcjach systemu.


(adaś99) #3

Marcin1025, wirusów żadnych nie powinno być, bowiem komputer był wiele razy skanowany różnymi programami (Malwarebytes, Avast). Punkty przywracania cały czas mam włączone ("zaptaszkowane" przy dysku C - systemowym), a jednak mimo to nie działają. Uzupełniając to, co napisałem w poprzednim poście, system automatycznie robi punkty przy instalacji lub deinstalacji programów, ale okresowo bez żadnej przyczyny już nie.


(Dimatheus) #4

Hej,

:arrow: A jaka przestrzeń zarezerwowana jest na przywracanie systemu?

:arrow: Ile wolnego miejsca jest na partycji C?

Pozdrawiam,

Dimatheus


(Atis) #5

Usługa Harmonogram zadań ma ustawiony tryb uruchamiania na automatyczny?

Ustawić można w ten sposób:

http://www.vistax64.com/tutorials/16952 ... edule.html


(adaś99) #6

Więc tak:

Ad. 1:

  • Używana przestrzeń magazynu kopii w tle: 1.592 GB

  • Przydzielona przestrzeń magazynu kopii w tle: 1.801 GB

  • Maksymalna przestrzeń magazynu kopii w tle: 2 GB

Maksymalna przestrzeń była zwiększana przeze mnie do obecnej wartości, gdyż też myślałem, że tu może leżeć przyczyna.

Ad. 2. Wolne miejsce na partycji C waha się od ok. 2 do ok. 5 GB (w różnych okresach).

-- Dodane 19.03.2012 (Pn) 1:51 --

@Atis: Jest ustawiona na automatyczną (dwa wyzwalacze: codziennie o godz. 00:00 oraz przy każdorazowym uruchomieniu systemu).


(Łukash) #7

Kliknij na zakładkę Historia > pod kolumną Poziom "powinien być" opis z jakiego powodu zadanie nie zostało uruchomione w przypadku błędu i gdy zadanie funkcjonuje właściwie.

Czy to kasowane nie ma związku z defragmentacją plików ? czy w tle nie działa jakiś program do defragmentacji ?

Nie za mało ? Oczyszczałeś system po instalacji SP1 i SP2 ?

Czyli widzisz punkty przywracania po wydaniu komendy: vssadmin list shadowstorage ?


(adaś99) #8

Ja w tej kolumnie mam przy każdym zdarzeniu napis "Informacje" i nic więcej. Po dwukliku na danym zdarzeniu (wierszu) wyświetlają się właściwości tego zdarzenia - tam są m.in. informacje o powodach jego uruchomienia, ale nie ma nic o niezakończeniu czy przyczynach błędu. Nie mam pojęcia, gdzie szukać informacji, o których piszesz.

Ja niczego nie uruchamiam. Być może sam system coś włącza w tle automatycznie (ale jeśli tak, to chyba powinno być tak ustawione, żeby nie kasował punktów?).

Hm, też chciałbym wiedzieć, czy nie za mało. Mam zainstalowany tylko SP1, niczego nie oczyszczałem poza standardowym oczyszczaniem co jakiś czas narzędziem systemowym oraz CCleanerem.

Są tylko informacje o przestrzeni magazynu kopii w tle (które podałem powyżej). Żadnych innych informacji po wpisaniu tej komendy nie ma.


(Łukash) #9

Czyli zadanie ponoć startuje ,jeżeli nie ma błędu to potencjalnie "powinno" być ok. Wyeksportuj spod prawego myszki dane zadania - zawartość SR.xml wklej tu i daj linka

Wyłącz systemowy defragmentator i poobserwuj sytuacje, odptaszkuj zadanie - zrób punkt itd. Większość programów do defragmentacji nie radzi sobie z woluminami kopii w tym również i systemowy , po ich działaniu właśnie (co dziwne bo nie u każdego) zostają usunięte punkty klik

Warto zainstalować SP2 :wink: Co do oczyszczania dysku ,to jeżeli SP nie był zintegrowany z systemem ,i doinstalowałeś go to w wierszu polecenia uruchomionym jako admin wpisz :

vsp1cln.exe [ENTER] [klik](http://technet.microsoft.com/en-us/library/cc709655(v=ws.10).aspx)

Podaj zrzut z okna po ww komendzie .

Nie masz czasem zainstalowanewgo innego systemu np XP ? klik


(adaś99) #10

http://wklej.org/id/712997/

Pobawię się w ten sposób, ale żeby to sprawdzić, potrzeba kilku dni. Dziwi mnie to, bo wcześniej nie usuwał (a na pewno też działał, bo nic nie grzebałem w defragmentatorze), więc tak na logikę nie powinien być przyczyną problemu.

Nie wiem, czy był, po prostu musiał zainstalować się przy okazji automatycznych aktualizacji systemu. Później wyłączyłem automatyczną aktualizację, bo za bardzo zamulało mi system podczas sprawdzania dostępności aktualizacji.

Nie, mam tylko ten jeden.


(Łukash) #11

Możesz podać jeszcze wynik: vssadmin list shadows - najlepiej z momentu w którym "zniknęły punkty"

Zatem możesz klepnąć : vsp1cln.exe ,jak SP był zintegrowany to nic się nie stanie ,jak instalowałeś - odzyskasz trochę miejsca.

Defragmentator to tylko jeden z podejrzanych (i dobrze by było gdyby to on był winny :wink: ) To nic ,że nie grzebałeś ,mi np znowu defragmentacja usuwa punkty ...coś się chrzani - nie wiadomo co i kiedy...

Tu jest wszystko ok.

Profilaktycznie sprawdź również stan uruchomiania usług (na pewno będzie dobrze ,bo możesz tworzyć punkty) :

1.Dostawca kopiowania w tle oprogramowania firmy Microsoft [Ręczny]

2.Kopiowanie woluminów w tle [Ręczny]


(adaś99) #12

Nie mam pojęcia, jak wyświetlić te dane z momentu, w którym zniknęły punkty, tym bardziej, że nie wiem, kiedy zniknęły.

Klepnąłem. Coś tam oczyściło, choć nie zauważyłem na C jakiegoś gwałtownego wzrostu ilości wolnego miejsca.

Obie mają typ uruchomienia ręczny.


(Łukash) #13

adaś99 , daj znać po obserwacji.

Jest OK - podejrzewałem jakąś paranienormalną rozbieżność ,ale ID się zgadza.

Chyba nie ma potrzeby aby "polować" . Miałem na myśli to ,że w trakcie "nieistnienia" punktu ,ten będzie widoczny dzięki pomocy wiersza poleceń ,ale raczej tak nie będzie.

Czasem jest to nawet 4GB z odzysku.

OK


(adaś99) #14

Czyli rozumiem, że wszystko jest OK, a jedynym podejrzanym, jaki pozostał, jest defragmentator? W takim razie poobserwuję go przez kilka dni. Jak zrozumiałem, może on kasować punkty przywracania, ale czy może być też odpowiedzialny za brak ich automatycznego tworzenia? Co zrobić, gdyby okazało się, że defragmentator jest przyczyną problemu?


(Łukash) #15

Z tym tworzeniem to też rożnie bywa ,jak wypowie się więcej osób to będziemy mieć jaśniejszą sytuacje - np u mnie nie tworzą się punkty po uruchomieniu systemu ,oraz o 00:00 jak to stoi w "wyzwalaczach" - u mnie tworzą sie punkty przed instalacja > po instalacją softu > oraz okresowo - tak zwane zaplanowane punkty (<-nie wiem według jakich reguł :smiley: )

Jest średnio OK :wink: .Moim zdaniem ,za usuwaniem punktów stoi defragmentator.

Defragmentować na żądanie i po tym tworzyć punkt ręcznie . Pomimo pseudo zgodności (testowałem naprawdę sporo - polecam Puran Defrag free) ,przeróżnych programów do defragmentacji ,z woluminami kopii ,te i tak usuwają punkty. Lekarstwem ponoć jest 16-KB lub większy rozmiar klastra w systemie plików (domyślnie jest 4 KB =D> - fsutil fsinfo ntfsinfo C: )


(adaś99) #16

No cóż, sprawdzę defragmentator i dam znać na forum za kilka dni. Zauważyłem, że u mnie - dokładnie tak jak u Ciebie - też tworzą się automatycznie tylko punkty przy instalacji programów (obecnie nie jestem w stanie powiedzieć, czy przed, czy po instalacji, gdyż nie zwróciłem na to uwagi) oraz zaplanowane punkty kontrolne (też nie wiem, wg jakich reguł - zaczęły pojawiać się dopiero niedawno). W każdym razie dzięki za poświęcony czas :slight_smile: . Nie wiem, czy ktoś jeszcze się wypowie, ale wszelkie sugestie co do ewentualnych przyczyn problemu będą przeze mnie mile widziane, a wręcz pożądane :slight_smile:


(Dimatheus) #17

Hej,

A zajrzyj do rejestru do gałęzi HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore i klucza o nazwie RPGlobalInterval, który definiuje, z jakim odstępem mają być tworzone automatyczne punkty przywracania systemu. Jaką masz wartość z powyższym kluczu?

Pozdrawiam,

Dimatheus


(adaś99) #18

Dimatheus, dla tego klucza mam:

Typ: REG_DWORD

Dane: 0x00015180 (86400)


(Dimatheus) #19

Hej,

Niestety i to ustawienie jest poprawne - definiuje oni, że punkty powinny być tworzone co 24 godziny.

:arrow: Próbowałeś wymusić utworzenie punktu przywracania? Być może kolejne utworzenie 1, 2 czy 3 punktów aktywuje możliwość automatycznego tworzenia punktów przywracania.

Co ciekawe system Windows 7 tworzy automatyczne punkty kontrolne dość rzadko. Na tym systemie w obecnej chwili mam tylko jeden punkt przywracania - poprzednich też nie usuwałem.

Pozdrawiam,

Dimatheus


(adaś99) #20

Co jakiś czas ręcznie robię punkty przywracania. Niestety, to niczego nie zmienia w kwestii automatycznego tworzenia punktów.

Być może rację ma Łukash, że za problemem stoi defragmentator. Objawy, z tego co się zdążyłem zorientować, są u mnie takie same, jak u niego.