Windows Update i Windows Defender przestały działać

Kilka godzin temu laptop pobrał sobie jakieś aktualizacje. Nie pamiętam ich numerów KB, ale w każdym razie jedna z ich to była jakaś paczka update’ów druga aktualizacja do Windows Defender. Po instalacji i ponownym uruchomieniu laptopa okazało się, że Windows Defender jakby znikł z systemu, nie uruchamia się, na próżno szukać go też po wpisaniu services.msc.

Nie działa także Windows Update, próbowałem zatrzymywać usługi, zmieniać nazwy katalogów z użyciem wiersza poleceń uruchomionego jako admin, ale nic to nie dało. WU ciągle zgłasza błąd 0x80080005 a wcześniej 0x80070424. Dodatkowo przy próbie uruchomienia go przez services.msc pojawia się komunikat jak na screenie

Wspomnianych wyżej update’ów ostatecznie nie udało się zainstalować. Zmiany zostały wycofane przez system i tak jak pisałem Windows Defender znikł, WU się zepsuło i co ciekawe, po ponownym uruchomieniu kompa wywaliło też antywirusa, którym był 360 Total Security. Obecnie zainstalowałem BitDefendera i wykonałem skan, co znalazło, usunąłem, więc jakieś wirusy są mało prawdopodobne, bo Laptop Lenovo G510, działa normalnie, bez lagów.

Tak wygląda strona, na której przedtem były informacje z Windows Defendera.

Nie mam pomysłu, co jeszcze podać, by ułatwiło to rozwiązanie problemu.

System oczywiście Windows 10.
Wersja 1903
Kompilacja 18362.239

A) reinstall
B) przywracanie systemu
EDIT: Ja bym się cieszył, że windows update wysiadł

Zaiste Milordzie, bardzo zacna porada, na którą w życiu bym nie wpadł…

A tak naprawdę to obu podanych przez Ciebie @anon57060744 rozwiązań chciałbym uniknąć.

Wejdz w Aktualizacje i zabezpieczenia -----> Rozwiazywanie problemów ----> Windows Update, kliknij
Postępuj zgodnie z poleceniami.
Jak to nie pomoże to w wierszu poleceń (administrator) wykonaj kolejno po sobie polecenia.

DISM.exe /Online /Cleanup-image /Restorehealth

sfc /scannow

P.S. Masz antywirusa więc windowsowy sie wyłączył

Tutaj nie do końca się zgodzę. Do dziś, choć antywirus był, ikona Windows Defendera z zielonym znaczkiem była widoczna w zasobniku. Dziś zniknęła i jej nie ma. Uprzedzając dociekanie - mam włączone, by w zasobniku pokazywało wszystkie ikony.

To może coś w autostarcie się popsuło?

Przecież widać, że w usługach WU nie można w ogóle włączyć, z powodu braku pliku (drugi screen w pierwszym poście). Windows Defendera w ogóle nie ma wśród usług w aplecie services.msc :frowning:

Wykonane.

Pierwsze polecenie zakończyło się sukcesem. Drugie nie znalazło problemów. Niestety, po ponownym uruchomieniu nadal brak Windows Defendera, a WU także nie działa…

Dysk sprawny, nie kona na tyle by zgłupiało DISM / SFC?

Dysk praktycznie nowy. Systemowy wymieniony nie dalej jak trzy tygodnie temu na SSD. Patriot Burst 240GB.

Screen S.M.A.R.T z SSD-Z poniżej:

Może tylko uszkodzenie w rejestrze, chociaż piszesz że ci pliki defendera nie istnieją i systemowe narzędzia ich z kopii nie przywracają?


Service Display Name Service Name Status Startup Type
Windows Defender Advanced Threat Protection Service Sense Manual
Windows Defender Antivirus Network Inspection Service WdNisSvc Running Manual
Windows Defender Antivirus Service WinDefend Running Automatic
Windows Defender Firewall MpsSvc Running Automatic
Windows Defender Security Center Service SecurityHealthService Running Automatic

Stan usług niby aktualizowany w lutym 2019, widać majowa aktualizacja nie dodała jakiś nowych?

Powiem szczerze, że jeszcze została deska ratunku, ostatnia w postaci Przywracania Systemu. Dziś jednak nie mam na nią czasu, może jutro, lub po weekendzie, bo zapowiada się dużo pracy, a laptop potrzebny…

Tych usług z Twojego screena nawet nie mam “fizycznie” w services.msc…

1lajk

A ja mam problem z Windows Defender Firewall (sam Windows Defender działa)

Poniżej “filmik” w którym widać że narzędzie WindowsFirewall.diagcab nie poradziło sobie z naprawą.
W prawym okienku można zobaczyć że usługa jest uruchamiana non-stop ale natychmiast się wyłącza.

dism i sfc: